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Contacting Telestream
To obtain product information, technical support, or provide comments on this guide, 
contact us using our web site, email, or phone number as listed below.

Resource Contact Information

Wirecast Technical 
Support

Support Website: http://www.telestream.net/telestream-
support/wire-cast/support.htm

Support Email: support@telestream.net

Enterprise Telephone Support: 

U. S. Toll Free: (877) 257-6245

U. S. from outside U.S.: (530) 470-2036

Europe | Middle East | Africa | Asia | Pacific:
 +49 228 280 9141

Terms and times of support services vary, per the terms of 
your current service contract with Telestream.

Telestream, LLC Web Site: www.telestream.net

Marketing Email: info@telestream.net

Sales Email: sales@telestream.net

Sales Website: http://www.telestream.net/purchase/
store.htm

Telestream, LLC
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International 
Distributor Support

Web Site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net

Share comments about this or other Telestream documents.

Wirecast Training 
Resources

Wirecast Training Resources

mailto:support@telestream.net
http://www.telestream.net
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net

http://www.telestream.net/telestream-support/wire-cast/training.htm#
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Copyrights and Trademark Notices
Copyright © 2022 Telestream, LLC and its Affiliates. All rights reserved. No part of this 
publication may be reproduced, transmitted, transcribed, altered, or translated into any 
languages without written permission of Telestream, LLC. Information and 
specifications in this document are subject to change without notice and do not 
represent a commitment on the part of Telestream. Specifications subject to change 
without notice.

Telestream, CaptionMaker, Cerify, DIVA, Episode, Flip4Mac, FlipFactory, Flip Player, 
GraphicsFactory, Kumulate, Lightspeed, MetaFlip, Post Producer, ScreenFlow, Switch, 
Tempo, TrafficManager, Vantage, VOD Producer, and Wirecast are registered trademarks 
and Aurora, ContentAgent, Cricket, e-Captioning, Inspector, iQ, iVMS, iVMS ASM, 
MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port, CaptureVU, FlexVU, PRISM, 
Sentry, Stay Genlock, Aurora, and Vidchecker are trademarks of Telestream, LLC and its 
Affiliates. All other trademarks are the property of their respective owners. 

Adobe. Adobe® HTTP Dynamic Streaming Copyright © 2014 Adobe Systems. All rights 
reserved.

Apple. QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the 
Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

Avid. Portions of this product Copyright 2012 Avid Technology, Inc.

CoreOS. Developers of ETCD.

Dolby. Dolby and the double-D symbol are registered trademarks of Dolby 
Laboratories Licensing Corporation.

Fraunhofer IIS and Thomson Multimedia. MPEG Layer-3 audio coding technology 
licensed from Fraunhofer IIS and Thomson Multimedia.

Google. VP6 and VP8 Copyright Google Inc. 2014 All rights reserved.

MainConcept. MainConcept is a registered trademark of MainConcept LLC and 
MainConcept AG. Copyright 2004 MainConcept Multimedia Technologies.

Manzanita. Manzanita is a registered trademark of Manzanita Systems, Inc.

MCW. HEVC Decoding software licensed from MCW.

MediaInfo. Copyright © 2002-2013 MediaArea.net SARL. All rights reserved. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Microsoft. Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008 
|Server 2012|Server 2016|Server 2019, Windows 7, Windows 8, Windows 10, Media 
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Player, Media Encoder, .Net, Internet Explorer, SQL Server 2005|2008|2012|2016|2019, 
and Windows Media Technologies are trademarks of Microsoft Corporation.

NLOG, MIT, Apache, Google. NLog open source code used in this product under MIT 
License and Apache License is copyright © 2014-2016 by Google, Inc., © 2016 by Stabzs, 
© 2015 by Hiro, Sjoerd Tieleman, © 2016 by Denis Pushkarev, © 2015 by Dash Industry 
Forum. All rights reserved.

SharpSSH2. SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer:

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Swagger. Licensed from SmartBear.

Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.

VoiceAge. This product is manufactured by Telestream under license from VoiceAge Corporation.

x264 LLC. The product is manufactured by Telestream under license from x264 LLC.

Xceed. The Software is Copyright ©1994-2012 Xceed Software Inc., all rights reserved.

ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.
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Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.
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MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT 
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR 
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE 
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM 
MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 80237 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE 
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING 
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL 
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE 
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD 
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER 
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER 
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR 
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. 
SEE HTTP://WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE 
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT 
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR 
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA 
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON 
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT 
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.
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Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), will be free from defects in materials and workmanship under normal 
operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality. 

Software Updates
Except as may be provided in a separate agreement between Telestream and You, if 
any, Telestream is under no obligation to maintain or support the Software and 
Telestream has no obligation to furnish you with any further assistance, technical 
support, documentation, software, update, upgrades, or information of any nature or 
kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
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in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product. 

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA

You can call Telestream during U. S. business hours via telephone at (530) 470-1300.

Regulatory Compliance
Electromagnetic Emissions: FCC Class A, EN 55022 Class A, EN 61000-3-2/-3-3, CISPR 22 
Class A

Electromagnetic Immunity: EN 55024/CISPR 24, (EN 61000-4-2, EN 61000-4-3, EN 
61000-4-4, EN 61000-4-5, EN 61000-4-6, EN 61000-4-8, EN 61000-4-11)

Safety: CSA/EN/IEC/UL 60950-1 Compliant, UL or CSA Listed (USA and Canada), CE 
Marking (Europe)

California Best Management Practices Regulations for Perchlorate Materials:
This Perchlorate warning applies only to products containing CR (Manganese Dioxide) 
Lithium coin cells. Perchlorate Material-special handling may apply. See 
www.dtsc.ca.gov/hazardouswaste/perchlorate.
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Introduction

Wirecast is professional-grade software for live streaming video production.

Topics
■Introducing Wirecast 18

■Wirecast Workflow 19

■Wirecast Resources 20

■Two Ways to Use this Application 22

Introducing Wirecast
Wirecast provides the tools you need for every step of a broadcast, from audio-video 
capture to live production switching to streaming.

Note: We use the word, “broadcast” throughout this guide to mean a one-to-many 
transmission of an audio-video stream, and related data, typically over the Internet.

Wirecast is available in two versions: Studio and Pro.

Wirecast Studio supports the following:

• Unlimited Capture

– Unlimited inputs

– Two remote guests via Wirecast

• Rendezvous conferencing

• Enhanced Production

– 4096 x 3072 maximum project and encoding resolution

– Five Main Mixing layers

– Built-in, animated lower thirds title library

– Integrated text, Chroma Key and built-in transitions

– Custom transitions, playlists

– Advanced audio mixer

– Social media comment moderation
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• Unlimited Destination Outputs

– Unlimited output destinations, including multiple simultaneous record-to-disk 
locations

– Virtual camera and microphone output

– 1-4 slot multi-viewer output unlimited

Wirecast Pro includes all the features of Wirecast Studio and also supports the 
following:

• Advanced Unlimited Capture

– Seven remote guests via Wirecast Rendezvous conferencing

• Advanced Production

– PTZ Camera Control

– Pro Audio FX

– Sports Production (instant replay, scoreboards)

– Virtual Sets and backgrounds

• Advanced Unlimited Destination Outputs

Adds baseband SDI/HDMI output, NDI program output, and Secondary Display output

– 1-17 slot multi-viewer output

– ISO recording of individual sources

– Multi-track audio recording

Features that pertain specifically to Wirecast Pro are indicated by this Pro icon:

 

Note: Both Studio and Pro licenses include one year of Insider Access Support 
providing free software updates, access to built-in Stock Media library, on-demand 
video training, access to the Knowledgebase and Community Forum, and email 
support with an eight-business-hour response time target.

This guide explains how Wirecast works, and provides tips for producing the best 
broadcasts possible.

Wirecast Workflow
Because of its versatility in handling a variety of inputs and outputs, Wirecast typically 
fits in the middle of your broadcasting workflow. Wirecast can take the place of 
traditional T-bar hardware switchers, graphics generators, and title generators. 
However, you can also use Wirecast simply as the back-end encoder for large switching 
systems.

Wirecast productions generally follow a four-step workflow:

PRO
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1. Plug in your live input devices such as video cameras, iOS cameras, computer 
desktop, and web feeds.

2. Capture your content.

3. Produce your program using the full range of Wirecast production features.

4. Stream your program live to the web or to a LAN, or record it to a local drive.

Figure 1. The Wirecast Workflow
 

Wirecast Resources
For up-to-date information about Wirecast, visit the following Telestream resources.

Tutorials, Webinars, and Demos
To learn Wirecast basics quickly, work through the tutorials in the Tutorials section of 
the Wirecast User Guide. The tutorial environment built into Wirecast corresponds with 
these tutorials. Together, the three tutorials take about thirty minutes.
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Telestream provides tutorials, webinars, and product demos on the Wirecast Training 
Resources page:
http://www.telestream.net/telestream-support/wire-cast/training.htm

Finally, Telestream provides tutorials, webinars, and product demos on Vimeo at these 
locations:

Wirecast Webinars

Wirecast Tutorial Series: Part I

Wirecast Tutorial Series: Part II

Also, see Making Great Broadcasts. This topic provides practical tips for improving the 
quality of your presentations.

Telestream User Forum
Join the active community of Wirecast users in posting Wirecast questions, answers, 
and feature requests. Also, one click takes you from the forum to the knowledge base of 
Wirecast technical articles.

Telestream User Forums:

https://telestreamforum.forumbee.com/

Wirecast Literature, Documentation, and Knowledge Base
Find current versions of Wirecast literature, user guides, and customer case studies on 
the Wirecast Literature and Documentation page. Find Wirecast technical articles on 
the Wirecast Knowledge Base.

Wirecast Literature and Documentation:

http://www.telestream.net/wirecast/resources.htm#docs

Wirecast Knowledge Base:

Wirecast Knowledge Base

Navigate the User Interface.
For descriptions of the various Wirecast menu items, tools and windows, see Windows, 
Controls, and Menus.

https://telestreamforum.forumbee.com/
https://telestreamforum.forumbee.com/
http://www.telestream.net/wirecast/resources.htm#docs
http://www.telestream.net/telestream-support/wire-cast/training.htm

https://support.telestream.net/s/global-search/Wirecast
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Two Ways to Use this Application
There are two different ways you can use Wirecast:

Presenter Is Operator
In this mode of operation, the person conducting the presentation simultaneously 
operates Wirecast.

Here are some suggestions for using Wirecast when you are both the presenter and 
operator:

• Keep it simple Set up Wirecast to make it easy for you to be the operator and the 
presenter. Set up your logo and titles so that you need to make very few changes 
during your presentation. Use a minimum number of shots so it’s easy for you to 
see which shot to choose.

• Keep the AutoLive feature on This enables you to present your shots with just one 
click. Though this limits your ability to perform complex presentations, it is the best 
way when the presenter is also the operator. To turn AutoLive on or off, select it 
under the Switch menu.

• Pre-configure your shots Make sure that all the shots are created prior to your 
presentation. Do not try to create or modify shots while broadcasting them.

• Use hot-keys for switching shots Wirecast provides a hotkey editor that enables 
you to easily assign hotkeys to your shots. 

Presenter Plus Operator
In this mode of operation, an engineer (or operator) is responsible for using Wirecast, 
and the presenter concentrates on the content of the presentation. 

Here are some suggestions for using Wirecast when you have both an operator and a 
presenter:

• Keep the AutoLive feature off This enables you to make several changes at one 
time before taking the changes live. However, to quickly make a shot live, press the 
Shift+Ctrl keys and click the shot. The AutoLive control is located under the Switch 
menu

• Open the Preview Area The operator should use Preview mode to examine every-
thing before it becomes live. The Preview display control is located under the Lay-
out menu.

• Use the Layer Windows to make more shots available To open layer windows so 
you can quickly flip between shots on several layers, select Window > New Layer 
Window.
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Installation

You can install Wirecast on any Mac or Windows computer that meets the minimum 
system requirements.
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General System Requirements

Operating System
• Minimum: Windows 10 version 1809 or higher; or Windows 11 21H2

• Recommended: Windows 10 21H2

Processor

Note: How to check the generation of your Intel processor.

• Minimum: Intel 6th generation (May be insufficient for 1080p+ or 60 fps workflows) 
or later; or AMD Ryzen™ 1000 Series or later

• Recommended: Intel 7th generation or later; or AMD Ryzen™ 3000 Series or later


https://support.telestream.net/s/article/Wirecast-How-to-check-the-generation-of-your-Intel-processor/
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Memory
• Minimum: 8GB RAM

• Recommended: 16+ GB RAM

Hard Drive
• Minimum: 7200 RPM Hard Drive (HDD) for record to disk

• Recommended: Solid State Drive (SSD)

Graphics Card
• Minimum: Intel HD (insufficient for advanced Multi-Viewer workflows), 2 GB video 

memory, DirectX 11 capable

• Recommended: Dedicated Nvidia GeForce 4+ GB video memory, DirectX 12 capa-
ble

Internet Bandwidth
Recommended: Total bitrate needed x 2 = Required upload bandwidth

Network Ports
You may want to check that the following ports are open for traffic on your network:

• 80 (HTTP/HTTPS)

• 443 (SSL)

• 1935 (RTMP)

• 2935 (RTMPS)

• 3478 (STUN/Rendezvous)

• 5349 (STUN/Rendezvous)

• 5353 (mDNS for NDI sources)

• 5960-59xx NDI port range (One port for each NDI source in use)

• 7272 (Remote Desktop Presenter)

• 49152-65535 (WebRTC Media/Rendezvous, selected at random)

If you are behind a firewall, check with your streaming destination for any sites you may 
need to whitelist.

Note: We recommend running Wirecast on the Windows Aero theme, which includes 
a hardware-accelerated window manager. Running Wirecast on the Windows Classic 
theme can cause performance issues.
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Rendezvous Requirements
Wirecast Rendezvous uses WebRTC technology that can be very resource intensive. For 
the best Rendezvous experience, we recommend the following hardware:

Based on a single simultaneous stream of 720p30 x264 @ 4.0Mbps.

1. Bandwidth per guest will scale downwards as more are added to maintain 
reliability.

2. Minimum recommended processor with example stream4. More demanding 
workflows may require a more capable CPU.

ISO Recording Requirements
• Solid State Drive or fast RAID array recommended for ISO Recording and Replay 

functionality.

• Actual data rates will vary depending on quality level selected for ProRes (Mac) or 
MJPEG recording (Windows), as well as the resolution and frame rate selected.

• For Mac ProRes recording please refer to Apple’s ProRes data rate specifications.

• Total expected data rate should be compared to available disk write speed to 
ensure adequate disk throughput.

Note: Failure to ensure the available disk write speed is greater than the highest 
expected total data rate may result in frames being dropped from recordings (ISO, 
Replay, and Record-to-Disk).

Recommended Hardware
• Intel Core i5 CPU @ 2.5 Ghz or higher recommended for 720p streaming with x264 

@ 30 fps.

• Intel Core i7 CPU @ 3.0Ghz or higher recommended for 1080p streaming with x264 
@ 30fps.

Note: 60 FPS streaming will result in increased CPU usage and a high bit rate (4Mbps 
or higher) for good quality.

Table 1. Rendezvous Bandwidth Requirements

Rendezvous Bandwidth 
Requirements Studio (2 guests + 1 host) Pro (7 guests + 1 host)

Bandwidth1 Add 4 Mbps Add 5+ Mbps2

Processor1 5 quad-core3 7 quad-core3
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• Minimum 4GB RAM, 2GB free hard disk space. Additional hard disk space required 
for recording to disk.

Hardware Accelerated Encoding Requirements
• Intel Quick Sync Video encoding requires an Intel CPU with an Intel® QuickSync 

Video core.

• NVIDIA NVENC encoding requires an NVidia GPU with Kepler architecture or newer.

Installation and Removal
You can install Wirecast on any Windows or Mac computer that meets the Wirecast 
basic system requirements.

Installing Wirecast
To install Wirecast, follow these steps:

1. Download the installer from the Telestream website:

https://dynamic.telestream.net/downloads/download-wirecast.asp?prodid=wire-
cast.

2. Run the installer (.exe) program and follow the instructions provided.

Note: The Wirecast installer asks whether you want to install the Virtual Microphone 
feature. If you do (recommended), check the box for this feature and continue the 
installation. You must have administrative rights to install Virtual Microphone.

3. If you have an older version of Wirecast already installed on your computer, the 
installer upgrades to the newer version.

See also Install and Activate Wirecast for Windows.

Uninstalling Wirecast
To uninstall Wirecast, do the following:

1. Run the Wirecast installer (.exe) program.

The installer asks if you want to repair or remove the existing version.

2. Select Remove to uninstall the existing version of Wirecast.

Purchasing, Activating, and Deactivating Wirecast
You can purchase and activate Wirecast on a computer that is either online or offline.

http://www.telestream.net/wirecast/overview.htm
http://www.telestream.net/wire-cast/overview.htm
https://dynamic.telestream.net/downloads/download-wirecast.asp?prodid=wirecast
https://dynamic.telestream.net/downloads/download-wirecast.asp?prodid=wirecast

https://vimeo.com/172647032
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Purchasing and Activating Wirecast Online
To purchase and activate Wirecast, do the following:

1. Launch Wirecast.

2. Select File > Preferences > Licenses, and click Purchase. Purchase Wirecast. Enter your 
license key into the License Key field. If you previously purchased a copy of Wirecast 
and want to use that serial number, enter that serial number.

3. Click Activate.

Wirecast validates the serial number and unlocks Wirecast.

4. Close the Preferences window.

Telestream activates your Wirecast program.

Note: You can also purchase a serial number at www.telestream.net.

See Preferences.

Activating Wirecast Offline
If the computer where Wirecast is installed is not on the Internet, you can use another 
computer that is online to activate your license and unlock Wirecast.

To activate your license from another computer, follow the steps in the Offline 
Activation Guide at:

http://www.telestream.net/telestream-support/wire-cast/training.htm.

Deactivating Wirecast
Deactivating a serial number on one computer allows you to re-activate it on another 
computer. Without an activated license, Wirecast adds water-marking to the video and 
audio whenever licensed features are used.

Note: You can always reactivate a serial number by re-entering it into the License Key 
field and clicking Activate.

To deactivate Wirecast, do the following:

1. Select File > Preferences > Licenses.

2. Click Deactivate.

Wirecast deactivates the serial number and removes it from the License Key field.

Note: You can access the License Reset Tool at:
https://www.telestream.net/telestream-support/deactivate-software.htm

See Preferences.

https://www.telestream.net/telestream-support/deactivate-software.htm
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Support Subscriptions and Upgrades
With each purchase of Wirecast – whether it is an upgrade purchase or full license – you 
receive an Insider Access Support subscription for one year from the date of purchase. 
You can renew this subscription annually.

You can choose to upgrade from an Insider Access Support subscription to a Premium 
Access Support subscription at any time, for an additional fee. You can also renew 
Premium Access Support subscriptions annually.

Your support subscription is tied to your Wirecast license. As long as your license is 
entered into the software and your Premium Access Support or Insider Access Support 
subscription is active, you can upgrade to the latest unlocked version of Wirecast for 
free. To do this, download and install the latest version of Wirecast. You will 
automatically have access to all the new features (depending on your license level).

If your support subscription has expired, or you haven’t entered your license into the 
software, you can’t upgrade to an unlocked version. The software reverts to 
demonstration mode. However, you may continue to use the last valid version of the 
software released during your support-subscription coverage period.

If your support subscription is about to expire (12 months from the date of purchase), 
Wirecast prompts you to renew it. If you do not renew it before it expires, you may re-
subscribe at any time for an additional fee.

See also Support Subscriptions and Upgrades.

Checking for Wirecast Updates
To check for Wirecast software updates, do the following:

1. Select File > Preferences > Software Update.

2. Click Check Now.

Wirecast checks for updates, but does not transmit personal information to 
Telestream during this action.

See Preferences.

Demonstration Mode
With no active serial number, Wirecast enters demonstration mode. In demonstration 
mode, Wirecast watermarks all outputs (both to disk and to networks). The video water-
mark is a periodic overlay of the Wirecast logo. The audio watermark is a periodic voice-
over. If you have a Wirecast serial number and are using a Wirecast Pro feature without a 
Pro license, Wirecast also watermarks that output.
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Installing a Hardware Controller
You can control many Wirecast functionalities with some external hardware controllers, 
or Human Interface Devices (HIDs). Wirecast provides control of three MIDI controllers: 
APC MINI, APC40mk2, Launchpad MK2, and one X-keys controller: XKeys 128.

To install a hardware controller for Wirecast, do the following:

1. Select File > Preferences > Controllers.

2. Select a controller from the drop-down menu.

3. To close the Preferences dialog box, click the “x.”

See Preferences.

Preventing Screen Tearing with Vertical Sync
You can prevent Wirecast from dropping frames, and optimize Wirecast performance 
by enabling vertical sync.

Wirecast usually synchronizes its video display with the refresh rate of your display. 
However, this degrades performance when the Wirecast program window is not visible 
(due to the screen being locked, Wirecast minimized, or the Wirecast covered by 
another application). Also, when your system can’t draw a complete frame by the time 
another one comes along you'll notice “tearing” artifacts in your video.

Degraded performance, “tearing,” and video stuttering in the Wirecast user interface 
might be caused by the Disable Vertical Synch option, which is selected by default.

Note: Disabled vertical sync can interfere with the smooth display of video in the 
Wirecast user interface. This does not, however, decrease the broadcast video quality.

Unchecking Disable Vertical Synch enables vertical synchronization. Vertical 
synchronization prevents the video card from drawing another frame until after the 
monitor finishes its current refresh cycle.

Note: When vertical synchronization is enabled, Wirecast limits the frame rate of the 
rendering engine to the video-signal frame rate. This improves video quality but could 
involve trade-offs. For example, this could introduce input lag which could interfere 
with the performance of games, particularly games that require precise timing or fast 
reaction times.

See also Screen Tearing.

In order to avoid dropping frames, do the following:

1. Select File > Preferences > Advanced.

2. Uncheck Disable Vertical Sync.

3. To close the Preferences dialog box, click the “x.”

https://en.wikipedia.org/wiki/Screen_tearing
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See Preferences.

Preventing Dropped Frames from Short Latency
You can prevent Wirecast from dropping frames, and optimize Wirecast performance 
by lengthening latency.

Wirecast adds latency to all incoming sources. Latency is the brief period between 
receiving live video and displaying it or processing it. Adding latency gives Wirecast 
time to store the incoming data properly. The Application Source Latency preference lets 
you specify the length of the latency. The lower this value, the less time Wirecast takes 
between receiving data and using it. If the connection is not fast enough, or the latency 
is too brief, this might result in dropped video frames (less noticeable) and audio blips 
(very noticeable). The higher this value, the more time Wirecast has to store data before 
displaying or processing it. You can set the value for Application Source Latency, from 
50ms at a minimum to 330ms at a maximum. The default is 300 ms.

In order to prevent dropping frames from short latency, do the following:

1. Select File > Preferences > Advanced.

2. Enter a value, in milliseconds, into the Application Source Latency field.

3. To close the Preferences dialog box, click the “x.”

See Preferences.

The Wirecast Capture Folder
The first time you launch Wirecast, Wirecast detects any media capture drive present in 
your computer, and creates the folder, Wirecast Recordings, on the media capture drive.
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Customization

You can customize Wirecast to your needs by choosing Wirecast preferences. You can 
select most preferences directly from a Wirecast document or from the Shot Editor. You 
can also manage your licenses, update your software, and select advanced video 
preferences through the Preferences window.
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Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop 
during installation.

Note: You can determine whether Wirecast displays the landing page, and whether 
Wirecast opens the last document you worked on, at startup.
See Show landing page on startup and Open last document on startup.
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The Wirecast Layout
Before customizing the Wirecast layout, familiarize yourself with the default layout, and 
with the main Wirecast windows, controls, and menus.
See The Default Layout.

Customizing Wirecast with Preferences
You can customize Wirecast to meet your particular production needs, and types of 
equipment, by choosing preferences.

See The Preferences Dialog Box.

To customize Wirecast, do the following:

1. Select File > Preferences.

2. In the Preferences dialog, click one of these headings to view and change its 
associated preferences:

– General

– Canvas

– Shot Display

– Licenses

– Update

– Shortcuts

– Controllers

– Advanced

Wirecast applies your preferences immediately, and saves them automatically, every 
time you change a preference.

Resetting Preferences
To reset your preferences, use Support Assistant.

See Send Support Information and Preferences.

Choosing the Wirecast Language
You can choose the language for the Wirecast user interface from among any of the 
languages supported. To set the language for Wirecast, do the following:

1. Select File > Preferences.

Wirecast opens the Preferences dialog.

2. In the Preferences dialog, click Advanced.
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3. To open the Language drop-down menu, click the downward-pointing arrow next 
to the Language field.

Wirecast opens the Language drop-down menu.

4. Select the desired language from the drop-down menu.

Wirecast displays a Shutdown dialog.

5. Click the Shutdown button.

6. Re-launch Wirecast.

Wirecast displays the selected language in the user interface.

See Language.

Document Hotkeys and Application Shortcuts
You can control most of the standard Wirecast commands with pre-set application 
keyboard shortcuts. Also, you can create document hotkeys for document commands 
you use often.

Creating a Keyboard Shortcut Set
You can create new keyboard shortcut sets, including both application keyboard 
shortcuts and document hotkeys, through the Shortcuts tab on the Preferences dialog. 
You create a new keyboard shortcut set by copying an existing keyboard shortcut set 
and modifying it.

To create a keyboard shortcut set, do the following:

1. Select File > Preferences > Shortcuts.

2. Select the keyboard shortcut set you want to copy from the Keyboard Shortcut Set 
drop-down menu.

3. Click Configure > Duplicate Set.

Wirecast copies the selected keyboard shortcut set and adds it to the Keyboard 
Shortcut Set drop-down menu.

4. Select the new keyboard shortcut set from the Keyboard Shortcut Set drop-down 
menu.

5. Click Configure > Rename.

Wirecast opens a renaming dialog box.

6. Enter a name for the keyboard shortcut set in the field under Please enter a new 
name for the Set, and click OK.

Wirecast renames the keyboard shortcut set, and closes the Preferences dialog box.

See also Shortcuts Preferences.
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Changing a Keyboard Shortcut
You can’t change any of the default application shortcuts in the Default keyboard 
shortcut set. However, you can copy the Default keyboard shortcut set, and edit the 
application shortcuts in the copied keyboard shortcut set. Also, you can change the 
document hotkeys.

To change a keyboard shortcut (either an application shortcut or a document hotkey), 
do the following:

1. Create a keyboard shortcut set by copying the Default keyboard shortcut set.

See Creating a Keyboard Shortcut Set.

2. Select the keyboard shortcut you want to change.

See Finding an Application Shortcut and Finding a Document Hotkey.

Wirecast opens the Click to record shortcut field towards the bottom of the Prefer-
ences dialog.

3. Enter the key desired in the Click to record shortcut field.

Wirecast saves the new keyboard shortcut.

Creating a Document Hotkey
To create a document hotkey, do the following:

1. Select File > Preferences > Shortcuts > Document Hotkeys.

2. Select a hotkey in the list.

Wirecast opens the Click to record shortcut field.

3. Enter a key in the Click to record shortcut field.

Wirecast binds the key to the command.

4. (Optional) To make your hotkey active even when the Wirecast window is not in 
focus, check Global. If Global is not checked, you must select the Wirecast window 
for the document hotkey to work.

See also Shortcuts Preferences.

Note: If your hotkey combination already is assigned to a command, Wirecast 
displays a warning icon in the Conflict column. The Conflicted sub-tab of the 
Application Shortcuts tab displays conflicted application shortcuts.

Creating a Document Hotkey for a Shot
On a shot in the layers pane, click the gear icon, select Assign Hotkey, and select a 
hotkey from the menu.

Wirecast assigns the hotkey to the shot, and displays the keyboard shortcut in the 
shot icon.

See Layers, Creating a Document Hotkey, and Shortcuts Preferences.
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Creating a Document Hotkey for Multiple Shots
You can assign the same document hotkey to multiple shots. This is useful when you 
want to activate different shots on different layers at the same time, using a single 
hotkey. To create a document hotkey for multiple shots, do the following:

1. Assign a keyboard shortcut to one shot.

See Creating a Document Hotkey for a Shot.

2. Assign the same keyboard shortcut to a second shot on another layer.

Wirecast displays the keyboard shortcut in both shot icons.

See also Shortcuts Preferences.

Displaying Either Hotkey Name or Key Combination on 
Shots

To determine whether Wirecast displays the hotkey name or the key combination itself 
on shots, do the following:

1. Open Preferences, and select the Shot Display tab.

See Customizing Wirecast with Preferences.

2. Click the arrows for the Display hotkeys using drop-down menu.

Wirecast displays the options Key Combination and Hotkey Name.

3. Select the type of hotkey display desired.

See also Shot Display Preferences and Shortcuts Preferences.

Setting the Primary Device for Audio Monitoring
To select the device Wirecast uses for audio monitoring, do the following:

1. In Windows, right-click the speaker icon in the task bar. Then, select Open Sound 
settings > Sound.

2. Under Choose your output device, select the desired default audio-monitoring 
device from the drop-down menu.

Wirecast uses the device chosen as the device for audio-monitoring. You can select a 
different device through the Audio Playback preference.

See Audio Playback.

Choosing a Video Adapter
If your computer has multiple video adapters, such as NVIDIA, AMD, or Intel graphics 
cards, you can determine which video adapter Wirecast uses. Generally, use this option 
only for troubleshooting.

To select a video adapter, do the following:
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1. Select File  > Preferences > Advanced.

2. From the Video Adapter drop-down menu, select the video adapter desired. Choose 
Select a video adapter.

3. To close the Preferences dialog box, click the “x.”

See The Preferences Dialog Box.

Disabling Sleep Mode
Wirecast does not prevent your computer from entering sleep mode. To ensure 
uninterrupted streaming, disable sleep mode on your computer while using Wirecast.

Assigning CPU Usage
To avoid a decrease in video quality, don’t set Wirecast CPU usage above 80%. See the 
Telestream Website for suggested configurations.

Keeping the Wirecast Window on Top
To keep the Wirecast window active as the topmost open window on your system, 
select File > Always On Top.

See File Menu.

Selecting and Customizing Encoder Presets
To select one of the default encoder presets, or to customize encoder presets for your 
outputs, do the following:

1. Select Window > Encoder Presets.

2. Select an encoder preset from the Encoder Preset drop-down menu, and click Close.

3. (Optional) Alternatively, check Video Encoding, Audio Encoding, or both. Choose the 
video and audio settings desired. Click Save As, give the custom preset a name, and 
click OK.

See The Encoder Presets Window.

External Display Outputs
You can use either the Secondary Display Monitor output or the Multiviewer output for 
external output. Secondary Display lets you send a frame-accurate program feed out 
via the software. You can feed this into a recorder or use it as a source for another 
program, such as Zoom. There is 1/4-second of latency in the Secondary Display 
output. This latency improves A/V sync and reduces dropped frames.
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The Multiviewer output, on the other hand, lets you monitor up to 17 sources or 
windows, including the Preview Area, the Live Broadcast Area, or any source you have in 
your document. Because the Multiviewer output is meant for monitoring rather than 
for frame-accurate recording, Multiviewer has no intrinsic latency. Multiviewer outputs 
usually have less latency than Secondary Display outputs.

See Multi-Viewer Output and Secondary Display Live Output.

Adding VST Plugins to the Available Audio Plugins
To add VST plugins to the plugins available to the Wirecast audio mixer, do the 
following:

1. Select Window > Audio Plugin Explorer.

See Window Menu.

Wirecast opens the Audio Plugin Explorer dialog box, listing the Telestream plugins 
installed by default.

2. Click the “+” button.

Wirecast opens a file browser.

3. Browse to a folder of VST plugins, select a VST file, and click Open.

Wirecast adds the VST plugin to the list of audio plugins.
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Document Creation and 
Input Configuration

Before broadcasting, create a document and configure the Wirecast inputs. Add shots 
to the document. Add sources to the shots. The document then contains the shots and 
sources for a particular broadcast.

Wirecast enables you to broadcast media created outside of Wirecast, as well as with 
live camera and live microphone sources.

Topics
■Creating a Document 40

■Configuring the Wirecast Layout 41

■Application Shortcuts and Document Hotkeys 43

■Standard Shots 44

■Playlist Shots 49

■Replay Shots 51

■Social Media Shots 53

■Placeholder Shots 57

■PTZ Cameras and Controls 59

■Rendezvous 62

■Transitions 68

■Supported File Types 69

■Remapping Media Locations 70

Creating a Document
You keep all the resources for a particular broadcast in a Wirecast document. You can 
save the audio, video, file, and controller sources, as well as the output settings, for a 
broadcast in a document file. Wirecast Document files have the file extension, WCST.

To create a new document, do the following:

1. Select File > New.

Wirecast opens a new document.
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2. To save the document, select File > Save.

3. Enter a file name for the document, and click Save.

Note: Consider establishing a file-naming method for documents. For example, you 
could name documents for specific broadcasts, or for specific types of broadcasts.

Adding Media to a Document
To add media to a document, do the following:

1. Select File > Import Media.

2. Browse to the media file desired, select it, and click Open.

Wirecast imports the file into the document.

Configuring the Wirecast Layout
To optimize the user interface for each document, you can configure the Wirecast 
layout. Wirecast saves the layout settings in the document file.

See The Default Layout.

To configure the Wirecast layout, do the following:

1. Select Layout.

See Layout Menu.

2. Choose a desired option from the menu.

Wirecast configures the layout accordingly, and closes the Layout menu.

3. To select whether Wirecast displays the Preview Area, the Live Program Area, or both, 
choose the appropriate Mode Selection button.

See Layers.

Resizing a Layer
To change the height of any layer, and the size of the shot icons on the layer, do the 
following:

1. Click the lower edge of the layer desired.

2. To increase the layer height, drag the lower edge downward. To increase the height, 
drag it upward.

See the screenshot of the Layers window in the topic Layers.
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The Preview Area
You can preview media files in the Preview Area.

See Preview Area.

Viewing the Preview Area
To display the Preview Area, select Layout > Show Live and Preview, or Layout > Show 
Preview Only.

See Preview Area.

Viewing a Shot in the Preview Area
To view a shot in the Preview Area, click a shot in a layer.

Wirecast displays the shot in the Preview Area.

See The Default Layout, Viewing the Preview Area, and Preview Area.

Magnifying the Preview Scrub-Bar Scale
To change the Preview Area scrub-bar scale, do the following:

1. To display the preview-shuttle magnification slider, click the magnifier (spyglass) 
button at the bottom of the Preview Area.

2. Drag the preview-shuttle magnification slider to the left to zoom out (increase) the 
time scale of the preview shuttle, and to the right to zoom in (decrease) the time 
scale of the preview shuttle.

Figure 2. Preview Area playback controls

For example, if you move the slider to the right, the In and Out controls move farther 
apart, increasing the magnification, so that you can more easily adjust the location of 
the In and Out controls. This is very helpful when you have long-duration shots. The 
magnification slider stops sliding when the scrub bar represents the full length of the 
shot.

In and Out 
controls Preview-shuttle magnification slider

Magnifier button

Playback speed control
Preview Area scrub bar
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Setting Preview Playback Speed
To set the speed of playback in the Preview Area, do the following:

1. Click the speed-control button (1x) at the bottom of the Preview Area.

Wirecast opens the speed drop-down menu.

2. Select a speed from the drop-down menu. Your choices are 1x (normal speed), 2x 
(double speed), .5x (half speed), and .25x (one-fourth speed).

Wirecast mutes the audio for any speed other than 1x.

Application Shortcuts and Document Hotkeys
You can use keyboard commands to execute most of the menu commands in Wirecast. 
These keyboard shortcuts are called application shortcuts. You can also execute many 
Wirecast document commands with keyboard shortcuts you create. These are called 
document hotkeys.

Note: You can view complete lists of application shortcuts and document hotkeys on 
the Shortcuts tab of the Preferences dialog.

Finding an Application Shortcut
You can find existing application shortcuts through the Shortcuts tab on the Settings 
dialog.

To find an application shortcut, do the following:

1. Select File > Preferences > Shortcuts.

2. Select the desired keyboard shortcut set from the Keyboard Shortcut Set drop-down 
menu.

3. Click the Application Shortcuts tab.

4. (Optional) To filter the shortcuts Wirecast lists, click the All, Customized, or Conflicted 
sub-tab.

5. To expand a menu item in the list, click the “+” next to the name of the menu item.

6. Do one of the following:

– Scroll down to the desired menu item to find its assigned application shortcut.

– Enter the name of the menu item into the Search field.

Wirecast filters the list of menu items, displaying only those containing your search 
term.

See also Shortcuts Preferences.
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Finding a Document Hotkey
You can find existing hotkeys for controlling documents through the Shortcuts tab on 
the Settings dialog.

To find a document hotkey, do the following:

1. Select File > Preferences > Shortcuts.

2. Select the desired keyboard shortcut set from the Keyboard Shortcut Set drop-down 
menu.

3. Click the Document Hotkeys tab.

4. Scroll down to the desired hotkey.

See also Shortcuts Preferences.

Standard Shots
You can create and edit shots for your broadcasts before you begin broadcasting.

Creating a Shot
1. To create a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Select options for the shot as desired.

See Add Shot Window.

Creating a Shot from a Shot Template
1. To create a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Select Templates.

3. Select Shot Template, and click the Add button.

Wirecast opens the templates dialog.

4. Select the template desired, and click Add.

See Add Shot Window and Creating a Custom Shot Template.

Adding Media Files from a Local Drive to a Shot
1. To add media files from a local drive to a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.
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2. Click Media Files. 

3. To select a media file from a local drive, double-click Browse Disk.... Select a file and 
click Open.

4. Click Add.

See Add Shot Window.

Adding Media Files from the Stock Media Library to a Shot
1. To add media files from the Stock Media Library to a shot, click the “+” in any of the 

layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Click Media Files. 

3. Double-click Stock Media Library.

4. The first time you open a Stock Media Library file, Wirecast displays Terms and 
Conditions. Read the Terms and Conditions, check the I Agree checkbox, and click 
Proceed.

Wirecast opens the Stock Media Library.

See the screenshot of the Stock Media Library in Stock Media Library.

5. Use Source Type and Left/Right buttons to navigate to a media file, then click 
Download to include it as a shot.

6. Click Add.

See Add Shot Window.

Adding Video Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Click Video Capture. Select video sources for the shot as desired.

3. Click Add.

See Add Shot Window and Wirecast: How to find the URI to add an IP Camera as a Web 
Stream source.

Adding an NDI™ Source to a Shot
Wirecast lists any NewTek NDI source on your local network under the Network option 
in the Add Source menu. To add an NDI source to a shot, do the following:

1. In a layer, click the “+” icon.

Wirecast opens the Add Shot dialog box.


https://support.telestream.net/s/article/Wirecast-How-to-find-the-URI-to-add-an-IP-Camera-as-a-Web-Stream-source

https://support.telestream.net/s/article/Wirecast-How-to-find-the-URI-to-add-an-IP-Camera-as-a-Web-Stream-source
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2. Select Network.

3. Select the NDI source from the list of sources in the right-side pane, and click Add.

Wirecast creates a shot for the NDI source selected.

Note: When checked, GPU Decoding for incoming sources will use your GPU to 
process the incoming NDI source, reducing the processing demand on the CPU.

Select video source, audio source and audio output. You can also make a copy of the 
URL to send to guests by clicking Copy.

See NDI Devices in the Shot Layer Properties Tab.

See also How to setup a NDI Discovery Server to resolve NDI connectivity issues in 
Wirecast.

Adding Audio Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Click Audio Capture. Select audio sources for the shot as desired.

3. Click Add.

See Add Shot Window.

Creating a Consolidated Shot
1. Select multiple sources in the Shot Layers tab of the Shot Editor.

See The Shot Editor Window.

2. Select Edit > Copy.

3. Select Edit > Paste as New Consolidated Shot to create a new shot in the selected 
layer.

See Edit Menu.

Adding a Title to a Shot
To add a title to a shot, do the following:

1. In a layer, click the Add Shot “+” button.

See Layers in The Default Layout.

2. Select Overlays > Title.

3. To add the title to your document, click the Add button.

See Title.

https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-NDI-Discovery-Server/?l=en_US&c=Product%3AWirecast&fs=Search&pn=1

https://support.telestream.net/s/article/Knowledge_Article/Wirecast-NDI-Discovery-Server/

https://support.telestream.net/s/article/Knowledge_Article/Wirecast-NDI-Discovery-Server/
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Adding a Virtual Set to a Shot
To add a virtual set to a shot, do the following:

1. In a layer, click the Add Shot “+” button.

See Layers in The Default Layout.

2. Select Templates > Shot Template.

3. In the Shot Template dialog box, navigate to one of the built-in virtual sets, and 
select it.

4. Customize the set as desired.

See Virtual Set Properties.

Opening a Shot for Editing
To open a shot in the Shot Editor window, do one of the following:

• In a layer, double-click the shot desired.

• Single-click the shot to select it. Then click the double-arrow on the left of the 
default layout to open the Shot Editor window.

See The Default Layout and The Shot Editor Window.

Adding, Deleting, or Rearranging Layers in a Shot
You can add, delete, or rearrange layers in a shot with the controls on the Shot Layers 
tab of the Shot Editor.

See Shot Layers Tab.

To add, delete, or rearrange layers in a shot, do the following:

1. Select a shot in a layer. Then select Edit > Edit Shot.

2. Edit the shot in one or more of the following ways, as desired:

• Add a layer by clicking the plus (+) button.

• Delete a layer by select selecting it and clicking the minus (-) button.

• Reorder the layers by selecting a source and clicking the up-arrow or down-arrow 
to move it.

• To move a layer forward or back, replace a source in a layer with another source, 
add a layer to a shot, remove a layer from a shot, or display the original location of a 
media file, click the gear button.

• Toggle, on or off, the visibility of a video source by clicking the eye button.

• Toggle, on or off, the visibility of an audio source by clicking the speaker button.

See Shot Layers Tab.
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Resizing or Rotating a Shot
To resize or rotate a shot, do the following:

1. Click a shot in a layer. Then, click the shot in the Preview Area.

Wirecast places a control frame around the shot in the Preview Area. The control 
frame includes handles for resizing and rotation.

2. Click and drag any of these handles to resize or rotate your image.

See Preview Area.

Positioning an Image Within a Shot
You can also snap an image in the Preview Area to various alignments: Snap to Center, 
Snap to Edge, Snap to Corner, or Snap to an Image. The yellow guidelines appear when 
the image is ready to snap into place.

See Preview Area.

Moving a Shot to Another Layer
You can move a selected shot to another layer by selecting Move to Layer from the Edit 
menu, then selecting the target layer from the drop-down menu. You can also click and 
drag the shot icon to a different layer.

When shots are created, they are assigned to a specific layer. They exist on that layer 
until they are moved or deleted. (See Layers.)

To temporarily disable the snap action, hold down the Alt key while moving an image 
into place (the yellow snap lines will not appear). Additionally, after selecting an image, 
you can use the arrows keys to nudge it into correct placement.
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Figure 3. Snap Actions

Playlist Shots
You can create and broadcast shots containing multiple preselected clips. First, create 
and edit the playlist shots.

Creating a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source 
from the list.

To create a new Playlist, click the “+” in one of the layers, and select Shots.
Select New Playlist Shot. Then click Add.
The playlist shot displays a playlist badge and the playlist duration.

Figure 4. Playlist Shot

Snap to Center
Snap to Corner 

Snap to Edge Snap to an Image

Playlist badge
Playlist duration
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Adding Clips to a Playlist Shot
To add clips to an existing playlist, do one of the following:

• Click and drag the desired clip from any layer onto the playlist shot.

• Click and drag the desired shot onto the playlist shot (you must click the bottom 
part of the shot icon to drag it).

Adding Clips to a Playlist from the Shots Menu
To add clips to an existing playlist shot from the Shots menu, do the following:

1. In a layer, double-click the desired playlist shot.

Wirecast opens the Playlist tab.

2. Select Shots > New Shot, and select the clips desired.

Wirecast adds the selected clips to the playlist.

Editing Playlist Shots
To edit a shot in a playlist, do one of the following:

• Double-click the shot in the playlist.

• Right-click the shot and select an item from the Shot Menu.

See The Shot Menu.

Note: Do not delete shots from a playlist while the playlist is running.

Setting Playlist Shot Attributes
You can determine how Wirecast plays playlists. To select playlist options, do the 
following:

1. In the Main Shot List tab in the Layers window, select a playlist shot, and click the 
button for the Source Properties tab.

See the Source Properties tab on The Shot Editor Window.

Wirecast opens the Playlist Properties tab.

2. In the Playlist Properties tab, set the options for the playlist as desired.

See Playlist Properties Tab.

Changing the Duration of a Playlist Shot
The Change Shot menu for playlist shots has a Modify Duration option. By default, live 
sources have an infinite duration (since they are not clips). For clips, you must assign a 
duration time.
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To set or change the duration of a playlist shot, do the following:

1. Right-click the shot and select Modify Duration from the Shot Menu.
See The Shot Menu.

Wirecast displays the Shot Duration window.

2. Enter a new duration time value.

3. (Optional) Check Apply to All if you want this duration applied to all items in the 
playlist.

4. (Optional) Reset the duration to its original value by clicking Reset.

5. Click OK when finished.

Adding a Live Source to a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source 
from the list.

Note: Wirecast does not support nested playlists: playlists within playlists).

Replay Shots
You can create replay shots that you can broadcast at any time.

See Configuring Replay + ISO.

Creating a Replay Shot from a Selected Clip
To create a Replay shot, do the following:

1. Make sure you have activated Replay.

See Activating Replay.

2. To play a clip, select the clip and click the Go button.

3. Select Replay + ISO > Program Replay > Start.
Wirecast displays the Replay controls.

4. Click the Create Replay Shot button.

Since the default replay duration is set at 30 seconds, Wirecast creates a Replay shot 
that starts 30 seconds before you clicked Create Replay Shot. Wirecast places the 
new Replay Shot in Layer 1 and displays the Replay controls next to the transition 
controls and Go button.

See The Default Layout.

Creating a Replay Shot from a Layer
To create a replay shot from a layer, do the following:
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1. In a layer, click the plus icon (+). In the Add Shot dialog box, select Shots > Replay 
Shot. Click Add.

2. In the Shot Layers tab of the Shot Editor, add additional graphics, titles or other 
sources to the shot as needed.

3. Select Replay+ISO > Configure, then select Replay Settings. Select the Replay 
template from the Replay Shot Template drop-down menu, check Program Replay, 
and click OK.

4. Enable the Replay system by selecting Replay+ ISO > Start All.

Wirecast displays the Replay controls.

5. Click the Create/Update Replay Shot button to create a Replay shot using the 
template.

See the Create/Update Replay Shot button on the screenshot in Replay Controls.

See Add Shot Window, The Shot Editor Window, Shot Layers Tab, and Replay Layer.

Trimming a Replay Shot
To trim a Replay shot from its start, do the following:

1. Select a Replay shot in a layer.

The Replay shot appears in the Preview Area.

2. Trim the shot by moving the In Point indicator and Out Point indicator to the 
desired start and end frames.

See In Point and Out Point in Media Files.

3. Play the Replay shot to the frame you want to end the shot.

4. Click the Create Replay Shot button.

Your Replay Shot now contains only the content you wanted.

Looping, Holding, or Removing a Clip After Playback
You can determine what Wirecast does when it is finished playing a live clip. To set what 
Wirecast does when finished, do the following:

1. Select a shot in the Shot Layers pane.

2. Click the three-dot button to open the Source Properties tab.

See the Source Properties tab on the screenshot of The Shot Editor Window.

3. Select the desired options for the clip on the Source Properties tab.

See Source Properties Tab.
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Social Media Shots
Wirecast lets you incorporate social-media feeds into your broadcasts. With the Social 
Comments feature, you can display, in overlays, Tweets from Twitter, and posts from 
Facebook or from YouTube Live. Also, you can conduct and display Facebook polls.

Displaying Social Media Comments
The Social Comments feature lets you bring audience comments into your broadcast. 
You can bring in comments from Twitter, Facebook Live (Profile, Page, Group), and 
YouTube Live broadcasts.

Setting up comment display is a two-step process:

1. Authenticate with the platforms from which you want to pull comments.

2. For Facebook and YouTube, begin streaming live to those platforms. This step is not 
necessary for Twitter.

3. Choose a social media title where Wirecast displays the comments.

Once you start streaming, you can moderate incoming comments manually, or set 
them to rotate on-screen during your broadcast.

See The Comment Moderation Window, Social Media Title, and Moderating Social Media 
Comments.

Configuring Twitter Comments
To display posts from a Twitter feed in your broadcast, first configure Wirecast for 
Twitter.

To configure your account with Twitter, do the following:

1. Select Social > Twitter > Settings. Then click the Authenticate button.

Alternatively, select Social > Comments to open the Comment Moderation window. 
Then, click the Twitter logo, and authorize your account on Twitter.

2. Enter the user name and password for your Twitter account.

Wirecast displays a PIN.

3. Copy the PIN and enter it into the PIN field.

4. Press Enter or Authorize app.

5. Select a feed type.

If you select Search, the Search String field becomes active., and Wirecast displays 
Twitter feeds that contain a search string.

See Moderating Social Media Comments and Moderating Facebook or YouTube Comments 
for a Streaming Computer or RTMP Server.
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Configuring Facebook Live or YouTube Live Comments
To display posts from a Facebook Live or YouTube Live feed in your broadcast, first 
configure Wirecast for Facebook Live or YouTube Live.

To configure Facebook Live or YouTube Live social comments, do one of the following:

• (Facebook only) Set your Facebook stream to public so that Wirecast can display 
Facebook comments in the Comment Moderation window.

• Click Output > Output Settings, and set up a streaming destination.

See Adding a Destination and The Output Settings Window.

• Click Social > Comments, and click either the Facebook or the YouTube logo.

Wirecast opens the Output Settings window, where you set up your streaming desti-
nation.

See also Configuring Wirecast to Show Facebook User Name and Photo, Moderating Social 
Media Comments, and Moderating Facebook or YouTube Comments for a Streaming 
Computer or RTMP Server.

Configuring Wirecast to Show Facebook User Name and 
Photo
By default, Wirecast displays a generic Facebook User graphic to identify the source of a 
Facebook Live comment. To enable Wirecast to display the actual Facebook user name 
and photo, ask the Facebook user to grant permission to Wirecast. Do the following:

1. Make sure Wirecast is configured to show Facebook comments.

See Configuring Facebook Live or YouTube Live Comments.

2. Let your viewers know you want to include their names and photos for their 
comments. Request their permission to let Wirecast access their names and 
pictures. Tell them they may grant permission through this website:

https://www.telestream.net/facebook/permission.htm
3. Tell your users that, to grant permission, they should click the button, Let Wirecast 

display your Facebook Live comments.

Choosing a Social Media Title for Displaying Comments
To choose a title for displaying social media comments, do the following:

1.  Click the “+” in one of the layers to create a new shot.

2. Click Overlays > Social Media Title.

Alternatively, from the Comment Moderation window, click the Create Title Shot but-
ton in the lower left.

3. Specify what each of the types of title displays.

4. Add your title shot to one of the layers in your document.

See Adding a Title to a Shot.

https://www.telestream.net/facebook/permission.htm
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Note: You can adjust the settings for each social media title in the Title Properties 
panel.

When you start your live stream, Wirecast displays comments from Facebook and 
YouTube in the Comment Moderation window.

When you authorize Twitter, Wirecast displays Tweets or comments from Twitter in the 
Comment Moderation window immediately.

See The Comment Moderation Window.

Creating a Facebook Poll in Wirecast
You can create and display Facebook polls in your broadcast. First, configure Wirecast 
for Facebook.

Note: Wirecast displays Facebook polls in the Facebook user interface only when a 
Facebook video is playing, and is fully open.

Note: Wirecast can use only Facebook Polls created within the Wirecast application 
itself. You can’t import Facebook polls created within the Facebook Live user interface.

To create a Facebook poll, do the following:

1. Select Social > Facebook > Create New Poll.

Wirecast opens a dialog box for specifying the poll options.

2. Enter a question.

3. Select whether there are two, three, or four answers, and enter each answer. Be sure 
to enter an answer for every option selected.

4. Check the boxes for any of the implementation options desired.

5. Click OK.

Once you’ve created the poll, Wirecast lists the poll in the Social > Facebook menu.

See Facebook.

Selecting a Facebook Poll
To select an existing Facebook poll, do the following:

1. Select Social > Facebook.

2. Select a previously-created poll from the drop-down menu.

Note: Wirecast saves Facebook polls, like Wirecast preferences, with the Wirecast 
application, not with a specific document.

See Facebook.
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Editing or Deleting a Facebook Poll
To edit or delete an existing Facebook poll, do the following:

1. Select Social > Facebook.

2. Select a previously-created poll from the drop-down menu.

3. Do one of the following:

• To edit the poll, select Edit.

• To delete the poll, select Delete.

Note: Facebook does not allow you to edit a poll that is being shown, so this option is 
not enabled while streaming to Facebook and using a poll.

See Facebook.

Showing or Hiding a Poll or Results when Streaming to 
Facebook
The options Show Poll, Show Results, and Hide are available when streaming to 
Facebook. Once you’ve activated the poll, you may display a poll or its results at any 
time while streaming to Facebook. When you start streaming, Wirecast makes the Show 
Poll option available, but by default, it is not selected.

There is a lag of 5 to 15 seconds between selecting a poll and having it appear in your 
stream. When Wirecast starts displaying the poll, it adds a check mark to the Show Poll 
option, and Wirecast enables the Show Results and Hide options.

To show or hide a Facebook poll or Facebook poll results, do one of the following:

• To show a Facebook poll, select Social > Facebook > Show Poll.

• To show the results for the Facebook poll, select Social > Facebook > Show Results.

Note: Showing a Facebook poll closes the poll to further responses.

Note: Facebook does not automatically display polls. The viewer must click on the 
video to see or vote on a poll.

• To hide the Facebook poll and results, select Social > Facebook > Hide.

Note: You may hide a poll only if it’s the active poll. Showing a different poll, or 
showing the results for a different poll, hides any other polls being shown. This allows 
you to show a poll, or show the results of the poll, and then hide it.
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Placeholder Shots
Wirecast comes with nine default placeholders, labeled A through I. If you need more, 
you can create your own. All existing placeholder letters appear in the list of available 
placeholders. Wirecast displays the current assignment of each placeholder next to the 
letter.

Adding and Modifying Template Placeholders
• To generate a new placeholder, select New Placeholder and click Add.

Wirecast displays the new placeholder shot in the shot editor, and displays its Place-
holder [#] in the list of placeholders.

Note: Wirecast saves new placeholders in the open document. These placeholders 
don’t appear in other documents. You can’t assign media to a placeholder with New 
Placeholder > Add. You can add an existing placeholder, or a new placeholder, to a 
shot.

Assigning Media to Placeholders
To assign media to a placeholder, do one of the following:

• Select Media > Assign Placeholder. Any placeholders that have been added to shots 
appear in the Assign Placeholder drop-down menu. Clicking on one of the available 
placeholders opens the Assign Placeholder dialog box.Select the type of place-
holder desired in the left pane, select a source in the right pane, and click Assign. 
When you assign a source to a placeholder, Wirecast uses that source in every shot 
in which that placeholder is used.

• In the Shot Layers tab, click on the gear menu of any placeholder and select Assign 
Placeholder. Wirecast opens a drop-down menu. Select a source for the placeholder.

• Right-click on a placeholder in the Preview Area. Wirecast opens a similar Assign 
Placeholder drop-down menu where you can select a source to replace your place-
holder.

Note: You can assign media that isn’t yet used in the document to a placeholder. 
However, you can’t assign Rendezvous guests to a placeholder until they’ve joined the 
broadcast.

Resetting Placeholders
Select Media > Reset Placeholder, then select a placeholder to remove any media 
assignments.
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Viewing Placeholders
To view the available placeholders, do one of the following:

• In a layer, click the “+” Add Shot button, and select Templates. Wirecast displays a list 
of available placeholders and their assignments in the Add Shot dialog box.

• Select Media > Assign Placeholder. Wirecast displays a partial list of available place-
holders.

Adding a Placeholder Shot
You can add a placeholder shot in the same way you add other shots. To add a 
placeholder shot, do the following:

1. To create a shot, click the “+” in any of the layers.

See Layers in The Default Layout.

Wirecast opens the Add Shot dialog box.

2. Select Templates.

3. Select a placeholder, and click the Add button.

Wirecast adds the placeholder shot to the layer.

Deleting a Placeholder
To delete a placeholder from a shot, do the following:

1. In a layer, click a shot that contains a placeholder.

Wirecast opens the shot in the Shot Layers tab.

2. Select the placeholder in the Shot Layers tab.

3. Click the delete button (-).

When you confirm, Wirecast deletes the placeholder from the shot.

Creating a Custom Shot Template
To configure any shot with a placeholder and save it as a template shot, do the 
following:

1. On any shot in a layer, click the gear button. Then, select Save Shot as a Template.

Wirecast displays a Request dialog.

2. Enter a template name and click OK.

Wirecast adds the shot template to the Custom Templates section of the templates 
dialog.

Wirecast saves custom templates in Global Preferences so that you can access your 
custom templates across different documents.
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Note: Any placeholders in your custom template revert to an unassigned 
placeholder, even if that placeholder was assigned to a source when you saved the 
custom template.

See Creating a Shot from a Shot Template.

Deleting a Custom Shot Template
To delete a custom template, do the following:

1. To open the Templates window, click the “+” in a layer.

Wirecast opens the Add Shot dialog.

2. Select Templates > Shot Template.

Wirecast opens the Shot Template dialog.

3. Select the custom template to delete, then click Delete Template.

Wirecast deletes the template from your Global Preferences. The custom template 
no longer appears in the Shot Templates window. However, Wirecast doesn’t delete 
shots in any documents that are based on the deleted shot template.

Add Shot Dialog
All

Displays all sources in one list.

Favorites

Displays a list of shots that have been marked as a Favorite by clicking on the star on 
the right side of each shot in the Add Shot dialog.

Media Files

Creates a Media File shot (video clip or picture). When selected, a navigation widow 
displays. Navigate to a media file location, select a media file, and click Open.

Shots

Creates a new shot. Options are New Playlist Shot, which creates a new Playlist shot, and 
New Shots From Clipboard, which creates a new shot from a file that has been copied to 
the clipboard. This is how you duplicate a shot.

Select a shot and click the Add button.

See Templates.

PTZ Cameras and Controls
You can control cameras that allow remote control of pan, tilt, and zoom (PTZ) 
functions. First, configure Wirecast to support your PTZ cameras.
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Setting Up PTZOptics Camera with a Dynamic IP Address
PTZOptics cameras ship with a Static IP address set to 192.168.100.88. To communicate 
with your cameras on your network, you must change this address to one in range of 
your network.

To set up your PTZOptics camera IP address, follow these steps:

1. To obtain a usable IP address for your camera, ensure you can access the video feed 
of your camera over HDMI or SDI (not IP). Since you will change the IP address, you 
must use HDMI or SDI to access the video feed. Connect the HDMI port of the 
camera to a TV, or if you are already using a capture card with, add the source to 
your document and queue it up in the Preview Area.

2. To set your Camera to DHCP (Automatic)--making it addressable by your PC--on the 
camera remote control, enter “# * 4” sequentially. The camera displays a message in 
the video feed that says “DHCP OPEN.” Then the camera reboots automatically.

Note: If your camera doesn’t display “DHCP OPEN” or restart automatically, contact 
PTZOptics for assistance, or manually assign the IP address yourself.

3. When Wirecast displays the video feed, on the remote control, enter “# * 4” 
(sequentially) to view the new DHCP address. The camera now requests a new IP 
address whenever it is plugged into a new network. This means the IP address can 
change, which generally isn’t desirable in a live environment.

Setting Up PTZOptics Camera with a Static IP Address
If you prefer to set a static IP address for a permanent installation, follow these steps:

1. To obtain a usable IP address for your camera, ensure you can access the video feed 
of your camera over HDMI or SDI (not IP). Since you will change the IP address, you 
must use HDMI or SDI to access the video feed. Connect the HDMI port of the 
camera to a TV, or if you are already using a capture card with, add the source to 
your document and queue it up in the Preview Area.

2. To set your Camera to DHCP (Automatic)--making it addressable by your PC--on the 
camera remote control, enter “# * 4” sequentially. The camera displays a message in 
the video feed that says “DHCP OPEN.” Then the camera reboots automatically.

3. Open a web browser, and enter the IP address obtained in the previous steps. You 
can view that IP address by entering “# * 4” (sequentially) using the remote control.

4. Enter admin for both the username and password.

5. Select Network in the navigation options, located at the top-left part of the web 
page.

6.  Find the DHCP/STATIC setting. 

7. Set IP Configuration Type to Fixed IP Address.

8. When Wirecast displays the confirmation dialog window, click Apply, then click OK.

9. Recycle to power on the camera to reboot it.
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Note: If you have trouble setting the IP address on your camera, contact PTZOptics 
for assistance.

Configuring The PTZ Controller
1. Get the IP address of your camera.

See Setting Up PTZOptics Camera with a Dynamic IP Address and Setting Up PTZOptics 
Camera with a Static IP Address

2. To display the PTZ Controller panel, select Window > PTZ Controller.

3. Select the video ingestion method from the Camera menu. This will be an HDMI or 
SDI capture device, or NDI if your device supports it.

4. Enter the IP address for your camera.

5. Port and VISCA Address are set automatically to the default values for PTZOptics 
camera. You don’t need to change these.

6. Click the Connection button to the far right of Status. Wirecast displays connected 
when a connection is made.

Setting Up a PTZ Camera Shot
To set up a Wirecast shot using a camera setup, do the following:

1. To display the PTZ Controller panel, select Window > PTZ Controller.

2. Select D-Pad from the Pan/Tilt menu and move the camera to a desired position. 
Pan the camera by clicking the left and right arrows, and tilt the camera by clicking 
the up and down arrows.

3. Enter a preset number (0 to 255) and click the Save button to save this camera 
position.

4. To create a camera shot, click a “+” in one of the Wirecast layers.

Wirecast opens the Add Shot dialog box.

5. Select Video Capture, select your camera from the device pane, and click the Add 
button.

Wirecast places your PTZ camera shot in the layer.

6. To open the Shot Editor, double-click your camera shot. Click the Shot Layer 
Properties tab.

7. Click the PTZ triangle to display the PTZ controls. Check the Preset check box, enter 
a preset number and click the Go arrow.

You can now move your camera by changing shots.
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Opening the PTZ Controller Panel
To open the PTZ Controller panel, select Window > PTZ Controller.

See The PTZ Controller Panel.

Enabling Preset Recall for a PTZ Camera
Once you have configured a shot layer with a PTZ preset, sending that shot to preview 
recalls the preset for the camera. If multiple shots share the same video source with 
different PTZ presets configured, the shot which is currently live takes precedence over 
subsequent PTZ preset recall actions, until you drop the shot from the live feed.

To enable preset recall, do the following:

1. In the Shot Editor, select the Shot Layer Properties tab. Click the PTZ triangle towards 
the bottom of Shot Layer Properties.

2. Check the Enable box. To select a preset, enter a preset number or click the up/
down arrow buttons. Click the Go button (right pointing arrow) to cause the 
associated PTZ camera to go live with the recalled preset.

When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel.

See Shot Layers Properties Tab and The PTZ Controller Panel.

Rendezvous
Rendezvous provides an easy way to organize a video conference with up to two 
guests in Wirecast Studio, and up to seven guests in Wirecast Pro. You can bring in live 
video feeds from a computer or smart device running a supported web browser, or 
from iOS devices running the Wirecast Go app.

Creating a Rendezvous Session
To create a Rendezvous session, do the following:

1. To open the Create Rendezvous Session dialog, do one of the following:

– In a layer, click the Add Shot (+) icon. When Wirecast opens the Add Shot 
dialogue, select Network > Create Rendezvous Session.

– Select Window > Rendezvous Dashboard. Click the Start Session button.

Wirecast opens the Create Rendezvous Session dialogue.
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2. In the Create Rendezvous Session window, optionally select Enable chat for session, 
Share chat history, or both. Then click Create Session.

The Enable chat for session option enables a chat dialog between you and your 
guests.

If you select Share chat history with new session guests, guests that arrive at any time 
in the session see the full chat history. If you don't select this option, new guests see 
only chat messages that occur after they’ve joined the session.

See Rendezvous Chat Features.

3. In the Created Session window click the Click to Copy button to copy the 
Rendezvous URL to the clipboard. Send this URL to the guests that you want to 
invite to the broadcast.

4. When finished, click OK.

Wirecast opens the Rendezvous Dashboard. If you enabled Rendezvous Chat, Wire-
cast displays the Rendezvous Dashboard with the Rendezvous Chat panel on the 
right. You can open and close the Rendezvous Chat panel by clicking on the “>>” 
button to the left of the Rendezvous Chat panel.

See The Rendezvous Dashboard.

Note: You can also show the live output in the Rendezvous display (instead of your 
local camera). To do this, click the camera button and select Live Output from 
[document title]. You can add live output audio by clicking the mic button.

Note: From the Rendezvous Dashboard you can mute audio or hide the camera of 
your local sources, or the sources of those who have joined. To do this, click the camera 
or mic button of the source to mute. You can disconnect at any time by clicking the 
Disconnect button.

See also Rendezvous Essentials.

Starting a Rendezvous Session
To start a new session, do the following:

1. Click Window > Rendezvous Dashboard > Start Session.

See The Rendezvous Dashboard.

2. Copy and email the session URL to all potential guests.

Joining a Rendezvous Session as a Guest
To join a Rendezvous session on a remote computer or smart device, do the following:

https://support.telestream.net/s/article/Rendezvous-Essentials

https://support.telestream.net/s/article/Rendezvous-Essentials/
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1. To initiate a connection with Wirecast, paste the URL you received in the 
Rendezvous invitation email into a browser. Press Enter.

The browser opens a Rendezvous guest window.

See The Rendezvous Guest Window.

Note: The only browsers supported by Wirecast for joining a Rendezvous session are 
Chrome, Safari, and Firefox.

2. (Optional) To open live chat, click the live chat  button.

3. (Optional) Turn off the camera by clicking the camera  button.

4. (Optional) Mute the mic by clicking the microphone  button.

5. (Optional) To share a screen, click the share screen  button.

If you select Share Screen, Wirecast opens the Choose what to share dialog.

Select the screen you want to share and click Share.

6. In the Rendezvous window, click the settings  button.

Wirecast opens the Microphone-Camera-Options dialog.

7. In the Camera-Microphone-Options dialog, select a microphone, camera, and 
options.

8. Enter an identification in the Your name field and click Join.

Note: Wirecast Go, running on iOS devices, can join a Rendezvous session by opening 
the URL. Android devices can join a session by opening a Session URL (sent to them) in 
the Chrome browser.

The Rendezvous window displays a Waiting to join message until the Wirecast host has 
added you as a guest.

Improving Rendezvous Audio with Music Mode
Only Rendezvous guests can turn on Music Mode. This greatly improves the audio 
quality for musical instruments played over Rendezvous.

Rendezvous guests can turn on Music Mode in the Rendezvous web app. This does the 
following:

• Changes the audio channel from the default monaural to stereo

• Increases the audio bit-rate from the default 32kbps to 256kbps, 128kbps for each 
stereo track.
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Note: Wirecast Music Mode improves audio quality only for Rendezvous guests 
sending audio to Wirecast. To conserve bandwidth, Wirecast doesn’t send the higher 
quality audio to other guests in a session.

•  Disables audio processing (echo cancellation and noise reduction)

Note: Disabling audio processing for speech through normal microphones can result 
in poor quality audio. Disable audio processing only for music.

Opening the Advanced Rendezvous Audio Mixer
To open the Advanced Rendezvous Audio Mixer, do the following:

1. Select Window > Rendezvous Audio Mixer.

Wirecast opens the Advanced Rendezvous Audio Mixer.

See Rendezvous Audio Mixer.

Adding a Guest to Rendezvous Dashboard
When a guest is waiting to join the Rendezvous session, Wirecast displays a guest icon 
in both the Wirecast default layout and in the Rendezvous Dashboard. To add a guest 
to a Rendezvous session, do the following:

1. In the Rendezvous Dashboard, click the guest icon and select a guest to add to the 
session.

See The Rendezvous Dashboard.

Adding a Guest to Wirecast Main or Shot Layer
1. In a layer, click the Add Shot (+) icon.

2. In the Add Shot dialog, select Network.

3. Under Rendezvous Session, select the name of the guest to add.

Wirecast displays your new Rendezvous shot on the shot layer from which it was 
selected.

4. Select the shot to display it in the Preview Area where you can place it and size it as 
needed.

Rendezvous Chat Features
There are times in a live interview when you need to communicate privately with your 
guests. That is the purpose of the Rendezvous Chat feature in Wirecast.

Wirecast displays a panel on the right side of the Rendezvous Dashboard that, when 
clicked, slides out to reveal the Rendezvous Live Chat panel.
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You receive a notification when a guest types a message, even if you have the Live Chat 
panel closed or if the Rendezvous Dashboard is not in focus.

Host and guests can type into the message window to communicate. Wirecast doesn’t 
display this chat panel on the live broadcast, so you can type private messages.

Guests’ names appear above messages they send. If you have several guests, each has a 
chat bubble window with a unique color, for easy identification.

As the host, you can select Clear Chat at the top right corner of your Live Chat panel. This 
clears all the messages from the Live Chat panels of you and the guests.

Guests connecting through a browser see the Live Chat panel. They can close their Live 
Chat panels by clicking on the X in the top of the panel.

If a message arrives for guests with the Live Chat panel closed, Rendezvous displays a 
green dot on the chat icon. Guests click this to open the chat panel.

If guests disconnect and reconnect to the same session, they still see the chat history, if 
chat history is enabled.

As host, disconnecting your session forces guests to disconnect, and deletes the chat 
history.

See Creating a Rendezvous Session and Wirecast: Rendezvous Chat Guide.

Reconnecting to a Rendezvous Session
To reconnect to the previous session, in the Rendezvous Dashboard, click Reconnect to 
previous session.

Wirecast restores all settings from the previous session, so long as the remote 
browsers are still open. If a guest has closed a remote browser, the guest can recon-
nect using the URL for the previous session.

Sharing Screen, Camera, or Both as Rendezvous Guest
Rendezvous guests can share their screens and cameras during a broadcast.

Note: You, as guest, might need to enable security or privacy permissions in your 
browser to allow screen sharing.

Note: Only one person can share screen and camera at any one time. However, 
multiple people at the same time can share screens with their cameras disabled.

To share your desktop, camera, or both as a Rendezvous guest, do the following:


https://support.telestream.net/s/article/Wirecast-Rendezvous-Chat-Guide/
https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-Rendezvous-Chat-Guide/?l=en_US&c=Product%3AWirecast%2CArticle_Type%3AFAQ%2CCategory%3AGeneral&fs=Search&pn=1
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1. Select Window > Rendezvous Dashboard.

Wirecast opens the Rendezvous Dashboard with a Share Screen button in the top-
right corner. The camera-share and screen-share buttons indicate whether camera- 
or screen-sharing are active.

See The Rendezvous Dashboard.

2. Click the Share Screen button.

Wirecast opens a drop-down menu.

3. Select one of the following options, as desired:

– Share screen & camera

If no-one else is sharing screen and camera, Wirecast asks which screen or win-
dow to share. Choose one.

If you, as guest, choose Share screen & camera, Wirecast displays only the Share 
Screen button for the Wirecast host.

When you, as guest, select Share screen & camera, the host sees two separate 
feeds in the Rendezvous Dashboard: one for the camera and one for the shared 
screen. The Wirecast host then can add one or both of these feeds, as separate 
shots, into the broadcast. Alternatively, the host can display the guest camera 
and the guest screen picture-in-picture.

– Share screen (disable camera)

When you, as guest, select Share screen (disable camera), the Wirecast host sees your 
shared guest screen.

Note: If a second guest selects Share screen & camera while a guest already is sharing 
both, Wirecast notifies the second guest that only one guest can share both screen 
and camera at a time. Wirecast offers the second guest the Share screen (disable 
camera) option.

4. (Optional) To stop sharing, you, as guest, can either click the Share Screen button at 
the top of the Rendezvous Dashboard, or click the Stop Sharing button displayed as 
a notification at the bottom of the screen.

Ending a Rendezvous Session
To close your session, in the Rendezvous Dashboard, click Stop Session.

When you disconnect from a Rendezvous session, Wirecast removes your camera 
from the guests’ browsers, and removes the guests’ cameras from your local session 
window.
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Transitions
There are three transition buttons: the Transition button, the Transition Controls button, 
and the Go button. You can configure the Transition button and the Transition Controls 
button.

See Transition Buttons.

Setting Transition Speed
To set the transition speed, select Switch > Transition Speed. Choose one of the five 
settings: Slowest, Slow, Normal, Faster, and Fastest.

Specifying the Transitions for the Transition Buttons
To assign a type of transition to a transition button, do the following:

1. Click the down-arrow on the right side of the transition button.

2. From the drop-down menu, select a new transition to assign to that button.

See Final Mix Audio Panel, and Selecting and Customizing Encoder Presets.

Importing Stinger Transitions
Stinger transitions are custom transitions that employ alpha-channel transparent 
backgrounds. These transitions typically are created using applications such as Adobe 
After Effects, Apple Motion or Telestream ScreenFlow.

To import a stinger transition, do the following:

1. Select Switch > Manage Stinger Transitions.

Wirecast displays the Stinger Transition Manager.

2. To import a transition file, click the plus (+) button, navigate to the desired stinger 
transition file, and select it.

Wirecast imports the stinger transition file, and adds it to the list of transitions avail-
able through the Transition Control button.

Note: Stinger transitions are stored in Wirecast preferences with the paths to media 
files. This allows the you to re-use stinger transitions in other Wirecast documents. 
When Wirecast can’t find a media file associated with a stinger transition, Wirecast 
removes the transition from the transition list. Also, Wirecast highlights the file name 
in red in the Stinger Transition Manager.

See The Default Layout and Manage Stinger Transitions.
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Executing a Stinger Transition
To execute a stinger transition, do the following:

1. To execute a stinger transition, click and drag the Transition Control button to open 
the drop-down menu.

2. Select the stinger transition.

3. To set the location where the shot will change from A to B, slide the scrubber to a 
location in the transition, then click the A/B button.

4. Click the Go button to execute the stinger transition.

See The Default Layout, Importing Stinger Transitions, and Manage Stinger Transitions.

Deleting Stinger Transitions
To delete a stinger transition, do the following:

1. Select Switch > Manage Stinger Transitions.

Wirecast displays the Stinger Transition Manager.

2. To delete a transition, select it and click the minus (-) button.

3. Click Close to exit the Stinger Transition Manager.

See Manage Stinger Transitions.

Supported File Types

Still-Image Types and Opacity
Wirecast supports a wide variety of still images types, for example TIFF, GIF, JPEG, and 
PNG. Some of these formats offer control of opacity, or transparency, by way of an alpha 
channel. Wirecast works seamlessly with these formats. TIFF, GIF, JPEG, and PNG are the 
preferred formats for graphics which have transparency.

GIF and Transparency
GIF files offer transparency but not a true alpha channel. You can define part of a GIF 
image as completely transparent, but not partially transparent. Some GIF images use 
transparency for much of the image. However, you can’t use transparency near the 
edges of the visible data in a GIF file. A GIF file that was created on a white background 
with transparency at the edges might show the white background at the edges in place 
of the transparency.

Tip: Avoid using GIFs with areas of transparency. When possible, use the image, 
without transparency, from which the GIF was generated. To add transparency to the 
image, save it in TIFF, GIF, JPEG, or PNG format; then define the transparency settings 
of the alpha channel.
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Supported Codecs
Wirecast supports media on a variety of platforms such as AVFoundation, a variety of 
file types such as MOV and AVI, and a variety of codecs such as AVC or H.264. Shown 
below is a list of file types and codecs that Wirecast supports.

Table 2. Supported Codecs

Remapping Media Locations
Wirecast stores paths to your media in the Wirecast document. If you move the media 
files for a document, use Asset Manager to update the document paths to the new 
media locations.

Tip: Keep the document WCST file in the same folder where you keep media files for 
the document. When you need to move the files to a new location, move this whole 

Video Codec MOV 
(M4V)

MP3 MPEG-4 
ISO 
(MP4)

WAV AIFF 
(AIFF, AIF) 

ASF 
(WMV)

WEBM

AVC YES NO YES NO NO NO
H264 YES NO YES NO NO NO
DVC25 YES NO NO NO NO NO NO
DVCPRO50 YES NO NO NO NO NO NO
DVCPRO100 YES NO NO NO NO NO NO
MJPEG YES NO NO NO NO NO NO
ProRes YES 

(mac 
only)

NO NO NO NO NO NO

QuickTime 
Animation

YES NO NO NO NO NO NO

VP8 NO NO NO NO NO NO YES
VP9 NO NO NO NO NO NO YES
Windows Media 
Video

NO NO NO NO NO YES 
(windows)

NO

Audio Codec
AAC YES NO YES NO NO NO NO
MP3 YES YES NO NO NO NO NO
Opus NO NO NO NO NO NO YES
PCM YES NO NO YES YES NO NO
Vorbis NO NO NO NO NO NO YES
Windows Media 
Audio

NO NO NO NO NO YES 
(windows)

NO
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folder. When you open the document in the new location, Wirecast finds the 
associated media automatically.

To update paths to media locations, do the following:

1. Select Media > Show Asset Manager.

2. Select the path to a media file you want to change.

3. (Optional) Some media sources, such as cameras, enable you to set the aspect ratio 
by displaying a Device Aspect Ratio menu. You can select an aspect ratio from this 
menu.

4. Select the desired media file from the Assign To menu; or click Browse, locate the 
desired media file, and then select the desired media file.

Note: When Remote Desktop Presenter (RDP) is selected as the media file, you can 
enter the IP address for the RDP. This enables you to build a Wirecast presentation with 
place-holders. You can reconfigure the placeholders later for a new source Remote 
Desktop Presenter.

5. Click Apply to save the new path to the media file, then close the Asset Manager.

Note: You can select a path from the list and click Delete to remove it. Also, you can 
click Delete All to clear the list.
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Output Configuration

Before you can broadcast with Wirecast, you must configure your output settings.

Wirecast enables you to specify many output settings for your presentation. You can 
configure Wirecast to broadcast multiple data rates simultaneously, broadcast with 
different encoders at the same time, or use Windows Media Encoder to record your 
broadcast to disk.

Topics
■Destinations 72

■Encoder Presets 86

■Mapping Audio Tracks to Output Audio Channels 91

■Mapping Audio Mixes to Playback Devices 91

■Streaming 91

■Configuring Replay + ISO 94

■Recording To Disk 99

Destinations
To broadcast with Wirecast, you must define at least one destination. A destination can 
be a broadcast server, content distribution network, or local disk recording.

See The Output Settings Window.

Destination Settings
Wirecast offers several default presets. First, choose the type of broadcast server, 
whether RTMP server, SRT (Secure Reliable Transport), Windows Media Server, or some 
combination. This decision depends on what you expect your viewers to use. With 
enough bandwidth, you can stream to combinations of RTMP Server and Windows 
Media Server by adding destinations to the output settings.

Note: To use Push To Server, you must have a reliable local Internet connection and 
access to a Windows Media Server. Pushing your broadcast to a Windows Media Server 
moves the bandwidth strain from your local machine to the external server.
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Creating an SDP File for Your Viewers
To view your screencasts, your viewers might need an SDP file from you. The SDP file 
contains multicast or unicast addresses, encoding format, and other important 
information.

You must create and distribute an SDP file when you change multicast or unicast 
Destination settings, including the encoder preset. To create and distribute an SDP file, 
do the following:

1. In the Output Settings window, click the gear button to the right of the Destination 
field.

2. Select Save SDP File.

Wirecast opens the Save File dialog.

3. Navigate to the desired location, and click Save.

4. Send the SDP file to viewers, and inform them they must save the SDP file on the 
computers they use to receive your broadcast.

See The Output Settings Window.

Selecting a Destination
To select a destination for a broadcast, do the following:

1. Select Output > Output Settings. Select a destination from the Destination drop-
down menu.

Wirecast displays the Output Settings dialog with presets for the destination you 
selected. Each Output Settings dialog has a unique set of controls and a way to 
authenticate your connection.

2. (Optional) To view more destinations in the Destination drop-down menu, click 
More in the Select an Output Destination dialog. Check the box for each destination 
you want to include in the destination menu list. Uncheck the box for any 
destination you want removed from the list of destinations for the broadcast.

3. Click OK.

See The Output Settings Window.

Adding a Destination
To add a destination for a broadcast, do the following:

1. Select Output > Output Settings.

2. In the left-side pane, click Add.

Wirecast displays the Select an Output Destination dialog.

3. Choose a destination from the Destination drop-down menu.
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4. (Optional) To view more destinations in the Destination drop-down menu, click 
More in the Select an Output Destination dialog. Check the box for each destination 
you want to include in the destination menu list.

5. Click OK.

Note: You can add as many destinations as you need, but keep in mind that each 
additional destination requires additional system resources.

See The Output Settings Window.

Removing a Destination
To remove a destination from a broadcast, do the following:

1. Select Output > Output Settings. Select a destination from the Destination drop-
down menu, and click OK.

Wirecast displays the Output Settings dialog with presets for the destination you 
selected.

2. In the left-side pane, select the destination you want to remove.

3. Click Remove.

4. Click OK.

See The Output Settings Window.

Modifying Windows Media Server Destination Settings
Windows Media can be used to broadcast WMV8, WMV9 and WMV9 Advanced. To 
modify Windows Media Server Destination Settings, do the following:

1. Select Output > Output Settings.

2. Select Windows Media Streaming from the Destination drop-down menu.

3. In the Output Settings dialog, check the box for Push to Server.

4. In the Address field, enter the Internet address of the Windows Media Server you 
use for broadcasting.

5. In the Publish Point field, nter the name of the file that is saved on the server. 
Wirecast adds this name to the URL that your users use. Contact your Windows 
Media Server administrator to learn how to build a proper URL based on the 
publish point.enter your Windows Media Server user name and password into their 
respective fields. Contact your Windows Media Server administrator to obtain 
these. If your account requires no user name or password, leave these fields empty.

6. From the Encoding drop-down menu, select any of the Windows-Media-based 
presets.

Wirecast displays the Pull From Server box.
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7. Check the Pull From Server box.

Pull From Server turns your local computer into a Windows Media Server, enabling 
you to broadcast immediately. There are, however, some limitations:

– User-Connection Limitation Your local Windows Media Server can’t support 
more than 50 connected users at a time.

– Bandwidth Requirement You must have enough bandwidth on your Wirecast 
computer to support all of your viewers.

– CPU Requirement Since the Wirecast computer is acting as a server, the CPU 
must be fast enough to handle all of the user connections.

It’s important to check for adequate bandwidth. For example, if you have only a DSL 
connection to the Internet, you might not have enough upload bandwidth to 
broadcast a 200k stream to 20 viewers.

Note: For broadcasting, your upload bandwidth matters most. Typical ISP packages 
offer higher download speeds than upload speeds.

8. In the Maximum Connections field, enter the maximum number of connections 
Wirecast accepts. Your server accepts a maximum of 50 user connections. However, 
your CPU is affected by the number of users connected. You might need to reduce 
the maximum to insure good performance.

9. In the Port Number field, enter the number of the port Wirecast uses to broadcast. 
Use any port number that isn’t already in use on your computer.

Wirecast adds a URL to the Location field. For example, if your computer IP address 
is 10.0.5.55 and your port is 1755, Wirecast generates the URL mms://10.0.5.55:1755.

See also Wirecast Network Ports and Proxy Servers.

10. If you have any firewall software installed, enable the port used for broadcast on 
the firewall.

11. To play your screencast in Windows Media Player, add the URL from the Location 
field to the Open URL field of Windows Media Player.

See The Output Settings Window.

Modifying RTMP Server Destination Settings
Wirecast can stream to an RTMP/H.264-compatible streaming server such as RTMP 
Server Media Server or Wowza Media Server.

To configure RTMP Server Streaming, follow these steps:

1. Select Destination > RTMP Server.

2. Select an encoder.

3. Enter the Address to the RTMP server. The default RTMP port is 1935, but you may 
need to configure your firewall to allow connections on this port.

https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-and-Proxy-Servers/?l=en_US&c=Product%3AWirecast&fs=Search&pn=1

https://support.telestream.net/s/article/Wirecast-and-Proxy-Servers/

https://support.telestream.net/s/article/Wirecast-and-Proxy-Servers/
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4. Wirecast can import a RTMP Server Encoder configuration file (XML file). Click Open 
FMLE XML File, and navigate to the configuration file and select either version 2.5 or 
version 3.0.

Wirecast reads the Address and Stream information from that file. Many online 
streaming services offer FMLE configuration files which Wirecast can use.

Note: Only the Address and Stream information from the XML configuration file is 
used. No Encoding information is imported.

5. Click OK to save your settings.

Modifying SRT (Secure Reliable Transport) Destination 
Settings

Wirecast can stream to SRT (Secure Reliable Transport), an open-source video transport 
protocol that enables the delivery of high-quality and secure, low-latency video across 
the public Internet. SRT Supports x264 and Apple H.264 encoding methods.

To configure SRT Streaming, follow these steps:

1. Select Destination > SRT:Secure Reliable Transport.

2. Select an encoder.

3. Enter the Address, Port, and Passphrase to the SRT.

4. Click OK to save your settings.

Modifying CDN Partners Destination Settings
Listed below are the Content Distribution Network (CDN) partner destinations available 
in Wirecast. Most destinations share a common user interface and require only a user 
name and password. To configure these, see Configuring Most Common CDN 
Configurations.

To configure destinations that do not conform to this paradigm, or that require 
additional parameters, see the Modifying topic for the specific destination.

Note: The list of CDN partners in Wirecast is subject to change at any time.

Configuring Most Common CDN Configurations
To stream to one of these CDN partners, do the following:

1. Select Output > Output Settings.

Wirecast opens the Output Settings dialog box.

2. Select a CDN partner from the Destination drop-down menu.

3. You can (optionally) click the Map button to open the Multi-Track Input Mapper. For 
each Channel, select (by checking the box) one or more inputs.
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4. Enter your username or email.

5. Click Authenticate to enter your password and generate the RTMP URL. You only 
need to do this one time because Wirecast stores the channel information for 
future streams. The default RTMP port is 1935. You may need to configure your 
firewall to enable connections on this port.

Note: If you do not have a username and password, you can sign up with a CDN 
partner by clicking Sign Up.

6. Select your channel.

7. Optionally, you can refresh your connection by clicking Refresh.

8. Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. However, greater delays require greater memory use. The amount 
of memory used is displayed when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

9. Click OK when finished.

Modifying Azure Media Services and Sermon.net 
Destination Settings

To stream to one of these CDN partners, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select a CDN partner from the Destination menu.

3. Select an encoder.

4. You can (optionally) click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Enter the domain name or IP address. Get this address from the CDN partner.

6. Enter the stream name of your broadcast. Get the stream name from the CDN 
partner.

Note:  If you do not have a stream name and password, you can sign up with the CDN 
partner by clicking Learn More.

7. Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.
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Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

8. Click OK when finished.

 Modifying Brightcove and Limelight Destination Settings
To stream to one of these CDN partners, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select a CDN partner from the Destination menu.

3. Select an encoder.

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Enter the domain name or IP address. Get this address from the CDN partner.

6. Enter the stream name of your broadcast. Get the stream name from the CDN 
partner.

7. Click Set Credentials to enter your Username and Password.

Note:  If you do not have a stream name and password, you can sign up with the CDN 
partner by clicking Learn More.

8. Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

9. Click OK when finished.

Modifying Akamai Destination Settings
To stream to Akamai, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select Akamai from the Destination menu.

3. Select an encoder.

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each Channel, select (by checking the box) one or more inputs.

5. Enter your Akamai Stream ID and Event Name.

6. Enter your Akamai Angle and Video Rate.
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7. Enter your user name and click Authenticate to enter your log in information.

Note: If you do not have a username and password, you can sign up with Akamai by 
clicking the Akamai icon, or by clicking Sign Up.

8. Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

9. Click OK.

Modifying LinkedIn Live Destination Settings
To stream to LinkedIn Live, follow these steps:

1. Enter a Name for your destination.

2. Select LinkedIn Live from the Destination drop-down menu.

3. Select an Encoder from the Encoding drop-down menu. 

4. You can (optionally) click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Select On Behalf of Organization or Member and click Login.

6. When Wirecast displays the login window, enter email, phone, and password 
information.

7. Click Sign In.

Note: If you do not have a username and password, you can sign up with LinkedIn 
Live by clicking Join Now.

8. Select an Organization.

9. Select an Ingest Region.

10. Enter your Post information.

11. To create an event, check Event, enter a URL, and click Verify URL.

Skip to the next step to create a targeted audience.

12. To create a targeted audience, check Audience Targeting and Click Setup.

Skip ahead to the next step if you created an event.

13. When Wirecast displays the Setup window, select multiple regions.

14. Select Languages and click OK.
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Note: Your target audience must include at least 300 members.

15. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

16. Click OK.

Modifying LiveArena Destination Settings
To stream to LiveArena, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select LiveArena from the Destination menu.

3. Select an encoder. 

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Enter your LiveArena Account ID, User Name, and Password.

6. Click Apply.

Note: If you do not have a username and password, you can sign up with LiveArena 
by clicking the LiveArena icon, or by clicking Sign Up.

7. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

8. Click OK.

Modifying Twitter Broadcast Destination Settings
To stream to Twitter follow these steps:

1. Optionally, enter a Name for your destination.

2. Select Twitter from the Destination menu.
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3. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

4. Click Plus (+) to enter your username and password.

5. Copy the Authorization Code and click on the URL below it.

6. When Wirecast displays the Authorization Code window, paste in the code and click 
Authorize.

Note: If Wirecast does not display the Authorization Code window, or if Wirecast 
displays an error window, clear your browser history or try using a different browser. 
Then, sign in again.

7. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the length of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

8. Click OK.

See also Wirecast: Streaming to Twitter using RTMP Output Destination.

Modifying Twitch Destination Settings
To stream to Twitch, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select Twitch from the Destination menu.

3. Select an encoder.

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Enter your Twitch username.

6. Click Authenticate to open the Twitch Log In window.

Note: If you do not have a username and password, you can sign up with Twitch by 
clicking the Twitch icon or by clicking Sign Up.

7. When Wirecast displays the Twitch Login window, enter your username and 
password, and click Log In.

8. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

9. Click OK when finished.

https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-10-Publish-to-Microsoft-Stream
https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-10-Publish-to-Microsoft-Stream
https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-Streaming-to-Twitter-using-RTMP-Output-Destination/?l=en_US&c=Product%3AWirecast%2CArticle_Type%3AUsing_Wirecast%2CCategory%3AOutput_Settings&fs=Search&pn=1

https://support.telestream.net/s/article/Wirecast-Streaming-to-Twitter-using-RTMP-Output-Destination/
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Modifying Vimeo Destination Settings
To stream to Vimeo, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select Vimeo from the Destination menu.

3. Select an encoder. 

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, click the box for one or more inputs.

5. Click Authenticate to enter your username and password.

Note: If you do not have a username and password, you can sign up with Vimeo by 
clicking Sign Up.

6. When Wirecast displays the Authorization window, click Allow.

7. Click the plus (+) icon to add a new event.

8. Enter your email and password, then press Enter.

9. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

10. Click OK when finished.

Modifying Wowza Streaming Engine Destination Settings
To stream to Wowza Streaming Engine, follow these steps:

1. Optionally, enter a Name for your destination.

2. Select Wowza from the Destination menu.

3. Select an encoder. 

4. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

5. Enter the domain name or IP address. Get the domain name or IP address from the 
CDN partner.

6. Enter the stream name of your broadcast. Get the stream name from the CDN 
partner.

7. Click Import Wowza Config to import a Wowza configuration to use.

8. Select User Agent. Default is Wirecast/FM1.0.

9. Click Set Credentials to enter your Username and Password.

Note:  If you do not have a stream name and password, you can sign up Wowza.
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10. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

11. Click OK when finished.

Modifying Zixi Destination Settings
To stream to Zixi, follow these steps:

1. Download and install Zixi Feeder.
For instructions on downloading and installing Zixi Feeder, see Zixi Documentation 
Center.

2. (Optional) Enter a Name for your destination.

3. Select Zixi from the Destination menu.

4. Select an encoder.

5. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

6. Enter Zixi connection information.

7. Enter your Zixi channel name and password.

8. Click Apply to generate the RTMP URL. You need to do this only one time because 
Wirecast stores the channel information for future streams. The default RTMP port 
is 1935. You may need to configure your firewall to enable connections on this port.

Note: If you do not have a username and password, you can sign up with Zixi by 
clicking the Zixi icon, or by clicking Sign Up.

9. (Optional) Enter a Stream Delay value. This provides a time buffer between your live 
stream from Wirecast and the actual broadcast itself. You can set the delay from 0 to 
999 seconds. However, greater delays require greater memory use. Wirecast 
displays the amount of memory used when you enter the amount of delay.

Note: We recommend keeping stream delay as low as possible, ideally less than 30 
seconds.

10. Click OK.

See also Setting up a Zixi Output Destination in Wirecast.


https://telestream.secure.force.com/kb/articles/Knowledge_Article/Wirecast-Streaming-to-Destination-Zixi/

https://support.telestream.net/s/article/Wirecast-Streaming-to-Destination-Zixi/

https://zixidocumentation.atlassian.net/wiki/spaces/110/overview?homepageId=22315017

https://zixidocumentation.atlassian.net/wiki/spaces/110/overview?homepageId=22315017
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Modifying Facebook Live Destination Settings
To stream to Facebook, follow these steps:

1. (Optional) Enter a Name for your destination.

2. Select Facebook Live from the Destination menu (if not already selected).

3. Select an encoder from the Encoding menu.

4. Choose the audio track to be used by selecting it from the Audio Track Selection 
menu.

5. (Optional) Map the audio tracks to the desired output audio channels.

See Mapping Audio Tracks to Output Audio Channels.

Note: If you change the encoding settings while streaming to Facebook, an error will 
occur. The encoder settings are set by Facebook.

6. To log into Facebook, do one of the following:

– To log into Facebook with a user account, click Authenticate and log into 
Facebook. If you already are logged into Facebook, you can click the Change 
button to log into a different Facebook account.

Note: If you do not have a username and password, you can sign up with Facebook 
by clicking the Facebook button, or by clicking Sign Up.

– To log into Facebook with a one-time stream key instead of a user account, click 
Pair Device. Wirecast opens a dialog. Follow the instructions given in the dialog.

7. Select Go Live Now or Schedule for Later from the Post To menu.

8. If you selected Schedule for Later, select also a start date and a time.

9. Select Pages, Profile, or Groups from the Post To destination menu. Click Refresh to 
refresh the page list. If planning to use co-branded content, check the Show verified 
pages only checkbox to filter out all non-verified pages. Enter a Title and a 
Description. Click Create to refresh after changing any settings.

10. If you selected Go Live Now, select also Pages, Profile, or Groups and enter a Title and 
Description (as described above). Optionally, click Advanced Options.

If you select Pages, you can also select Crosspost, if desired.

11. If you chose to post to a Profile, select also a level of Privacy: Public, Friends, or Only 
Me.

12. Click Create to start an event on Facebook. You can, optionally, optimize your 
connection by clicking Optimize Connection. When you do, a progress bar is 
displayed while optimization is performed. Click Cancel Speed Test at any time to 
cancel your optimization request.

13. Click OK when finished.
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Modifying Microsoft Stream Destination Settings
In order to broadcast using Microsoft Stream, you must first configure your streaming 
using Office 365. For a detailed procedure on how to do this visit the Telestream 
website at: Publish to Microsoft Stream

1. When Wirecast displays the Output Settings window, select Microsoft Stream as your 
Destination, and click OK.

2. When Wirecast displays the Output window, select an Encoder and Audio Track for 
the stream. Paste in the address copied from Office 365 where streaming was 
initiated.

3. (Optional) Enter a Stream Delay if needed. Click Ok when finished.

4. (Optional) Click the Map button to open the Muti-Track Input Mapper. For each 
channel, select (by checking the box) one or more inputs.

Click OK when finished.

Modifying YouTube Destination Settings

Note: Custom encoders cannot be used to stream to YouTube. They may only be used 
to encode a recording to disk.

To stream to YouTube, follow these steps:

1. Log into your YouTube account using your browser.

2. (Optional) Enter a Name for your destination.

3. Select YouTube from the Destination menu.

4. Select an encoder.

5. (Optional) You can click the Map button to open the Multi-Track Input Mapper. For 
each channel, check the box for one or more inputs.

6. Check Use Backup Server if you get an error when authenticating, or the application 
tries to connect and then crashes.

Note: At times the primary streaming servers at YouTube go down for maintenance 
or other reasons. When Wirecast users attempt to connect to these servers, especially 
when using YouTube's “Stream Now” feature, they are unable to connect.

7. Click the plus (+) icon to add a new event.

Note:  If you do not have a YouTube account, click Sign Up (or go to 
www.youtube.com).

8.  Enter all of your event information and click Save.


https://support.telestream.net/s/article/Wirecast-10-Publish-to-Microsoft-Stream
www.youtube.com
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Note: Click the Details button to get more information from Google.

9. Click Authenticate, enter your login information, and wait for your event to appear 
in the Event menu box. Click the minus icon (-) to remove a selected event. 
Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. Click OK when finished.

Note: If you are not already signed in, Wirecast launches a window enabling you to 
sign into your YouTube account. Enter your account information and click Sign In.

See also Wirecast: Output Destination - Youtube (RTMP).

Encoder Presets
Without compression, the bandwidth of audio-video data can be too large to 
successfully broadcast across a network. An encoder is a program that compresses 
audio, video, or both, for broadcast. Wirecast supports a wide variety of encoders, also 
known as codecs.

The settings for encoders range from simple to very complex. Wirecast offers presets of 
the most common settings for encoders. This provides a starting point, reduces 
complexity, and enables you to experiment and adjust settings as you test your 
broadcast.

Note: You can edit Encoder Presets from the Output Settings window. To do this, 
select Output > Output Settings, click the gear icon, then choose View Details from the 
drop-down menu.

See The Encoder Presets Window.

Selecting an Encoder Preset
To use an encoder other than the default, select an encoder from the Encoding drop-
down menu in the Output Settings dialog.

Note: Click More next to the Destination field to display a list of all available 
destinations. Check the box for each destination you want to include in the 
destination menu list.

Note: Click Filter from the gear menu next to the Encoding field to display a check list 
of encoder presets. Check the presets you want to display in the Encoder Presets menu. 
Click Save when finished.


https://support.telestream.net/s/article/Destination-RTMP-YouTube-Live
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Creating an Encoder Preset
The default encoder presets cannot be changed. However, you can make a copy of any 
preset, modify it as needed, and save it under a new name. You can refer back to the 
default presets at any time since they are never modified.

To edit an encoder preset, do the following:

1. Select Window > Encoder Presets.

2. Select a preset to edit from the Encoder Preset drop-down menu.

3. Change the settings as desired.

4. Click Save As. Enter a name for the edited preset.

5. Click OK.

Note: Click New Preset from the Gear menu next to the Encoding field to create a new 
encoder preset. Enter a name for your new preset and click OK.

Note: Click View Details from the Gear menu next to the Encoding field to modify an 
encoder preset. One important option is Strict Constant Bitrate. When checked, the 
bitrate is strictly held at the bitrate entered in Average bit rate.

Modifying the MainConcept H.264 Preset
To modify a MainConcept H.264 preset, follow these steps:

1. Select Window > Encoder Presets.

2. Select the MainConcept H.264 encoder preset from the Encoder drop-down menu.

3. To encode video, check the Video Encoding checkbox.

When checked, Wirecast encodes the video for your broadcast. When Video Encod-
ing is unchecked, the output contains a blank video screen.

Note: To create an audio-only broadcast, uncheck Video Encoding and check Audio 
Encoding (AAC). To create a video-only broadcast, check Video Encoding and uncheck 
Audio Encoding (AAC).

4. Enter the desired width, in pixels, into the Width field.

5. Enter the desired height, in pixels, into the Height field.

6. Select the desired framerate, into the Frames per second field. This value is a target 
value for the encoder. The exact value of the output is not guaranteed.

7. To encode your video at a target average bit rate (ABR), enter the target bit rate for 
your broadcast in Kbits (1000 bits) per second into the Average bit rate field. Higher 
numbers provide better quality, but you should limit the speed to the bandwidth 
available to your target audience. With ABR, the bitrate varies around this target. At 
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a specific moment, the bitrate may be higher or lower than the target rate. 
Alternatively, consider encoding at a constant bit rate (CBR). See below.

8. Select an encoder profile from the Profile menu. Three profiles are provided: 
Baseline, Main, and High. The Baseline profile is commonly used in mobile 
applications and other applications operating with limited processing power, 
storage capacity, or bandwidth. The Main profile is appropriate for general-purpose 
applications of broadcast media and high-bandwidth Internet broadcasting. The 
High profile provides the highest broadcast-quality encoding.

9. (Optional) Key frame every allows you to enter the number of frames between the 
key frames Main Concept creates. The more often Main Concept creates a 
keyframe, the better the video quality, but, the greater the bandwidth required.

10. (Optional) To determine the number of frames between timecode stamps, check 
the Timecode Every checkbox and enter the number of frames. Main Concept 
embeds timecode stamps in the flash stream. If you enter the value of zero, Main 
Concept doesn’t embed timecode.

11. (Optional) To encode your video at a constant bit rate (CBR) instead of at an average 
bit rate (ABR), check Strict Constant Bitrate. Disabling CBR can result in slightly 
improved quality and decrease file size, but at the cost of greater bit rate 
fluctuations. This could prove troublesome for certain streaming destinations. 
Selecting this option for recording is not recommended because it can result in 
decreased quality and larger files, with no real benefit. Alternatively, consider 
encoding at an average bit rate (ABR). See above.

12. (Optional) When checked, Keyframe Aligned facilitates adaptive bitrate streaming 
by ensuring that keyframes from multiple streams are in sync, along with the 
keyframes, timestamp, DTS and PTS values. This is true only if those other streams 
also have the option turned on and have the same keyframe interval. To accomplish 
this, Wirecast disables scene detection and manually inserts the keyframe at the 
exact keyframe interval specified. Therefore, to ensure quality and smooth 
switching in the player, the keyframe interval should be between one- to four-
second range. When you enable Keyframe Aligned, absolute timestamp also is 
enabled.

13.  (Optional) When you check the Audio Encoding (AAC) checkbox, Main Concept 
encodes the audio for your broadcast. When Audio Encoding (AAC) is unchecked, 
the output contains no audio track.

14. Select the type of audio channels: Mono or Stereo. Mono uses less bandwidth than 
Stereo.

15. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate 
menu. This is the target bit rate for your audio. Higher numbers provide better 
quality, but you should limit the speed to the bandwidth available to your target 
audience. The encoder compresses the audio to approximate this target. However, 
at different times during your broadcast the bit rate may be higher or lower than 
the target rate. The total broadcast bit rate is a function of video bit rate plus audio 
bit rate.

16. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample rate 
menu. This value specifies how many thousands of times per second to sample the 
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audio in the broadcast. Higher values provide better quality sound, but at greater 
bandwidth.

17. Click Save to save your settings.

See The Encoder Presets Window.

Modifying the x264 Preset

Note: The x264 implementation of the H.264 standard results in better quality and 
lower CPU usage for any given bitrate, but at the cost of higher memory usage. The 
default implementation is based on the MainConcept codec and uses less memory.

To modify an x264 preset, follow these steps:

1. Select Window > Encoder Presets.

2. Select an x264 from the Encoder menu.

Note: See The Encoder Presets Window.

3. Check the Video Encoding checkbox. When checked, the video for your broadcast is 
encoded. When unchecked, a blank video screen is provided. This is the preferred 
method of producing audio-only broadcasts.

4. Enter the Width of your broadcast video.

5. Enter the Height of your broadcast video.

6. Select the desired frames per second (fps) of your broadcast. This value is a target 
value for the encoder. The exact value is not guaranteed.

7. To encode your video at a target average bit rate (ABR), enter the target bit rate for 
your broadcast in Kbits (1000 bits) per second into the Average bit rate field. Higher 
numbers provide better quality, but you should limit the speed to the bandwidth 
available to your target audience. With ABR, the bitrate varies around this target. At 
a specific moment, the bitrate may be higher or lower than the target rate. 
Alternatively, consider encoding at a constant bit rate (CBR). See below.

8. Select encoding quality (Ultra fast to Very slow encoding). Slower encoding results 
in better quality.

9. In the x264 command line options edit box, enter any command line options you 
want included.

10. Select an encoder profile from the Profile menu. Three profiles are provided: 
Baseline, Main, and High. The Baseline profile is commonly used in mobile 
applications and other applications which operate with limited processing power, 
storage capacity, or bandwidth. The Main profile is appropriate for general-purpose 
applications of broadcast media, such as high-bandwidth Internet broadcasting. 
The High profile provides the highest broadcast-quality encoding.

See Profile.
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11. (Optional) Key frame every allows you to enter the number of frames between the 
key frames x264 creates. The more often x264 creates a keyframe, the better the 
video quality, but, the greater the bandwidth required.

12. (Optional) To encode your video at a constant bit rate (CBR) instead of at an average 
bit rate (ABR), check Strict Constant Bitrate. Disabling CBR can result in slightly 
improved quality and decrease file size, but at the cost of greater bit rate 
fluctuations. This could prove troublesome for certain streaming destinations. 
Selecting this option for recording is not recommended because it can result in 
decreased quality and larger files, with no real benefit. Alternatively, consider 
encoding at an average bit rate (ABR). See above.

13. (Optional) Check Keyframe aligned.   When checked, it facilitates adaptive bitrate 
streaming by ensuring that keyframes from multiple streams are in sync, along with 
the keyframes timestamp, DTS and PTS values. But this is true only if those other 
streams also have the option turned on and have the same keyframe interval. To 
accomplish this, Wirecast disables scene detection and manually inserts the 
keyframe at the exact keyframe interval specified. Therefore, to ensure quality and 
smooth switching in the player, the keyframe interval should be in the 1 to 4 
second range. When Keyframe Aligned is enabled, absolute timestamp is also 
enabled.

14. (Optional) To determine the number of frames between timecode stamps, check 
the Timecode Every checkbox and enter the number of frames. x264 embeds 
timecode stamps in the flash stream. If you enter the value of zero, x264 doesn’t 
embed timecode.

15. (Optional) When you check the Audio Encoding (AAC) checkbox, x264 encodes the 
audio for your broadcast. When Audio Encoding (AAC) is unchecked, the output 
contains no audio track.

16. Select the number of channels: Mono or Stereo. Mono uses less bandwidth than 
Stereo.

17. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate 
menu. This is the target bit rate of your audio. Higher numbers provide better 
quality. The connection speed of your audience is a significant factor in 
determining your target bit rate. The encoder compresses the audio to 
approximate this target. However, at different times during your broadcast the bit 
rate may be higher or lower than the target rate. The total broadcast bit rate is a 
function of video bit rate plus audio bit rate.

18. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample rate 
menu. This value specifies how many thousands of times per second to sample the 
audio in the broadcast. Higher values provide better quality sound, but at greater 
bandwidth.

19. To save your settings, click Save.

See The Encoder Presets Window.
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Mapping Audio Tracks to Output Audio Channels
You can determine the output audio destination channels for each of the audio tracks 
available in a Wirecast document. To map audio tracks to output audio channels, do the 
following:

1. Click Output > Output Settings.

Wirecast opens the Output Settings dialog.

2. Click the Map button.

See Map Button.

Wirecast opens the Multi-Track Input Mapper window.

See The Multi-Track Input Mapper.

3. In each Channel row, click the checkbox for each track you want to send to that 
output audio channel.

4. To close the Multi-Track Input Mapper window, click the “x.”

Mapping Audio Mixes to Playback Devices

There are times when you want to route different audio mixes to different destinations. 
For example, you might want to send a mix without microphone audio to your 
announcers, and a full mix, including mics, to the producer. In Wirecast, you can assign 
one playback device to announcers and another to the producer. Then, map the audio 
tracks desired to each playback device.

Note: You can route up to four output channels to audio devices.

To map an audio track to a playback device, do the following:

1. In the audio mixer, click Add new audio output.

Wirecast opens a new Audio Output box to the right of the Final Mix.

2. In the Audio Playback drop-down menu, select the playback device desired.

3. In the Audio Track Selection drop-down menu, select the track required.

See The Audio Mixer Window and The Multi-Track Input Mapper.

Streaming
To start steaming, do the following:

1. Click the Stream button.

See the Stream button on the screenshot in Control/Status Bar.

PRO
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The Stream button blinks green until a connection is made. Once you are connected, 
the Stream icon turns unblinking green. If you can’t connect, Wirecast displays an error 
message.

If you are streaming to Facebook, Wirecast displays additional statuses on the right side 
of the status bar.

Figure 5. The Status Bar

         

See Streaming Status Colors.

1. (Optional) To record your broadcast click Record.

2. To stop streaming, click Stream again.

Streaming Status Colors
Wirecast indicates connectivity strength by the number of bars displayed in the Stream 
icon. Fewer bars indicate lower speed or connection reliability issues. If packets aren't 
reaching the destination server, Wirecast buffers the packets. When this happens, the 
green streaming indicator turns yellow and Wirecast continues sending those packets 
in an attempt to reach the destination server.

If packets continue to fail to reach the server, Wirecast drops packets, and the streaming 
indicator turns red. When Wirecast stops attempting to send packets, Wirecast displays 
the red Failed icon .

When the connection is recovered, Wirecast replaces the red Failed icon with green 
bars.

Buffer Utilization
When streaming over RTMP, there is a buffer for the packets called the flash queue.

The buffer is utilized to handle scenarios where the Internet uplink to the RTMP 
endpoint (CDN) temporarily is unable to deliver at a fast enough rate. Any of the 
following can cause a slow-down:

• Your local LAN is saturated

• Your ISP uplink is saturated

• The route from your ISP to the end point is compromised or saturated

• The endpoint is saturated

Number of Likes

Number of 
viewers

Number of comments
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• Any degradation in transmission speed from Wirecast to the CDN endpoint.

Colors
• Green will be shown when the flash queue is able to be emptied just as fast or 

faster than it is able to be filled.

• Yellow will be shown when the flash queue has grown, but is not yet approaching 
overload.

• Red will be shown when the flash queue is just about to be full, in which packets 
will be lost.

 Example 1
• Encoding is set to 7Mbps

• ISP upload speed is 7Mbps

• Video content was fairly still, but a scene change or shot switch occurs that is fast 
motion.

• The encoder bursts to handle the more complex content, and momentarily requires 
8Mbps to properly deliver the content.

• The flash queue is only able to output at 7Mbps, so it grows with more frames/
packets backed up.

• The Icon color turns Yellow, to alert this state.

• The encoder catches up, and settles back down to 5Mbps after the scene change.

• The Icon returns to green.

Example 2
• Encoding is set to 5Mbps

• ISP upload speed is 7Mbps

• Video content is running fine, with green Icon.

• Someone else on the network begins uploading at 4Mbps, perhaps an Aspera 
transfer if you remember those taking down Telestream's network...

• The available bandwidth to the stream is 3Mbps during this usage.

• The icon will turn yellow, then turn red.

• If the queue stays red for long enough, the stream disconnects.

Example 3
• Encoding is set to 5Mbps

• ISP upload speed is 7Mbps

• Video content is running fine, with green Icon.

• The ISP oversold their network, and some neighboring business or residents all 
hopped on the Internet at the same time.

• The available upload speed drops to 5Mbps
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• The icon drops to yellow, then to red.

• The icon stays red, and the stream continues.

• Viewers are still seeing the stream despite the icon being red.

• The flash queue is able to unload the packets during downward bitrate fluctua-
tions, and builds more packets in buffer during upward bitrate fluctuations, just 
enough that the queue stays in this almost-full-but-hasn't-burst state.

Troubleshooting Connectivity for Streaming
You can test for server-side issues by running a test stream to a test server. If you get a 
continuous green streaming indicator to the test destination, but poor streaming to 
your regular destination server, the problem probably lies with the destination server. 
Contact the CDN host and report the destination-server problem.

To test for Internet ISP problems, run a speed test. Note upload speed and packet loss. 
Your combined encoder settings to all destinations should total no more than half the 
tested upload speed. Streaming requires this headroom because both the sending data 
rate and the ISP upload bandwidth can vary from moment to moment. Actual upload 
speed often varies from the speed claimed by an ISP.

Keep packet loss at 0%. Any other number indicates packet loss. If you are losing 
packets, have the ISP run tests to your point-of-origin broadband connection.

While streaming from Wirecast, keep CPU use under 60% for optimal performance. If 
CPU usage exceeds 80% a variety of problems might occur, including disconnection.

Limiting Reconnection Attempts
When Wirecast loses an Internet connection, Wirecast attempts to reconnect. Each time 
Wirecast attempts reconnection, the Stream icon blinks.

To limit the number of reconnection tries, do the following:

1. Select File > Preferences > General.

2. Enter a value into the field, Maximum Reconnect Attempts.

3. To close the Preferences dialog box, click the “x.”

Configuring Replay + ISO
 

Replay enables you to repeatedly play a clip, or even a portion of a clip, any number of 
times. You can also replay playlists (see Viewing the Countdown Timer for a Shot). This 
makes the combination of Playlist and Replay a very powerful production tool.

ISO (or Isolated Output) recording allows users to record system devices (cameras, 
capture cards, or mics) not being broadcast. This enables you to broadcast one device 
while recording another. You also can set up ISO sources as replay sources. Wirecast 

PRO
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provides all replay functionality, such as keyboard shortcuts, mark-in, and mark-out, for 
ISO sources.

Replay and ISO share the same menu because you can set up ISO sources for replay. You 
can toggle this functionality in the ISO Settings window. If you set an ISO source for 
replay, Wirecast applies the replay settings configured in the Replay+ISO window to the 
ISO source.

Note: Wirecast doesn’t render multiple replay clips captured during the same replay 
session when played at the same time on different main layers or on different shot 
layers.

To use the Replay feature, first set it up the way you want it to perform. To set up Replay, 
do the following:

1. Select Replay+ISO > Configure.

2. Check the Program Replay box.

3. Choose the settings desired. Descriptions of the settings follow.

Capture Audio in the Replay

Check the Audio box to capture audio in the replay you’re creating. If unchecked, all 
audio is ignored.

Video Quality

Set the video quality for Standard or High. Depending on the quality you choose, 
Wirecast displays an estimate of the write rate.

Folder

Click Browse and navigate to the location where you want to store your replay shots.

Create Replay Keyboard Shortcut

Select a keyboard shortcut from the drop-down menu that will activate the Create 
Replay function.

Update Replay Keyboard Shortcut

Select a keyboard shortcut from the drop-down menu that will activate the Update 
Replay function.

Mark Replay Keyboard Shortcut

Select a keyboard shortcut from the drop-down menu that will activate the Mark Replay 
function.

Manage

Opens the Preferences > Shortcuts window so you can add, delete or change your 
application shortcuts and document hotkeys. Check the Global check box if you want 
that hotkey to be available in the drop-down menus above.

4. Click OK.

See Replay + ISO Menu and Replay Shots.
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Activating Replay

Note: When Replay is activated, CPU usage increases.

To activate Replay, select Replay > Start All.

The Start All menu item becomes Stop All and Wirecast adds buttons to the Wirecast 
default layout: Set Replay Mark In and Update Replay Shot.

Once Replay has been activated it keeps all shot activity (playing of clips or capturing of 
live sources) in the Replay buffer on disk. The amount that is saved when the Create 
Replay Shot button is pressed depends on the value entered into the Default Replay 
duration setting.

See Replay Shots.

Configuring ISO Recording
ISO (or Isolated Output) recording is a Wirecast Pro feature that allows you to create 
clean recordings of your system devices (cameras, capture cards, or mics) even when 
they are not being displayed in the Live Broadcast Area. This can be useful when 
creating a video-on-demand version of your live show. You can save full recordings of 
all your cameras even when they weren't live in your broadcast.

There are two ways to record ISO sources:

• Capture Source ISO allows you to choose one source to record, such as a webcam or 
a microphone. This makes an isolated source recording. If your source includes 
audio, you can capture that audio with Capture Source ISO. This option doesn't 
enable you to combine separate audio and video raw sources into one ISO record-
ing.

See Capture Source ISO.

• Shot ISO lets you record any shot that is on your Main Shot Display. You can mix two 
or more sources into a single shot. You can record ISO sources, such as WebRTC 
(Rendezvous and Wirecast Go), NDI, Webstream, or Elgato sources, that are not sup-
ported by the Capture Source ISO option.

See Shot ISO.

1. To configure a source for ISO recording select Configure from the Replay+ISO menu.

2. Click Add ISO. Configure as desired.

Note: If you want to record audio that is coming from a separate source, such as from 
a separate microphone, you can set up ISO recording for the separate source via 
Capture Source ISO. Alternatively, you can place your chosen video and audio sources 
into a single shot on the Main Shot Display and use Shot ISO to record that multi-source 
shot.
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Capture Source ISO
Capture Source ISO lets you record an individual ISO camera or audio source. For 
example, you can record a Facetime session from a phone, or video and audio from a 
camera plugged into a capture card.

Note: Certain sources, such as Rendezvous guests, Web Stream sources, IP Cameras 
sources, Web Page plugin sources, or Wirecast Go sources will not show up as available 
Capture Source ISO sources. To record these, you should use Shot ISO.

If your chosen source produces both video and audio, you have the option to include 
which media tracks are included from your single source.

Note: Wirecast splits pre-Wirecast 14.1 ISO-configured documents containing video 
and audio from two different sources into two separate source recordings: one for 
audio, one for video.

Shot ISO 
Shot ISO lets you record any ISO shot on the Main Shot display. You can combine any 
audio and video sources into a shot. You can also record shots that contain sources that 
aren't available in Capture Source ISO, such as Rendezvous guests and IP camera 
sources.

If your chosen shot has both video and audio, you have the option to choose which 
media tracks are included from the shot.

Shot ISO recordings produce video at the canvas resolution and frame rate. You can 
adjust these in Preferences > Canvas. Audio settings match the Wirecast internal mixer 
settings: stereo, 32-bit float, 48 kHz.

Note: Shot ISO recording doesn’t play animated graphics or media files contained in 
your source. If you don't want a static image to appear in place of the graphics or 
media, place that source in a different shot on a different layer.

Audio-Only Recordings You can make audio-only ISO recordings, using either Capture 
Source (if your source is audio) or Shot ISO (if your shot includes only audio).

The ISO configuration dialog displays the current video resolution and frame rate for 
the selected source, as well as the number of audio channels, bits per sample, and 
sample rate. When no source is selected or the source does not produce a certain type 
of media, Wirecast displays None next to the corresponding video and audio track 
checkboxes.

ISO Recording Formats
• QuickTime: ProRes Video + Uncompressed Audio: ProRes is better suited for NLE 

work. Also, color space information is less ambiguous.
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• QuickTime: x264 Video + Uncompressed Audio:

– x264 is a compressed video file that results in significantly smaller file sizes.

– x264 recordings are still placed in QuickTime files and still paired with 
uncompressed audio. Uncompressed audio offers top quality and minimal CPU 
drain for archival purposes.

– You can choose the bitrate and keyframe interval for recordings that use x264 
encoding.The default values are 10 Mbps with 15 frames/second. The defaults 
were chosen for high quality full HD archival. We use the high-profile encoder 
setting and the “fast” x264 algorithm with variable bitrate encoding.

Quality
Wirecast offers the ability to encode your files using ProRes or x264 on both Mac and 
Windows.

Filename
The filename for each new ISO recording includes the next number in a sequence that 
begins with 1. For example, Wirecast names the first ISO file “ISO 1", the second “ISO 2", 
the third “ISO 3", and so on. Name-sorted listings of recordings on disk remain in order 
beyond the ninth ISO configuration.

You can choose another name for an ISO file, but that will not affect the automatic 
sequential naming. If you rename “ISO 1" to “Names Don't Matter,” Wirecast still names 
the next file “ISO 2" by default.

Folder Wirecast remembers the last folder you assigned to an ISO recording 
configuration and uses that folder as the default for the next configuration you create. 
Wirecast applies this setting to all projects.

Replay Check this to make your ISO recording available for instant replay within the 
broadcast. You can apply this setting for files created through Capture Source ISO as well 
as through Shot ISO.

See tutorials on Replay for information on configuring ISO replays.

File Options
Single File

This is best used if you have shorter broadcasts and have plenty of disk storage space. 
When you choose Single File, you're choosing a 12-hour maximum file duration.

New File Every

This ensures you don't generate files larger than available disk space. If you have a long 
broadcast or limited space, consider limiting your ISO file sizes. This option breaks long 
recordings into files at the duration you specify.

See Starting your ISO Recording.
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Recommended Minimum System for ISO Recording
ISO recording is resource intensive. Recording individual cameras or shots alongside 
the actual production requires a powerful system.

For ISO recording, the minimum recommended system includes:

•  An i7 processor

•  A high-end dedicated graphics card

•  An SSD for recording

Recording To Disk
If you want to archive your stream, you can use the Record To Disk destination.

To record to disk, do the following:

1. Click the Record button (or ISO Record button) at the top of the Wirecast default 
layout.

Wirecast opens the Output window.

2. To add a recording destination, click the Add button at the bottom of the window.

Wirecast displays a dialog box.

3. Select Record to Disk and click OK.

4. In the Output Settings window, select Record To Disk (MOV, MP4 or Windows Media).

5. Select an encoder.

6. Click Browse or enter the path to the location where you want your recording saved.

7. Select a recording mode: Use Filename Only, Auto Increment Filenames, or 
Timestamp Filenames. If you select Auto Increment Filenames, your filename will 
have an incremental number appended to the end of it. This causes a new file to be 
created every time you start recording to disk. If you select Use Filename Only your 
previous file is overwritten.

8. Click OK.

Note: When recording to disk on FAT32-formatted drives, single files can’t be larger 
than 4GB in size. So, recording files larger than 4GB to a FAT32-formatted drive may 
result in files that do not close properly. We recommend you record to disk on a 
Windows NTFS formatted partition whenever possible.
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Live Broadcast Production

Once you’ve created a document and have configured the inputs and outputs for your 
broadcast, you’re ready to broadcast with Wirecast.

Topics
■Launching Wirecast 100

■Switching 100

■Viewing the Countdown Timer for a Shot 101

■Broadcasting 102

■The Final Mix Audio Panels 102

■Viewing a Layer in a Layer Window 104

■Social Media Comments 104

■Creating a Border 106

■Controlling a PTZ Camera 106

■Starting your ISO Recording 107

Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop 
during installation.

Switching
You can view shots in the Preview Area before taking them live, or you can take shots 
live in one click, without previewing.

Switching with Preview
Do the following to switch shots when AutoLive is disabled:

1. Click a shot in a layer, or several shots in different layers.

Wirecast displays the shots in the Preview Area.
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2. Click a Transition Controls button. Alternatively, press the keyboard shortcut Ctrl+1 
to select the first Transition Controls button or Ctrl+2 to select the second Transition 
Controls button.

See the Transition Controls button on the screenshot in The Default Layout.

3. Click the Go button.

Wirecast places the shots in the Preview Area into the Live Broadcast Area, and 
broadcasts the shot.

See AutoLive, The Default Layout, Final Mix Audio Panel, and Go Button.

Switching to a Playlist
Switching to a playlist is the same as switching to any other shot. To switch to a playlist, 
when AutoLive is disabled, do the following:

1. Select the playlist shot.

Wirecast displays the shot in the Preview Area.

2. Click the Go button.

Wirecast displays the shot in the Live Broadcast Area, and broadcasts the shot.

See AutoLive, The Default Layout, and Go Button.

Single-Click Switching with AutoLive
To switch shots when AutoLive is enabled, click a shot in a layer.

Wirecast places the shot in the Live Broadcast Area, and broadcasts the shot.

Note: When you select multiple shots on multiple layers, Wirecast displays all of them 
in the Live Broadcast Area, with layer 1 on top and layer 5 at the bottom.

See AutoLive, The Default Layout, and Go Button.

Viewing the Countdown Timer for a Shot
See Playlist Countdown Timer Display.

The countdown timer under the Live Broadcast Area can show the countdown for any of 
the shots, including playlist shots, displayed in the Live Broadcast Area.

To select a shot for the countdown timer, take one or more shots to the Live Broadcast 
Area. Then, do the following:

1. To open the counter display mode menu, click the gear icon under the Live 
Broadcast Area.

2. Do one of the following:
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• Select the top item (the name of the currently playing shot) to display its count-
down time alone.

• For a playlist, select the bottom item (New Playlist - Completion) to display the 
countdown time of the current shot and of the playlist.

Broadcasting
Before you can broadcast with Wirecast, you must configure your output settings.

See Selecting a Destination.

To start broadcasting, select Output > Start/Stop Broadcasting > Start All.

Note: If you try to broadcast without first configuring an output, Wirecast opens the 
Output Settings window for you. See The Output Settings Window.

Taking a Snapshot of the Live Broadcast Area
You can take snapshots of the Live Broadcast Area on-the-fly. Wirecast saves the 
snapshots as PNG files in the folder designated for snapshots. To take a snapshot of the 
Live Broadcast Area, do the following:

1. Make sure the snapshots are kept in a folder convenient for you.

See Live Snapshots Folder.

2. Start broadcasting.

See Broadcasting.

3. When the desired frame appears in the Live Broadcast Area, click the Snapshot 
button.

See Snapshot Button.

The Final Mix Audio Panels
With the Final Mix Audio panels, you can set the volume level, or you can mute the final 
mix audio level, for the Preview Area or the Live Broadcast Area. There are separate Final 
Mix Audio panels for the Preview Area and for the Live Broadcast Area. The controls for 
both Final Mix Audio panels work the same way.

See Final Mix Audio Panel.

Displaying the Audio Mixer
To display the Wirecast audio mixer, select Window > Audio Mixer.

See Window Menu.
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Displaying or Hiding the Final Mix Audio Panel
To display Final Mix Audio for preview and live displays, select Layout > Final Mix.

To hide Final Mix Audio select Layout > Final Mix again.

See Final Mix Audio Panel.

Controlling or Muting the Final Mix Audio Level
To control the volume for either the Preview Area or for the Live Broadcast Area, select 
the respective Final Mix Audio panel, and do one of the following:

• To set the volume, click and drag the slider control up or down.

The decibel scale next to the slider indicates the audio level. When you take a pre-
view shot live, the live audio levels match the levels set in preview.

•  To mute the audio output, click the Mute button.

See Final Mix Audio Panel.

Adding a Filter to an Audio Channel
To add a filter to an audio channel, do the following:

1. Open the audio mixer.

See Displaying the Audio Mixer.

2. In the Live Sources pane, click the Add New FX button.

Wirecast opens a drop-down menu of available effects.

3. Select an effect.

Wirecast adds the name of the selected effect to the Live Sources pane of the audio 
mixer.

See also Adding VST Plugins to the Available Audio Plugins.

Adding a Filter to the Final Audio Mix
To add a filter to the final audio mix, do the following:

1. Open the audio mixer.

See Displaying the Audio Mixer.

2. In the Final Mix pane, click the Add New FX button.

Wirecast opens a drop-down menu of available effects.

3. Select an effect.

Wirecast adds the name of the selected effect to the Final Mix pane of the audio 
mixer.

See also Adding VST Plugins to the Available Audio Plugins.
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Viewing a Layer in a Layer Window
To open any layer in its own window, do the following:

1. Select Window > New Layer Window.

Wirecast displays a list of the layer windows you can open (Main Layer 1 through 
Main Layer 5).

2. Select the layer you want to open.

Wirecast displays the layer in a separate layer window.

This separate layer window works exactly like the layers in the default display, but you 
can move layer windows independently of one another.

See also Layers.

Social Media Comments
You can include comments made by viewers on various social-media platforms in your 
broadcasts, through the Comment Moderation window.

See Social Media Shots and The Comment Moderation Window.

Sorting Social Media Comments
To sort social media comments by super-chat comments, then favorite comments, then 
all other comments, click the Favorite header in the Comment Moderation window.

See The Comment Moderation Window.

Moderating Social Media Comments
Once you have a social media title in your document, and comments coming into the 
Comment Moderation window, select a comment in the Comment Moderation window, 
and select your social media title in the main shot display.

To moderate comments, do the following.

1. Select one of the following:

– Create Title Shot from the lower-left corner of the Comment Moderation window 
View comments pane.

– (+) Choose Overlays > Social Media Title.

Wirecast opens the Social Media Title window.

2. Select a social media title, and adjust any settings in the Social Media Title Properties 
window.

3. Select Social > Comments.

Wirecast opens the View comments pane on the Comment Moderation dialog box.
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4. Once you have comments coming in, and a social media title in your document, 
click the Live radio button for one or more comments in the Comment Moderation 
window.

The selected comment appears in the Social Media Title in the Preview window.

5. Click Go Live to send the social media title to your live broadcast.

• Once your social media title is live, you can select any other comment in the View 
comments pane on the Comment Moderation window. Wirecast transitions the first 
comment out and the next comment in.

• If you have Rotate Selected.. checked, simply leave your social media title live. Wire-
cast automatically rotates the selected comments into your broadcast.

See Social Media Shots and The Comment Moderation Window.

Moderating Facebook or YouTube Comments for a 
Streaming Computer or RTMP Server

You can moderate Facebook or YouTube comments from a computer that is 
broadcasting your program from Wirecast, while you stream the broadcast to Facebook 
or YouTube via a second computer, streaming server, or RTMP server.

These are two typical scenarios for this method:

• You produce a show using Wirecast on one computer, and transmit the feed to 
another computer or streaming service. The second computer or service streams 
the broadcast to Facebook or YouTube. Some producers use this method to bal-
ance resources between two computers.

• You produce a show using Wirecast, and stream to Facebook or YouTube from the 
same computer. In this scenario, you use a generic RTMP server, not the built-in 
Facebook or YouTube destinations in Wirecast.

Do the following:

1. Make sure you have authenticated Wirecast with the desired social media platform.
See Social Media Shots.

2. To open the Comment Moderation panel select Social > Comments > View active 
accounts.

Wirecast opens the Comment Moderation dialog box to the Active Accounts pane.

3. Click the Add Facebook or YouTube Feed (+) button.

See View Active Accounts.

Wirecast opens the Select Destination dialog box.
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4. Log in using credentials that have rights for the page, group or channel you want to 
access.

Do one of the following:

– Click the name of the social media platform to which you are streaming and from 
which you want to grab comments. Log in with your user account credentials.

– Check the box for Login as new user, create a user account, and log in.

In the Comment Moderation window, Wirecast displays the posts in your feed for 
the platform selected.

Wirecast displays a drop-down menu of events.

5. Choose the name of the event or live stream desired.

Once your stream has started, you should see the comments come through to your 
moderation panel, as you would if you were streaming directly from that computer.

6. Select comments for display as you would when moderating comments on a 
Wirecast computer which is broadcasting.

See Moderating Social Media Comments.

See Social Media Shots and The Comment Moderation Window.

See also How to bring social media comments from a live stream that is not coming from 
your Wirecast system.

Creating a Border
You can add a border around a video layer, and control the parameters of the border. To 
create a border, do the following:

1. Open the Shot Layer Properties tab.

See The Shot Editor Window.

2. To open the border controls, click the triangle next to Border.

3. Adjust the border controls as desired.

See Border.

Controlling a PTZ Camera
To control a remotely-controlled pan-tilt-zoom (PTZ) camera, do the following:

1. Configure Wirecast for the PTZ camera.

See Setting Up PTZOptics Camera with a Dynamic IP Address and Setting Up PTZOptics 
Camera with a Static IP Address.

2.  Select a PTZ camera shot in a layer.

3. In the Shot Layer Properties tab of the Shot Editor, click the triangle next to PTZ, and 
click the PTZ Controller button.

Wirecast opens the PTZ controller panel.


https://support.telestream.net/s/article/Wirecast-15-1-0-How-to-bring-social-media-comments-from-a-live-stream-that-is-not-coming-from-Wirecast-system

https://support.telestream.net/s/article/Wirecast-15-1-0-How-to-bring-social-media-comments-from-a-live-stream-that-is-not-coming-from-Wirecast-system


Live Broadcast Production
Starting your ISO Recording

107

Wirecast User Guide

4. Control the camera with the controls in the PTZ Controller.

See The PTZ Controller Panel and PTZ Control in the Shot Layer Properties Tab.

Starting your ISO Recording
When you finish configuring your ISO sources, you're ready to start recording. There are 
a couple of ways to start your ISO recordings.

1. Click Replay+ISO to open the drop-down menu. Select either Start All or another 
ISO that you have set up.

2. Alternatively, click the ISO-REC button at the top of the default layout. This starts all 
your configured ISO recordings.

See Configuring ISO Recording.

ISO Error Reporting
When starting ISO recordings, Wirecast sends specific error messages to the user-log 
and presents you with a generic modal dialog that reads: “Av recording failed to start. 
View the user log for details and edit the Replay+ISO configuration to resolve issues.” 
The dialog contains an Edit button which opens the ISO configuration dialog.

Many types of ISO recording errors occur after you start recording; some occur soon 
after. These asynchronous errors are reported only in the Notifications window where 
no modal dialog is shown.

Configuration Errors and Warnings
While you interact with the ISO configuration dialog, Wirecast searches for a number of 
configuration errors and potential problems. Warning icons appear in the dialog next 
to the configuration fields. If you hover the cursor over a warning icon, a tool tip 
appears detailing the problem. Also, the topmost warning message appears in red text 
at the bottom of the dialog until all warnings are cleared for the selected configuration.

A warning icon appears near each ISO configuration that has a problem. A list of the 
configuration problems Wirecast detects follows.

•  No source/shot is selected for recording.

•  The recording uses a source or shot that no longer exists.

•  The recording uses the same source or shot as another recording.

•  No media tracks are enabled for recording.

•  The source does not produce media that matches the enabled tracks.

•  The recording uses the same output file as another recording.

•  The file name contains restricted characters.

•  The selected output folder does not exist.
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•  The space available on the selected drive is insufficient for recording.

•  The file duration must be between 10 seconds and 12 hours.

See Configuring Replay + ISO.



Live Broadcast Production
Starting your ISO Recording

109

Wirecast User Guide



Windows, Controls, and Menus 110

Wirecast User Guide

Windows, Controls, and 
Menus

You create broadcasts through the various windows, controls, and menus of Wirecast.

Topics
■The Default Layout 111

■Preview Area 116

■Live Broadcast Area 116

■Final Mix Audio Panel 117

■Layers 119

■Add Shot Window 120

■The Shot Editor Window 141

■The Shot Menu 154

■The Preferences Dialog Box 156

■The Audio Mixer Window 167

■The Output Settings Window 169

■The Encoder Presets Window 171

■The Comment Moderation Window 173

■The PTZ Controller Panel 175

■Menus and Application Keyboard Shortcuts 178

■File Menu 179

■Edit Menu 180

■Switch Menu 181

■Media Menu 183

■Output Menu 184

■Layout Menu 188

■Replay + ISO Menu 189

■Social Menu 190

■Window Menu 191

■Help Menu 197
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The Default Layout
When you create a new document, Wirecast displays the document in the default 
layout. The main elements of the Wirecast layout are labeled in the following screen 
shot, and are described below.

Figure 6. The Default Wirecast Layout

Control/Status Bar
Control buttons and status information are displayed at the top of the default layout.

Wirecast displays the following controls and statistics:

Stream button

When clicked, Wirecast begins streaming.

Menu Bar
Mode Selection Buttons

Go Button

Open 
Shot 
Editor

Final Mix Audio Panel
Live Broadcast Area

Preview Area

Control/Status Bar

Layers Transition Controls Button 2

Snapshot Button

Transition Controls Button 1

Output Settings

Record
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Figure 7. The Control/Status Bar

Streaming time

Total cumulative time the document has been streamed. This value does not reset 
when you start/stop the broadcast. If you save portions of the broadcast to disk, 
Wirecast still displays the total cumulative time.

Record Button

Click to begin recording.

Recording Time

This displays how long you have been recording. This value does not reset when you 
start/stop the broadcast. It is cumulative.

ISO Record

Click to begin ISO recording.

ISO Record Time

Displays the ISO recording time.

Multiviewer/Secondary Live Output Button

Opens the configuration window if you haven’t already configured your displays. Once 
you've configured your displays, this button places the windows on your displays as 
configured.

Display Buttons

These three buttons enable you to choose to display the Preview Area, the Live 
Broadcast Area, or both in a divided display.

Note: To avoid decrease in video quality, Wirecast should not be used at CPU usage 
above 80%. See the Telestream Website for suggested configurations. You can also 
view streaming statistics by selecting Output > Show Statistics.

Stream button

Recording Time
ISO Record Time

Record Button
Streaming time

Multiviewer/Secondary Live 
Output Button

ISO Record
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Transition Buttons
Wirecast displays up to four transition buttons: up to three Transition Controls buttons, 
and the Go button. You can assign transitions to the Transition Controls buttons. 
Typically, use Cut as the standard first transition control, and Smooth as the standard 
second transition control. Clicking the Go button executes the selected transition 
control.

Note: Preferences > General enables you to determine the number of Transition 
Controls buttons Wirecast displays (between 0 and 3).

Changing Transitions
Click the Cut button to make it the current transition type.

You can also select one of the two buttons by pressing Ctrl+1 or 2 keys for the two 
transition types displayed.

If you click the down-arrow on the right side of any of the transition buttons, you can 
select a new transition to assign to that button.

Go Button
When clicked, Wirecast executes the transition selected, broadcasts the shot selected, 
and displays it in the Live Broadcast Area.

If AutoLive is enabled, the Go button appears with a red dot. When AutoLive is enabled, 
simply selecting a shot--without clicking the Go button, broadcasts the shot.

With AutoLive enabled, clicking the Go button updates the live shot with any changes 
you have made to it with the Shot Editor. If you have made no changes to the live shot, 
clicking the Go button does nothing when Wirecast is in AutoLive mode.

With AutoLive disabled, you can make several changes to your broadcast without your 
viewers seeing the change. This is most useful when an engineer runs your broadcast.

See Single-Click Switching with AutoLive and AutoLive.
See Selecting and Customizing Encoder Presets and Specifying the Transitions for the 
Transition Buttons.

Mode Selection Buttons
Button containing green and red dots

When clicked, Wirecast displays both the Preview Area and the Live Broadcast Area.

Button containing green dot

When clicked, Wirecast displays the Preview Area.

Button containing red dot

When clicked, Wirecast displays the Live Broadcast Area.
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Note: These three buttons work the same as three of the options in the Layout Menu. 
See Layout Menu.

Playlist Controls
Wirecast provides basic playback controls for playlists. The controls are located at the 
bottom of the Playlist tab window and in the Source Properties tab for a selected playlist. 
You can transition to the previous or next shot in the list, set playlist behavior, shuffle 
the playlist order, and more.

See Source Properties Tab.

Figure 8. Playlist Controls

Total Shots

Displays the total number of shots in the playlist.

Duration

Displays the duration of the playlist.

Resume

When checked, if you exit the playlist, when you return the playlist will resume playing 
at the location (same shot) as when you exited.

Shuffle

Click to shuffle the order of the playlist shots. 

Previous

Transitions to the previous shot in the playlist if the playlist is currently live.

Next

Transitions to the next shot in the playlist if the playlist is currently live.

When Finished

Sets the behavior of the playlist when the last shot in the list has been played. A check 
mark indicates what menu item (behavior) is selected.

Duration Previous
Transition

Next When Finished

Total Shots

Resume

Shuffle 
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• Loop transitions back to the first shot, endlessly.

• Hold stays on the last shot. If the last shot is a clip, the last frame in the clip is dis-
played. If the last shot is a live shot, the live source stays active. If the last shot in a 
Playlist is a video clip Shot, it will obey the rules set for the video clip in the Media 
Properties Inspector tab under Source Properties. However, it will hold the Playlist 
on that last Shot if Set Playlist Behavior is set to “Hold”. Therefore, if you want to see 
the last video in the Playlist pause on the last frame, you must set When Finished to 
“Hold” under Source Properties, in addition to setting the playlist behavior to 
“Hold”. If you set When Finished to “Loop”, under Source Properties, the last video in 
the Playlist will continue to loop. 

• Available Shots transitions to another shot on the same layer. All available shots are 
listed as menu selections. (In the example shown, the only available shot is “Logo”.)

• Previous Live Shot transitions back to the shot that was live before the playlist began 
playing.

• Current Preview transitions the contents of Preview to the Live Broadcast Area.

Transition

Sets the transition to use when switching between shots.

Replay Controls
When you select Replay + ISO > Start All, Wirecast displays the Replay controls, as 
shown here:

Figure 9. Replay Controls

See Creating a Replay Shot from a Layer.

Playlist Countdown Timer Display
Wirecast displays a countdown timer below the Preview Area or Live Broadcast Area 
whenever you play a video shot or playlist. If you play multiple video shots, click the 
gear menu icon and select the shot to associate with the countdown timer.

Frame advance

Elapsed time

Template selection

Create/Update 
Replay shot
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See Selecting and Customizing Encoder Presets.

Figure 10. The Playlist Countdown Timer

Preview Area
Displays the selected shot as it would appear when broadcast, without broadcasting 
the shot. When the shot in the Preview Area is selected, Wirecast outlines the preview 
with a control frame for resizing and rotating the shot.

See Viewing the Preview Area, Viewing a Shot in the Preview Area, and Resizing or Rotating 
a Shot.

Live Broadcast Area
The Live Broadcast Area shows the un-encoded shot currently being encoded and 
broadcast. Also, you can play, pause, or scrub clips displayed in the Live Broadcast Area 
while they are broadcast.

See Switching with Preview and Single-Click Switching with AutoLive.

Snapshot Button
When clicked, Wirecast takes a snapshot of the Live Broadcast Area at canvas resolution, 
and saves the snapshot as a PNG file in the designated snapshot folder.

See Live Snapshots Folder.

Gear icon
Countdown timer

Gear menu
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Final Mix Audio Panel
The Final Mix Audio panel enables you to control the output volume level, mute audio 
output, and mute the line-out feed for Preview and Live windows. The Preview and Live 
Volume controls enable you to adjust the audio volume for Preview and Live separately.

Figure 11. Final Mix Audio Panel

The Preview Monitor Audio Button
When clicked, Wirecast mutes or un-mutes Preview playback on your computer 
speakers or headphones.

The Monitor Preview Audio button and the Monitor Final Mix Audio buttons control 
whether you hear the output audio through your headphones or computer speakers. 
These do not affect what your viewers can hear. You can monitor Preview or Final, but 
not both at the same time. You can mute both.

Live Volume 

The Final Mix Monitor 
Audio button

The Final Mix Mute Button

Live Decibel scale

Preview Volume 

The Preview Monitor 
Audio Button

Preview Decibel scale

Volume slider
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If you do not want to broadcast audio, modify the encoder presets to not process audio 
through the encoder.

See Encoder Presets.

The Final Mix Monitor Audio button
When clicked, Wirecast mutes or un-mutes final mix playback on your computer 
speakers or headphones.

The Monitor Preview Audio button and the Monitor Final Mix Audio buttons control 
whether you hear the output audio through your headphones or computer speakers. 
These do not affect what your viewers can hear. You can monitor Preview or Final, but 
not both at the same time. You can mute both.

If you do not want to broadcast audio, modify the encoder presets to not process audio 
through the encoder.

See Encoder Presets.

Note: All Wirecast audio meters use a consistent dBFS scale. Whether you're viewing 
Multiviewer audio bars or the Advanced Audio Meter, the readings use the same scale. 
Level indicators turn yellow when they hit -6dB and red when they move above -1dB. 
All indicators show when audio is clipping by turning yellow or red.

See Controlling or Muting the Final Mix Audio Level and Displaying or Hiding the Final Mix 
Audio Panel.

The Final Mix Mute Button
When clicked, Wirecast mutes or un-mutes the final mix output.

The Final Mix Mute button controls what your viewers hear. You can quickly mute all 
your audio output with this button. This is great for quickly muting audio on your 
regular broadcast. When you mute the final mix audio, the encoder still generates 
audio, but the output gets muted for all program audio (except ISO-recorded sources). 
If, alternatively, you do not want to broadcast audio at all, it's better to modify the 
encoder presets to not process audio through the encoder, which will save system 
resources.

See Encoder Presets.



Windows, Controls, and Menus
Layers

119

Wirecast User Guide

Layers
Figure 12. Layers

The horizontal bars towards the bottom of the screen are the layers. You can make 
more layers visible. Also, you can add, modify, and play shots from the layers.

By default, Wirecast displays five layers. Each layer can contain multiple shots. A red LED 
indicates that a shot is Live.

Wirecast allows you to put shots on any of the layers. Layering shots enables Wirecast to 
superimpose them, from the lowest layer to the highest, to form a single composite 
visual image during broadcast.

By default, Wirecast displays five layers. Each layer contains shots that can be selected 
by clicking a shot. A red LED indicates that a shot is selected. When a shot is selected it 
is displayed in the Live Broadcast Area. If you select multiple shots (by selecting a shot 
on more than one layer) Wirecast displays all of them in the Live Broadcast Area.

Wirecast displays Layer 1at the top, Layer 5 at the bottom, and the other layers, in order, 
between them. The order of layers determines the order of superimposition in the Live 
Broadcast Area. If you place a video shot on Layer 5 and a title on Layer 1, Wirecast 
superimposes the title over the video.

See also Viewing a Layer in a Layer Window.

Tabs

Layer

Shots
Duration

Document hotkey

File name



Windows, Controls, and Menus
Add Shot Window

120

Wirecast User Guide

Add Shot Window
The Add Shot window provides a way to add sources, such as live sources, file sources, 
the Remote Desktop Presenter program, shot graphics, shot audio, and shot templates. 
Click the Plus Button (+) to open the Add Shot menu.

When Wirecast displays the Add Shot menu, select a shot category, select the type of 
shot to add. Modify the shot if desired and allowed. To add a shot to a layer, click the 
Add “+” button in a layer.

To add a source to the Favorites menu, select the source and click the star icon.
Wirecast changes the color of the star to white and adds the source to the Favorites 
menu.

Video Capture
System Device

Select a system device.

See NDI Devices in the Shot Layer Properties Tab.

Wirecast Gear Inputs

If you using Wirecast Gear (and have an active license) all available video inputs will be 
listed. If you are using Wirecast Gear 300/400 series hardware, the Wirecast Gear Video 
Inputs appear in the Shot Selection menu.

After a WC Gear shot is created, you can set up the shot using Wirecast Gear controls.

Audio Input

Select the audio input (if any) from the pull-down menu.

Audio Capture
System Device

Select a system device. 

See NDI Devices in the Shot Layer Properties Tab.

System Audio Capture

Select an audio capture device.

Source Name Displays the name of the source. To change the source name, enter a 
new one.

Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay the audio 
signal to sync it up with a video source.

Monitor Click the Monitor icon to cause audio to play through your monitor output. 
The icon is gold when selected (turned on). If unselected, audio will not play through 
the monitor output for this source. Selected is the default.
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ASIO and WASAPI Sources

Select an ASIO audio capture device and click the Add button.

Any ASIO or WASAPI source on your local network will be discovered by Wirecast and 
listed under Capture Devices in the Source Input Menu. These devices are generally 
used with multi-track audio outputs. ASIO Audio Capture is a very low latency 
professional audio capture API. It is used to connect to professional audio interfaces. 
WASAPI Audio Capture is also a low latency audio capture API. It replaces the old 
DirectShow-based audio capturing.

Media Files
Browse Disk

Select to navigate to a media file.

Stock Media Library

Select to display the Stock Media Library window.

A media file is a video clip or a picture. To open a media file source, select Media Files 
from the source menu in the shot window, and then navigate to your file. You can also 
click the Add Media File button at the bottom of the Add Shot window.

Media files have the following settings:

Source Name

Displays the name of the source. To change the source name, enter a new one.

In Point

Click Jump to move the play head to the In Point in the media file. Set the In Point either 
by dragging the In Point icon to the desired beginning position on the play bar, or by 
entering a value into the In Point field.

Out Point

Click Jump to move the play head to the Out Point in the media file. Set the Out Point 
either by dragging the Out Point icon to the desired end position on the play bar, or by 
entering a value into the Out Point field. The green triangle shows the current location 
of the Play Head.

Figure 13. In Point and Out Point Icons

When Finished

Select what happens when the media finishes playing. Loop causes the media to begin 
playing again. Hold causes the media to stop and hold the last frame in the Live 

In Point icon Out Point icon

Playhead
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Broadcast Area. Remove causes the media to be removed from the Live Broadcast Area 
when it finishes playing.

Begin playing when media becomes Live

When checked, the media begins playing as soon as it is made Live. 

Remember position even when not Live

When checked, the media will always start playing where ever it was playing when it 
was stopped, even if it was removed from the Live Broadcast Area and made Live again. 
When unchecked, the media will start from the beginning every time it is taken Live.

Set Default

Click to set the media display to default settings.

Live Playback

Changes are live. When you select this option and your shot is live, Wirecast displays 
any action you take in the Preview Area--such as playing, pausing or scrubbing--in the 
Live Broadcast Area, and broadcasts the action live.

Note: If you use this feature to pause or scrub media in the live broadcast, it's usually 
best to uncheck Begin playing when media becomes live.

Stock Media Library
When clicked, Stock Media Library opens the Stock Media Library window.
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Figure 14. Stock Media Library Window

Source Type

You can toggle on/off any type of media to include in the display: Video, Images, and 
Audio.

Search

Enter key words to display just the media files including these words. The display is 
updated as your enter words.

Left/Right arrows

Click the arrows to move to the next or previous set of Stock Media files.

Play button

Click to begin playing the selected media file.

File marker

Move the marker to view the media file quickly.

Download button

Click to download the selected media file into a shot.

Source TypeSearchLeft/Right arrows
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See Adding Media Files from the Stock Media Library to a Shot.

Network
iOS Cam

Select an IOS Camera device, or an iOS camera through the Wirecast Go iOS app.

Rendezvous

Select to create a new Rendezvous session, or select to reconnect to a previously 
created session.

Web Page

Creates a new web page shot.

See Web Page Properties.

Web Stream

Creates a new Web Stream shot.

See Web Stream Properties.

NDI(R) Source

Select any NDI-capable devices on your network.

Web Page Properties
Web Page shows a web source defined by a web address (URL). To open a web page 
source, select Web Page from the source menu in the shot window. Web Page Properties 
have the following settings:

Name

Displays the name of the source. To change the source name, enter a new one.

Audio Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay audio.

Video Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay video.

URL

Displays the web address (URL) of the source. To change the address, enter a new one.

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Go Back/Go Forward

If you have enabled Interaction on your web page, these buttons allow you to go back 
or go forward just as you would in a browser.
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Transparent Background

Check to make the background transparent in your shot.

Shutdown when inactive

Check to turn off the audio and disable it from the shot when playing videos.

Override CSS

Enter Cascading Style Sheet code to override the default code for this web display.

Interaction

Allows you to choose how you want to interact with your web page in the Preview 
window. Choices are Never, Always, or On Double-click.

Monitor

Click the Monitor icon to cause audio to play through your monitor output. The icon is 
gold when selected (turned on). If unselected, audio will not play through the monitor 
output for this source. Selected is the default.

Web Stream Properties
The Web Stream option allows RTMP, RTSP, MMS, or HTTP streams to be taken directly 
into Wirecast. This is useful for incorporating remote IP Cameras or other network 
streams into a broadcast. Sources are automatically detected and are also identified by 
IP Camera Profile. To open a Web Stream source, select Web Stream from the source 
menu in the shot window.

Web Stream Properties has the following settings.

Name

Displays the name of the source. To change the name, enter a new one.

Audio Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay audio.

Video Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay video.

URI

Enter the address of your input stream. (For example: rtsp://127.0.0.1:8080/
my_stream.sdp, or http://10.0.0.1/my_stream, or rtmp://hades.telestream.net:1935/live/
myStream).

Username

Enter your username for your URI stream.

Password

Enter your password for your URI stream.

Buffer

Enter a buffer time in seconds.
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Reconnect

Click to reconnect the web stream source.

Apply

Click the Apply button to update any changes.

Timestamps

Select Provided by source, or Provided by Wirecast. This setting allows you to use 
timestamps embedded in the source, or use timestamps generated by Wirecast. 
Timestamps are used to synchronize devices. Many sources don't provide completely 
accurate timestamps, resulting in sources out of sync with each other (i.e. audio and 
video not syncing).

Select Provided by Wirecast to ignore the timestamps coming from the source, and 
instead generate new timestamps. However, the risk is that if the system is under a 
heavy load, the generated timestamps could be impacted, and end up arriving late. The 
default setting is Provided by source.

See Wirecast: Timestamps Option.

Deinterlacing

Select None, or Blend Fields.

Dynamic Range

Select Default, Full or Limited.

Monitor

Click the Monitor icon to cause audio to play through your monitor output. The icon is 
gold when selected (turned on). If unselected, audio will not play through the monitor 
output for this source. Selected is the default.

Screen Capture
Remote Desktop Presenter

Creates a new Remote Desktop Presenter shot.

See Remote Desktop Presenter Properties.

Screen Capture

Creates a new screen capture shot of any monitor or window on your computer. 

See Screen Capture Properties.

Note: When in screen-capture mode, some apps take control of your mouse and 
make the cursor invisible. To reduce the capture window size and regain use of your 
mouse, press Alt + Tab.


https://support.telestream.net/s/article/Wirecast-Timestamps-Option
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Remote Desktop Presenter Properties
The Remote Desktop Presenter (RDTP) is a utility application that enables Wirecast to 
broadcast the desktop of any computer running the Telestream Desktop Presenter 
program. To open a Remote Desktop Presenter source, select Remote Desktop Presenter 
from the source menu in the shot window.

Remote Desktop Presenter is normally auto-detected by Wirecast and is automatically 
added to the list of sources. However, if a RDTP is not detected, or if you want to add 
one in a remote location you can manually add it by selecting New Remote Desktop 
Presenter from the Source menu in the default layout.

Remote Desktop Presenter Properties has the following settings.

Source Name

Displays the name of the source. To change the source name, enter a new one.

Audio Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay audio.

IP Address

Enter an IP address of the target computer.

Enable Audio When checked, the audio from the remote desktop is enabled.

Apply

Click the Apply button to update any changes.

Monitor

Click the Monitor icon to cause audio to play through your monitor output. The icon is 
gold when selected (turned on). If unselected, audio will not play through the monitor 
output for this source. Selected is the default.

Screen Capture Properties
A screen capture displays any monitor or window on your computer. To open a screen 
capture source, select Screen Capture from the source menu in the shot window. Screen 
captures have the following settings:

Name Displays the name of the source. To change the source name, enter a new one.

Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay audio.

Video Delay Enter the amount of time (in seconds, as short as 1 ms) to delay video.

Capture Video Check to enable Capture Type, Show Cursor, and fps settings (described 
below).

Capture Type   Select Monitor (captures your entire monitor), Window (captures the 
currently selected window), or Game (captures the game currently played on your PC). 
If you select Game, you can also configure how your game is captured by selecting 
options offered under Select Window/Monitor (described below).
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Anti Cheat Support Enables anti-cheating support for game capture.

Show Cursor Check to show the cursor in your streaming. Uncheck to hide it.

fps Select the FPS, from 10 to 60 frames per second as the capture rate. An FPS of 60 is 
the best frame rate, but it requires greater streaming bandwidth.

Capture System Audio Check to capture system audio when streaming. Uncheck to 
mute the audio.

Select Window/Monitor   Click the Configure button to display the Select Window 
dialog. If you selected Game for your Capture Type, Wirecast displays a configuration 
window with the following options:

– Capture Any Full Screen Game Check this box to automatically capture a game 
running in a full monitor screen, or running in a full screen of a window.

– Support Multiple Video Cards/SLI Check this box if you have a Windows system 
with multiple discrete GPUs and are experiencing problems capturing a game. 
(Performance of the capture may be slower than when running on a single GPU.)

– Capture Third Party Overlays Check this box to capture overlays rendered on 
top of a game that are generated by applications external to the game. (For 
example, the Steam in-game overlay.

Choose Audio Device Click the Configure button to display the Select Audio Device 
dialog, then select an audio device from the drop-down menu.

Note: Some apps, when screen captured, take control of your mouse and the cursor is 
not displayed. You can, at any time, press Alt + Tab keys to reduce the capture window 
size and enable you to use your mouse.

Dynamic Range Select dynamic range setting: Default, Full or Limited.

Monitor Click the Monitor icon to cause audio to play through your monitor output. 
The icon is gold when selected (turned on). If unselected, audio will not play through 
the monitor output for this source. Selected is the default.

See Screen Capture.

Overlays
Clock

Creates a shot that displays time.

See Clock Properties.

Image Carousel

Creates a new image carousel shot that shows a sequence of images. 

See Image Carousel Properties.

QR Code Generator

Creates a QR code display to present to your viewers in a live broadcast.
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See QR Code Generator Properties. 

Scoreboard

Creates a new scoreboard shot.

See Scoreboard Properties.

Social Media Title

Opens a selector for Social Media Titles.
See The Comment Moderation Window, and Social Media Shots.

Text

Creates a new text shot.

See Text Shot Properties.

Title

Opens a dialog for adding titles and lower thirds. In the dialog, you can see the 
available title designs in a continually growing library of title designs. You can search for 
a title and filter your search using various criteria. You can preview the intro and outro 
animation, and you see how the title fits on the screen.

You can revise titles in your project in the Title Properties tab.
If your project contains titles made with earlier versions of Wirecast, those legacy titles 
continue to appear in your project. To access the legacy titles, click the three dots in the 
upper-right corner of the Add Source dialog, and choose Display Deprecated Sources. 
Wirecast displays the names of animated titles with Title... at the beginning. Wirecast 
displays the names of legacy titles with Title (legacy) at the beginning.

See Titles (Animated) Properties.

Text Shot Properties
Text displays a text phrase. To open a text source, select Text from the source menu in 
the shot window. Text Properties have the following settings.

Name

Displays the name of the source. To change the Source Name, enter a new one.

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Mode

Select the source of your text: Text (directly entered) or File (navigate to a text file), or 
RSS (ticker tape RSS feed).

If you select Text, enter your text in the text box below the source selector.

If you select File, enter a file name in the File Path box displayed, or click the navigation 
button (three dots) and find your text file. The text from your file will be automatically 
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered 
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also 
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check Keep reading text file continuously to keep the text display in your broadcast up to 
date with file changes.

If you select RSS, enter a URL in the URL box displayed.

Text

Enter text to display.

File

Click the (...) icon to navigate to the file containing text to display.

RSS URL

Enter the RSS URL where the text to be displayed is located.

Update frequency

Enter the number of seconds between updates.

Keep reading text file

Check to keep reading the text file for changes.

Font

Select the desired font used for your messages. If you select Web Font, a Web Font field 
will display below. You can also select any of the fonts installed on your computer.

Face

Select the font style from the list of combination of bold and italic.

Size

Enter the font size. Click the gear icon to select the type of font size: small, medium, 
large, etc. 

Justify

Enables you to justify the text along the left, center, or right side of the display.

Align

Enables you to align the text at the top, middle, or bottom of the display.

Color

Click the box to open the color selection panel. Select a new text color from the palette.

Wrap

Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.

Scroll

Enter a scroll mode: Non Stop or If it Does Not Fit.

Background

Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to 
open the color palette and select a background color. Click the second color box to 
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the 
gradient display.
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Shadow

Check to activate the text shadow slider controls. Click the color box to open the color 
palette.

Angle

Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is offset 
from the actual text.

Offset

Move the slider to adjust the distance the shadow text is offset away from the actual 
text.

Blur

Move the Blur slider to adjust the amount of blur in the shadow text.

Titles (Animated) Properties
A title is text displayed in a banner window. Wirecast offers a wide variety of animated 
lower thirds and titles. To open a title source, select Title... from the Add Source menu.

Animated titles have the following settings:

Left/Right arrows

Click to view the previous page, or next page, of titles.

Search

Enter name of title desired.

Filters

Click to open options for filtering your view of the titles.

Scale to Fit/Show Preview

Click to view either the title scaled to the whole screen or placed in its live position.

Tags

Displays identifying tags for the title.

Lines of Text

Displays the number of lines of text in the title.

Custom Colors

Displays the number of custom colors in the title.

Intro Duration

Displays the length of the intro animation.

Animate Intro

Click to preview either the intro animation.

Outro Duration

Displays the length of the outro animation.
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Animate Outro

Click to preview the outro animation.

Note: Some title styles have customization sections for Subhead 1 and Subhead 2.

Title (legacy) Properties

Note: To access legacy titles, in the Add Shot dialog, click the three vertical dots at the 
top right corner of the box. Then select Show Deprecated Sources.

Legacy titles have the following settings:

Name

Displays the name of the source. To change the Source Name, enter a new one. 

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Mode

Select the source of your text: Text (directly entered) or File (navigate to a text file), or 
RSS (ticker tape RSS feed).

If you select Text, enter your text in the text box below the source selector.

If you select File, enter a file name in the File Path box displayed, or click the navigation 
button (three dots) and find your text file. The text from your file will be automatically 
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered 
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also 
check the Keep reading text file continuously to keep the text display in your broadcast 
up to date with file changes.

If you select RSS, enter a URL in the URL box displayed.

Text

Enter text to display.

File

Click the “...” icon to navigate to the file containing text to display.

RSS URL

Enter the RSS URL where the text to be displayed is located.

Update frequency

Enter the number of seconds between updates.

Font

Select the desired font used for your messages. If you select Web Font, a Web Font field 
will display below. You can also select any of the fonts installed on your computer.
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Face

Select the font style from the list of combination of bold and italic.

Size

Enter the font size. Click the gear icon to select the size of font.

Style

Select any combination of Bold, Italic, All Caps, by toggling each button.

Justify

Enables you to justify the text along the left, center, or right side of the display.

Align

Enables you to align the text at the top, middle, or bottom of the display.

Color

Click the box to open the color selection panel. Select a new text color from the palette.

Wrap

Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.

On Change

Select transition type: Fade, Drop In, Drop Out, and Slide. Enter the length (in seconds) 
of the transition time.

Scroll

Enter a scroll mode: Non Stop or If it Does Not Fit.

Direction

Select the direction of the scrolling: Top to Bottom, Bottom to Top, Left to Right, or Right 
to Left. 

Speed

Enter the speed (in pixels per second) that you want your message to scroll through the 
display.

Auto Reverse

When checked, the display reverses the scrolling direction when it reaches the top or 
bottom of the list.

Background

Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to 
open the color palette and select a background color. Click the second color box to 
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the 
gradient display.

Shadow

Check to activate the text shadow slider controls. Click the color box to open the color 
palette. 
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Angle

Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is offset 
from the actual text.

Offset

Move the slider to adjust the distance the shadow text is offset away from the actual 
text.

Blur

Move the Blur slider to adjust the amount of blur in the shadow text.

Twitter Feed (legacy) Properties
Twitter Feed displays a list of Twitter messages.

Note: To access legacy Twitter feed posts, in the Add Shot dialog, click the three 
vertical dots at the top right corner of the box. Then select Show Deprecated Sources.

Twitter Feed Properties has the following settings:

Name

Displays the name of the source. To change the source name, enter a new one. 

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Mode

Select the source of your text: Text (directly entered) or File (navigate to a text file), or 
RSS (ticker tape RSS feed). 

If you select Text, enter your text in the text box below the source selector. 

If you select File, enter a file name in the File Path box displayed, or click the navigation 
button (three dots) and find your text file. The text from your file will be automatically 
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered 
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also 
check the Keep reading text file continuously to keep the text display in your broadcast 
up to date with file changes.

If you select RSS, enter a URL in the URL box displayed.

Text

Enter text to display.

File

Click the “...” icon to navigate to the file containing text to display.

RSS URL

Enter the RSS URL where the text to be displayed is located.
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Update frequency

Enter the number of seconds between updates.

Font

Select the desired font used for your messages. If you select Web Font, Wirecast displays 
a Web Font field below. You can also select any of the fonts installed on your computer.

Face

Select the font style from the list of combination of bold and italic.

Size

Enter the font size. Click the gear icon to select the size of font.

Justify

Enables you to justify the text along the left, center, or right side of the display.

Align

Enables you to align the text at the top, middle, or bottom of the display.

Color

Click the box to open the color selection panel. Select a new text color from the palette.

Wrap

Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.

Scroll

Enter a scroll mode: Non Stop or If it Does Not Fit.

Background

Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to 
open the color palette and select a background color. Click the second color box to 
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the 
gradient display.

Shadow

Check to activate the text shadow slider controls. Click the color box to open the color 
palette. 

Angle

Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is offset 
from the actual text. 

Offset

Move the slider to adjust the distance the shadow text is offset away from the actual 
text.

Blur

Move the Blur slider to adjust the amount of blur in the shadow text.



Windows, Controls, and Menus
Add Shot Window

136

Wirecast User Guide

Scoreboard Properties

 

Scoreboards allow you to add a scoreboard graphic to your broadcast that can be 
dynamically updated. Multiple scoreboards can be added. Unlike most other elements 
in Wirecast, changes to the scoreboard go live instantly without requiring a transition. 
Once the scoreboard is live, the preview image is exactly as it is seen in your broadcast. 
To open a scoreboard source, select Scoreboard from the source menu in the shot 
window.

Scoreboards Properties has the following settings.

Source Name

Displays the name of the source. To change the Source Name, enter a new one. 

Scoreboard 

Select how the scoreboard will look using two drop-down menus. The upper menu 
selects the scoreboard style: Pipe, Shade, Corner, etc. The lower menu selects how the 
display fields are laid out: Basic, Right Stats, or Bottom. 

Home/Visitor/Score

The Home, Visitor, and Score fields contain the home and visitor team names and their 
current score. The three icons to the right of these fields control the text alignment, font 
size, and font color. Click on each icon to open its control window.

BG Color

Sets the background color for the Home or Visitor field display. Click the color icon to 
open the control window.

+1, +2, +3

Click these score increment buttons to increase the Home or Visitor score display.

Field 1-4 

Displays information inside the scoreboard depending on the layout chosen using the 
scoreboard menus. The three icons to the right of these fields control the text 
alignment, font size, and font color. Click on each icon to open its control window.

Use a Custom Image 

Check to enable the Choose button.

Choose

Click to navigate to the location of your custom image.

Reset

Click to remove a custom image.

Note: Because Wirecast updates the scoreboards dynamically, It is recommended 
that you fill in the additional information fields while using a layout that hides them. 

PRO
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Then, change to a layout that reveals those fields when ready, otherwise your viewers 
see you typing in those fields live.

There are four keyboard shortcuts associated with the scoreboard.

Table 3. Scoreboard

In order for these keyboard shortcuts to be active, the scoreboard must be displayed in 
the Live Broadcast Area and the Wirecast default layout must be in focus (selected as the 
active window).

See Application Shortcuts and Document Hotkeys.

Clock Properties
A clock shot displays time. Clock Properties has the following settings.

Name

Displays the name of the source. To change the source name, enter a new one. 

Clock Modes

Select Clock, Countdown, or Stopwatch.

Figure 15. Clock Modes

Clock Mode:

Date Select a date display format.

Time Select a time display format.

Countdown Mode:

Mode Select Countdown from or Countdown to.

= Increments Home 
score

-  Decrements Home 
score

]  Increments Visitor 
score

[  Decrements Visitor 
score

Clock mode
Countdown mode

Stopwatch mode



Windows, Controls, and Menus
Add Shot Window

138

Wirecast User Guide

Start Time

Enter the time value from which to start counting. 

Start/Stop/Resume and Reset

Click Start to start the counter. When counting, click Stop to stop the counter. When 
stopped, click Resume to start counting again, or click Reset to rest the counter.

Automatically Start

When checked, the counter will start when the shot is taken live.

Format

Select one of the time-display formats from the drop-down menu.

Start, Stop, Reset

Click Start to begin counting down. Click Stop to end counting down. Click Reset to 
reset clock to Timer value.

At Zero

Select either Stop at 00:00 or Start count up clock.

Stopwatch Mode:

Start, Stop, Reset

Click Start to begin counting. Click Stop to end counting. Click Reset to reset stopwatch 
to zero.

Display Format

Select time elements to display: Hours, Minutes, Seconds, and Fractional Seconds.

Font

Select font from drop-down menu.

Face

Select face from drop-down menu.

Size

Click the gear icon to select the font size from the menu.

Background

Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to 
open the color palette and select a background color. Click the second color box to 
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the 
gradient display. 

Shadow

Check to activate the text shadow slider controls. Click the color box to open the color 
palette.

Angle

Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is 
offset from the actual text. 
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Offset

Move the slider to adjust the distance the shadow text is offset away from the actual 
text.

Blur

Move the Blur slider to adjust the amount of blur in the shadow text.

Image Carousel Properties
An image carousel shot shows a sequence of images. Image Carousel Properties has the 
following settings:

Name

Displays the name of the source. To change the source name, enter a new one. 

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Change Every

Sets how often the images are changed, in seconds. 

Fade-In Time

Sets how long it takes for each image to fade in, in seconds. Enter zero for 
instantaneous display of images.

Shuffle Images

Check to shuffle the display order of the images. When unchecked, images are 
displayed as they are ordered in the image list.

Add/Delete/Move Images

Click the plus (+) button to find and add images. Select an image on the list and click 
the minus (-) button to delete it. You can move images up and down the list by 
selecting an image and clicking the up or down arrow.

QR Code Generator Properties
QR Code Generation has the following settings:

Source Name

Displays the name of the source. To change the source name, enter a new one.

Video Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay video. 

Content

Enter the message you want to be embedded in the QR code displayed in your 
broadcast.
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Deinterlacing

Select None, or Blend Fields.

Backgrounds
Web Page

Creates a new web page shot.

See Web Page Properties.

Solid Color

Creates a new solid color shot.

See Solid Color Properties.

Solid Color Properties
Solid Color displays a solid color background. To open a solid color source, select Solid 
Color from the source menu in the shot window. Solid Color Properties has the following 
settings:

Name

Displays the name of the source. To change the Source Name, enter a new one.

Width/Height

Displays the width and height of the display source. To change the width or height, 
enter a new value.

Background

Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to 
open the color palette and select a background color. Click the second color box to 
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the 
gradient display.

Templates

Shot Template
Select Templates from the Add Shot menu.

When Wirecast displays the Templates window, select a template.

Wirecast displays the new template shot in the Shot Editor.

• Placeholder Shot

See Assigning Media to Placeholders.

• Virtual Set Properties

 
PRO



Windows, Controls, and Menus
The Shot Editor Window

141

Wirecast User Guide

A Virtual Set is a pre-built source set, complete with graphics, that simulates a news-
anchor set. For example, you can select a virtual set that displays three layers of decor 
with two live sources. You can use virtual sets as they are, or you can customize them to 
meet your needs.

Virtual Sets has the following setting.

– Source Name Displays the name of the source. To change the source name, 
enter a new one. 

The Shot Editor Window
The shot editor has six tabs: Shot Layers, Shot Layer Properties, Audio, Chroma Key 
Properties, Smooth Transition Properties, and Source Properties.

Figure 16. The Shot Editor Window

Shot Layers

Enables you to add and delete sources and to change the display order (layering within 
the shot).

Shot Layer Properties

Enables you to change the size, position, and other properties of a shot.

Audio

Enables you to set and monitor the audio level.

Chroma Key Properties

Enables you to configure the source chroma key settings. Each source in a shot can 
have its own chroma key settings.

Shot Layers tab

Chroma Key Properties tab

Smooth Transition Properties tab

Shot Layer Properties tab

Audio Properties tab

Source Properties tab
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Smooth Transition Properties Tab

Enables you to set transition properties.

Source Properties (...) Tab

Enables you to set properties for a source in your shot.

Note: The title of the Source Properties tab changes with the type of shot selected. For 
example, when you select a playlist shot, the title of the Source Properties tab becomes 
Playlist Properties.

Shot Layers Tab
The Shot Layers tab lists all of the layers in the shot.

Note: Source icons appear only when you hover over them.

Figure 17. The Shot Layers Tab

     

See Adding, Deleting, or Rearranging Layers in a Shot.

Replay Layer

 

The replay layer is a placeholder layer that can be added to any shot for the purpose of 
creating a replay template shot. Once the shot is selected in Replay Settings, it can be 
used as a template for any created replay shot.

See Creating a Replay Shot from a Layer.

Select source

Move up or 
down

Add or remove 
source

Manage layers

Eye Icon

Speaker icon

PRO
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Shot Layers Properties Tab
The Shot Layer Properties tab enables you to make adjustments to the sources in your 
shot. The various controls on the Shot Layer Properties tab are described below.

Position

Displays the position of the selected source in your shot. Position “0 0” represents the 
middle of the shot area. To move a source, enter new location values.

Size

Displays the size of the selected source in your shot. To resize a source, enter new size 
values.

 Gear button

When clicked, Wirecast lets you select how to size the bounding box: by pixels or by 
percentage.

Scale Jog Wheel

When the jog wheel is dragged left or right, Wirecast changes the scale of the 
bounding box.

 Scale to Fit Button

When clicked, Wirecast expands the source to its maximum size on the canvas. This 
might distort the display of the source depending on the option selected in Fill.

See Fill.

 Reset Position Button

When clicked, Wirecast restores the source to its original scale and rotation.

Fill

The Fill drop-down menu offers these ways to fill the bounding box with the image:

• Lock Aspect Ratio fills the bounding box until one side hits an edge. Respects the 
aspect ratio, and doesn’t crop the image.

• Lock and Fill Width fills the bounding box to its width. Respects the aspect ratio. If 
the bounding box height is less than the image height, the top and bottom of the 
image are obscured. If the bounding box height is greater than the height of the 
image, Wirecast displays the image letterboxed.

• Lock and Fill Height fills the bounding box to its height. Respects the aspect ratio. If 
the bounding box width is less than the image width, the sides of the image are 
obscured. If the width of the bounding box width is greater than the width of the 
image, Wirecast displays the image pillar-boxed.

• Stretch to Fill fills the bounding box. Does not respect aspect ratio. If the image 
dimensions don’t match the bounding box dimensions, the image is distorted.

Note: The Fill feature is not active in Clock, Text, Solid, QR Code or Web Page shots. In 
these shots the image automatically stretches to fill the bounding box.
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X Y Z Rotation

Slide the X (Horizontal), Y (Vertical), or Z (Straight-through) axis sliders to rotate the 
source. (See Reset, under Crop.

Opacity

Slide the Opacity slider to adjust the degree of transparency of your image.

Reflection

Slide the Reflection slider to adjust the degree of reflection below your image.

Border

The border controls enable you to add a border around a video layer, and to control the 
parameters of the border.

Note: When a smooth transition is applied, Wirecast interpolates the values of the 
border group over the transition period.
Wirecast applies the matte before applying any border, feathering, corner radius, or 
cropping. Then, Wirecast applies any cropping.
Finally, Wirecast applies the border, feathering, and corner radius parameters.

Descriptions of the border controls follow.

• Width The Width slider controls the thickness of the border, in pixels. Wirecast 
places the border around the rectangle of the layer. The border doesn’t follow the 
edges of an input in an alpha channel, such as content in a chroma key.

• Align Type lets you determine where to align the border: with Inner the border cuts 
into the content, with Center the border sits across the center of the layer bounds, 
and, with Outer, the border sits outside the bounds.

• Color sets the color of the border with a standard color picker. The default is white, 
which provides the greatest contrast with the black background.

• Corner Radius specifies the radius of the corners from 0% to 100%. The corner mask 
hides the corners of the layer. This control works independently from the Width 
slider. You can apply the corner mask to any layer, regardless whether a border 
width has been specified.

• Feather specifies the amount of feathering, from 0% to 100%. Feathering provides 
an alpha ramp around the edges of the layer. This control works independently 
from Width and Corner Radius. Feathering smooths edges. You can use feathering to 
generate a vignette effect on a layer.

• Matte A matte is a mask over a shot. Select a matte by clicking the down-arrow on 
the Matte menu. The default is No Matte. You can also use any media file as a custom 
matte. To do this, create a new shot of the media file you want to use as a matte. 
This file now appears in the Matte drop-down menu where you can select it.

Crop

Clicking the Crop triangle opens the cropping adjustment pane. Slide the Left, Right, 
Top, and Bottom sliders to crop your source image.
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•  Gear button When clicked, Wirecast opens a menu of adjustment increments, 
allowing you to adjust the crop parameters either by a number of pixels or by per-
centage.

• Reset When clicked Wirecast resets the crop controls to their default settings.

Color

When clicked Wirecast opens the color adjustment pane. Slide the color controls to 
adjust the color.

• Reset When clicked, Wirecast resets the color controls to their default settings.

Drop Shadow

Click the Drop Shadow triangle to open the Drop Shadow adjustment pane. Check the 
checkbox to enable the controls.

• Color Click in the color field to open the color palette. Select a shadow color and 
luminance by sliding the vertical and horizontal sliders. Click outside the color edit 
box to close the palette.

• Angle Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow 
text is offset from the actual text.

• Offset Move the slider to adjust the distance the shadow text is offset away from the 
actual text.

• Opacity Slide the Opacity slider to adjust the degree of transparency of your source.

• Blur Size Move the slider to adjust the amount of blur in the drop shadow.

• Use As Defaults Click to set the current drop shadow configuration as the default 
setting. All future enabled drop shadows will be set this by default. Clicking this 
button does not retroactively update previously created shots. Drop shadow set-
tings on individual shots still can be changed.

• Reset Click to restore the drop shadow settings back to the default values. You can 
also restore the drop shadow settings to Wirecast application defaults by holding 
the Shift key down and clicking Reset.

PTZ

Click the PTZ triangle to open the PTZ control panel.

• Preset Check the Preset box to select a PTZ preset.

•  Up-arrow and down-arrow buttons Click the up and down arrows to find a 
PTZ preset to recall.

•  Right-pointing arrow button Click the right-pointing arrow button to apply 
the PTZ preset.

• Show PTZ Controller Click to display the PTZ Controller panel.

See The PTZ Controller Panel and How to Scale a Shot.


https://support.telestream.net/s/article/Wirecast-How-to-Scale-a-Shot
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PTZ Control in the Shot Layer Properties Tab
You can select PTZ Controller presets associated with a shot layer video source from the 
Shot Layer Properties tab of the Preview Inspector. You configure PTZ Control Presets in 
the PTZ Controller Panel.

To expand the PTZ control panel, click the PTZ triangle. To enable preset recall, check 
the Enable box. To select a preset, enter a preset number or click the up/down arrow 
buttons. Click the Go button (right pointing arrow) to cause the associated PTZ camera 
to recall that preset.

Once you have configured a shot layer with a PTZ Preset, sending that shot to preview 
recalls the preset for the camera. If multiple shots share the same video source with 
different PTZ Presets configured, the shot which is currently live takes precedence over 
subsequent PTZ Preset recall actions, until you drop the shot from the live feed.

When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel. 
See Shot Layers Properties Tab.

NDI Devices in the Shot Layer Properties Tab
If you have selected an NDI source, the NDI Source Properties tab will display. In addition 
to the controls above, an NDI source has the following controls:

Video Delay

Enter the amount of time (in seconds, as short as 1 ms) to delay video.

Bandwidth

Select the bandwidth to use: Highest (max quality), Lowest (max efficiency), or Audio 
Only (video bandwidth not applicable).

GPU Decoding

When checked, incoming sources will use your GPU to process the incoming source.

Timestamps

Select Provided by source, or Provided by Wirecast. This setting allows you to use 
timestamps embedded in the source, or use timestamps generated by Wirecast. 
Timestamps are used to synchronize devices. Many sources don't provide completely 
accurate timestamps, resulting in sources out of sync with each other (i.e. audio and 
video not syncing).

Select Provided by Wirecast to ignore the timestamps coming from the source, and 
instead generate new timestamps. However, the risk is that if the system is under a 
heavy load, the generated timestamps could be impacted, and end up arriving late. The 
default setting is Provided by source.

Deinterlacing

Select None, or Blend Fields.

Dynamic Range

Select Default, Full or Limited.



Windows, Controls, and Menus
The Shot Editor Window

147

Wirecast User Guide

Monitor

Check the Monitor check box to cause audio to play through your monitor output. If the 
check box is unchecked, audio will not play through the monitor output for this source. 
Checked is the default.

Note: NDI networking requires that your network has port 5353 open for mDNS 
device discovery, as well as one port per video channel (starting from port 5960 and 
onward) transmitted by an NDI source, plus one additional port for messaging.

See PTZ Cameras and Controls.

Audio Properties Tab
The Audio Properties tab enables you to control and monitor audio. You can set the 
audio level, mute and monitor the audio, and map channel outputs.

Figure 18. The Audio Properties Tab

Volume

Adjust the slider to set the audio volume level.

Pan

Adjust the slider to pan between left and right audio.

Meter

Monitors the audio level. You can also mute the audio by clicking the audio icon.

Speaker Icon

Click to mute the audio output. Icon turns gray when muted. Click the icon again to un-
mute the audio.

Channels

Select left (L) or right (R) for each channel. Adjust volume slider for each. 

Map button

Meter display

Volume slider

Pan control

Speaker icon
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Apply to All

Click to apply the current settings to every instance of the selected source. If you have 
any shot specific configurations in other shots, they will be changed to match what was 
configured when you click this button. This action cannot be undone!

Set as Default

Click to take the current settings and set them as the default configuration. Any time 
this source is added to a shot in the future, it will be created with this configuration.

Reset

Click to reset the default settings. This is useful if you have made changes to the default 
custom settings, but want the defaults set back to the factory default settings. Factory 
defaults are: Chan 1 = Left; Chan 2 = Right; additional channels are unassigned.

Map

Click to open the audio mapping window. Check a square to map an audio channel to 
an audio track. Any audio can be tracked to any or all tracks. However, you will typically 
assign a group of channels to one track and other groups to other tracks.

If you have created a shot using a 16 input device, the mapping window will display all 
16 channels.

Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out 
currently only supports two channels.

The audio track that is actually used is selected from the Audio Track Selection menu in 
the Output Settings window. You can select only one track. However, if you are 
recording, you can select multiple audio tracks.

Chroma Key Properties Tab
Chrome key enables you to replace all areas of a selected color with a background 
image. For example, you can replace the green in a traditional background green 
screen with an image. The image appears in the background instead of the color green.

The Chroma Key Properties tab enables you to turn on/off chroma keying and to make 
chroma key adjustments. Check the Use box and+ select the type of use: Chroma, Luma, 
or Color Key.

Use

Check to turn on chroma keying. Uncheck to turn it off. Select the type of use: Chroma, 
Luma, or Color Key.

Color

Click the color square to open the Color Pallet. Select a color to use as the chroma key 
color and click OK. Click the dropper icon to use your mouse to select a chroma key 
color from your screen. Hover over the a desired color in the selected source, and click 
the left mouse button to select that color. All adjustments will be made using the 
selected color as the key.
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Key Threshold

Move the slider to adjust how far away from your chosen chroma color you want to 
enable keying. The farther right you move the slider the more variation to the color it 
accepts.

Black Clip

The Black Clip slider allows you to define what is considered “black”. When slider is fully 
left, you have a very thin definition of what black is. The farther to the right you go, you 
start adding more cases of what we consider “black'”. In chroma key, rarely do you want 
to bump the far left side to the right.

White Clip

The White Clip slider allows you to define what is considered “white”. Slide both all the 
way to the right, for a very thin definition of white. The more you increase the range, 
the more you add to what you consider to be full intensity brightness. In chroma key, 
rarely do you want to bump the far right side to the left.

Spill Suppression:

This slider says: anything that is near green, bump it away from green. Move this slider 
to help take away the green reflection it locates on an edge. This will take everything 
that's green, and take away its greenness.

Solidify:

This slider says: if all the pixels around me seem to be part of the key, then bump up my 
probability of being part of the key. This tends to “solidify” your key. Move the slider to 
the right to bump up the alpha values for pixels surrounded by high alpha values. One 
disadvantage is that the hair on a subject may appear more “blocked” in nature.

Edge Coloring

Move the slider to adjust the level of edge coloring which pull colors from inside of 
keyed object to get rid of halo on an image.

Display

Select display: result of keying, white-alpha channel, or black-alpha channel. This can 
be helpful to get key parameters set correctly.

Luma Key

This lets you key based on its brightness (or Luma value). You have an icon with a white 
background - and you want to get rid of the white background.

Color Key

This lets you set the image alpha based on the distance from a given color in the RGB 
space. This is useful for images (logos) that have non-black and non-white 
backgrounds. If the BG is black or white use Luma Key. If it's a plate from a greenscreen/
bluescreen then use Chroma Key. Otherwise, try Color Key.

Alpha Clip

This lets you choose what distance from the key color should be considered 
“foreground.” Anything over a given distance from the key color is “foreground” 
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otherwise it's “background.” A range is used so there is a smooth transition from 
foreground to background.

Smooth Transition Properties Tab
The Smooth Transition Properties tab provides control over how objects (image, movie, 
title, etc.) are added or removed in the Live Broadcast Area. Wirecast performs motion 
only during a Smooth transition. If you are using any other transition, the motion 
settings are ignored.

There are two types of motion. When an object is added to your broadcast it is called 
Build In; When it is removed it is called Build Out. Motion only occurs when an object 
enters or leaves the Live Broadcast Area. For example, if you have two shots, each with a 
foreground and the media in the foreground is the same, then a Smooth transition is 
performed between the foregrounds. However, no motion is performed. Or, if a logo is 
positioned in the top left corner in an existing shot, and it is in the bottom right corner 
in a new shot, when you make the new shot Live the logo smoothly transitions from the 
top left corner to the bottom right corner. But the Build In and Build Out settings are 
ignored. 

However, if you have two shots with a Foreground, but the media in each is different, 
the Build Out is performed for the existing shot, and the Build In is performed for the 
new shot.

Direction Menus

These provide selections of where the Build In comes from (top, bottom, right, etc.) 
when it is added, and where the Build Out goes when it is removed.

Fade In / Fade Out

Checking these checkboxes causes an object to be added or removed gradually. If 
unchecked, the object is instantly added or removed, much like a cut transition.

Spin In / Spin Out

Checking these checkboxes causes an object to be added or removed in a spinning 
fashion.

Scale In / Scale Out

Checking these checkboxes causes an object to be added or removed in a scaled 
fashion.

Apply To All

Click this button to make the Transition Settings the same for all sources in a shot. This 
is useful if you want to make all of your motion the same for all of the elements in the 
shot.

Set As Default

Click this button to make these Transition Settings the default settings for all new shots. 
These default settings will be applied in all future WC documents.
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Source Properties Tab
The Source Properties tab provides control over clip properties and behaviors. When a 
playlist is selected, the Source Properties tab also provides playlist controls.

See also Playlist Controls and Playlist Properties Tab.

Name

Clip filename, editable.

In Point/Jump

Enter the timecode for the in-point desired. Click Jump to bring the playhead to the in-
point.

Out Point/Jump

Enter the timecode for the out-point desired. Click Jump to bring the playhead to the 
out-point.

When Finished:

Options in the drop-down menu determine Wirecast behavior when the live clip is 
done playing, as follows:

Table 4. When Finished

Loop Hold Remove

With no options checked
Wirecast replays the clip from its 
beginning.

With no options checked
Wirecast holds on the last frame. 
If it’s an audio-only clip, Wirecast 
holds on silence.

With no options checked
Wirecast drops the clip from the 
live playback window.

With Begin playing when 
media becomes Live checked
When the clip goes live, Wirecast 
plays the clip from the clip 
beginning.

With Begin playing when 
media becomes Live checked
When the clip goes live, Wirecast 
plays the clip from the clip 
beginning, and holds on the last 
frame.

With Begin playing when 
media becomes Live checked
When the clip goes live, Wirecast 
plays the clip from the clip 
beginning to the end, then 
drops the clip from the live 
playback window.

With Begin playing when 
media becomes Live and 
Remember position even when 
not Live checked
When the clip goes live, Wirecast 
plays the clip, starting after the 
last frame previously played.

With Begin playing when 
media becomes Live and 
Remember position even when 
not Live checked
When the clip goes live, Wirecast 
plays the clip, starting after the 
last frame previously played, 
and holds on the last frame. 
Wirecast doesn’t restart the clip 
until you uncheck this option.

With Begin playing when 
media becomes Live and 
Remember position even when 
not Live checked
When the clip goes live, Wirecast 
plays the clip, starting after the 
last frame previously played, to 
the end. Then Wirecast drops 
the clip from the live playback 
window.
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With Begin playing when 
media becomes Live, 
Remember position even when 
not Live, and Live Playback: 
Changes are live checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Begin playing when 
media becomes Live, 
Remember position even when 
not Live, and Live Playback: 
Changes are live checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Begin playing when 
media becomes Live, 
Remember position even when 
not Live, and Live Playback: 
Changes are live checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Begin playing when 
media becomes Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Begin playing when 
media becomes Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Begin playing when 
media becomes Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Remember position even 
when not Live checked
When the clip goes live, click 
Play. Wirecast plays the clip, 
starting after the last frame 
previously played.

With Remember position even 
when not Live checked
When the clip goes live, click 
Play. Wirecast plays the clip, 
starting after the last frame 
previously played, holds on the 
last frame, and doesn’t restart 
until you uncheck this option.

With Remember position even 
when not Live checked
When the clip goes live, click 
Play. Wirecast plays the clip, 
starting after the last frame 
previously played, to the end. 
Then Wirecast drops the clip 
from the live playback window.

Table 4. When Finished

Loop Hold Remove
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Set as Default

Click to make the current source properties the default source properties.

Playlist Properties Tab
The Playlist Properties tab contains the following settings for playlist shots:

Name

An editable field for the name of the playlist.

When Finished

Sets the behavior of the playlist when the last shot in the list has been played. A check 
mark indicates what menu item (behavior) is selected.

• Loop transitions back to the first shot, endlessly.

With Remember position even 
when not Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Remember position even 
when not Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Remember position even 
when not Live, and Live 
Playback: Changes are live 
checked

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Live Playback: Changes 
are live checked
When checked, Wirecast lets you 
control the playback with the 
tools in the Preview window.

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Live Playback: Changes 
are live checked
When checked, Wirecast lets you 
control the playback with the 
tools in the Preview window.

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

With Live Playback: Changes 
are live checked
When checked, Wirecast lets you 
control the playback with the 
tools in the Preview window.

Note: When you check Live 
Playback: Changes are live, it is 
usually best to uncheck Begin 
playing when media becomes 
Live and Remember position 
even when not Live.

Table 4. When Finished

Loop Hold Remove
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• Hold stays on the last shot. If the last shot is a clip, the last frame in the clip is dis-
played. If the last shot is a live shot, the live source stays active. If the last shot in a 
Playlist is a video clip Shot, it will obey the rules set for the video clip in the Media 
Properties Inspector tab under Source Properties. However, it will hold the Playlist 
on that last Shot if Set Playlist Behavior is set to “Hold”. Therefore, if you want to see 
the last video in the Playlist pause on the last frame, you must set When Finished to 
“Hold” under Source Properties, in addition to setting the playlist behavior to 
“Hold”. If you set When Finished to “Loop”, under Source Properties, the last video in 
the Playlist will continue to loop. 

• Available Shots transitions to another shot on the same layer. All available shots are 
listed as menu selections. (In the example shown, the only available shot is “Logo”.)

• Previous Live Shot transitions back to the shot that was live before the playlist began 
playing.

• Current Preview transitions the contents of Preview to the Live Broadcast Area.

Transition

Sets the transition to use when switching between shots.

Remember position when not live

When selected, Wirecast remembers the start frame for the playlist when the playlist 
isn’t live.

Previous

Transitions to the previous shot in the playlist if the playlist is currently live.

Next

Transitions to the next shot in the playlist if the playlist is currently live.

Shuffle

Click to shuffle the order of the playlist shots. 

Total Shots

Displays the total number of shots in the playlist.

Duration

Displays the duration of the playlist.

See also Source Properties Tab.

The Shot Menu
You can change almost all the attributes of a shot through the shot menu. To open the 
shot menu for a shot, right-click on the desired shot in a layer.
Wirecast displays the shot menu.

Change Source Select Change Source to change the video source of your shot. Upon 
selection, a menu of sources will display enabling you to make a selection.
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Change Audio Select Change Audio to change the audio source of your shot. Upon 
selection, a menu of audio sources will display enabling you to make a selection.

Keyboard Shortcut You can create a keyboard shortcut for opening the shot. To do 
this, select Keyboard Shortcut from the shot menu. Then, select a menu number to 
associate with that shot.

Wirecast checks that menu item and adds the keyboard shortcut number in the shot 
icon.

To take a shot using the assigned hotkey, press the number key assigned to that shot.

You can assign multiple shots to the same menu number as long as they are on 
different layers. When you use the assigned hotkey all the shots assigned to it will be 
taken. Selecting a checked menu item will uncheck it and unassign the shot.

Select Unmap All Keys to remove all hotkey assignments.

Note: See also Creating a Document Hotkey.

Edit Shot You can edit a shot by clicking the double arrows (located on the left side of 
the Preview Area) to the right, revealing the shot editing panel. You can also edit a shot 
by double-clicking on it, by right-clicking it and selecting Edit Shot, by selecting Edit 
Shot from the Edit menu, or by selecting it and pressing the Ctrl+E keys.

Rename Shot You can rename a shot by right-clicking it and selecting Rename Shot, or 
by selecting Rename Shot from the Edit menu. You can also rename a shot by selecting 
it and pressing the Ctrl+R keys.

Duplicate Shot You can duplicate a shot by right-clicking it and selecting Duplicate 
Shot, or by selecting Duplicate Shot from the Edit menu. You can also duplicate a shot 
by selecting it and pressing the Ctrl+D keys.

Duplicate Shot Options Check a source to create a new instance of it when 
duplicating the shot containing it. Multiple selection is allowed.

Delete Shot You can delete a shot by right-clicking it and selecting Delete Shot, or by 
selecting Delete Shot from the Edit menu. You can also delete a shot by selecting it and 
pressing the Ctrl+Backspace keys.

Save Shot as Template You can configure any shot with a Placeholder and save it as a 
Template Shot. When the dialog box displays, enter a template name and click OK.

Lock Shot Icon Click to take a snapshot of your live shot icon thumbnail and save it as a 
static image for your shot. This can help users identify each shot with a snapshot image 
that's meaningful for them. For example, if you have a PTZ camera with multiple shots 
configured for different camera positions, you can display a customized snapshot of 
each camera angle as the icon for each shot. This provides quick identification during 
production. Once a shot icon is locked, the Gear menu item will turn into Unlock Shot 
Icon.

Refresh Shot Icon Click to refresh the shot icon after any changes made.
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The Preferences Dialog Box
You can customize Wirecast functionality with the settings in the Preferences dialog 
box.

See Customizing Wirecast with Preferences.

General Preferences
You can customize whether Wirecast shows the landing page and last document on 
startup, the number of transition buttons shown, and other defaults, through the 
General preferences.

Open last document on startup

When checked, the last document you used is opened when Wirecast starts up.

Show landing page on startup

When checked, the Welcome screen is displayed when Wirecast starts up.

Show Number of Viewers

When checked, enables the viewership indicator while streaming.

Send diagnostic and usage information

When checked, causes diagnostic and usage information to be sent to Telestream 
anonymously.

Hide Unlicensed Features

When checked, Wirecast hides unlicensed Pro features from display in the menus.

Transition Buttons

The value selected from the drop-down menu determines the number of transition 
controls buttons Wirecast displays in the default layout.

Maximum Reconnect Attempts

The number entered into this field determines the number of times Wirecast tries to 
reconnect to a host provider. The default is three.

Audio Playback

The device selected from the drop-down menu determines the device Wirecast uses for 
monitoring audio playback.

Stock Media Download Folder

This field displays the full path of the folder where Wirecast stores stock media 
downloads. Clicking the Browse button lets you select a different folder for stock media 
downloads.
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Live Snapshots Folder

This field displays the full path of the folder where Wirecast stores your snapshots of the 
Live Action Area. Clicking the Browse button lets you select a different folder for 
snapshots.

See Snapshot Button.

Canvas Preferences
Canvas preferences let you set options for your document canvas, including the default 
size and the display rate used for video rendering.

Canvas Size for New Documents

The preference selected from the drop-down menu determines the default canvas size 
for new documents.

Note: To optimize the quality of the video that Wirecast broadcasts, set the canvas 
size to match, as closely as possible, the resolution of the desired output.

Lock Aspect Ratio When Resizing Layers

When checked, maintains aspect ratio when resizing layers.

Enable Snapping to other layers

When checked, turns on snapping to selected layers.

Enable Snapping to canvas

When checked, turns on snapping to the canvas.

Show Z Rotation controls

When checked, Wirecast displays the Z Rotation controls.

Video Display Rate

The preference selected from the drop-down menu determines the frame rate 
displayed on the canvas.

Note: To optimize resources, set this as closely as possible to the framerate of the 
desired output. The framerate you set is the framerate that Shot ISO and Multiviewer 
use automatically.

Shot Display Preferences
Shot Display preferences enable you to change settings related to your shots and the 
Main Shot Display.

Theme

The preference selected from the drop-down menu determines how Wirecast displays 
the shot window.
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• Default: Displays shot icons normally.

• Lighter: Displays the Main Shot Display area with a lighter background.

• XKeys: Displays shot icons with shot titles highlighted.

• XKeys - Layer Backgrounds: Displays shot icons with colored backgrounds.

Display hotkeys using

When clicked, Wirecast opens a drop-down menu displaying the following options:

Key Combination

When checked, Wirecast displays the key combination on the shot.

Hotkey Name

When checked, Wirecast displays the hotkey name on the shot. Live GPU Accelerated 
Icons

The preference selected determines the framerate at which Wirecast displays the active 
icons.

Note: Higher framerates place greater demands on your CPU. This could diminish 
Wirecast performance.

Live Audio Meters

When checked Wirecast enables live audio meters.

When Dragging Multiple Files From ExplorerFolder

The preference selected determines what Wirecast does when you drag multiple files 
from a folder into Wirecast. Depending on your selection, Wirecast either creates a 
playlist containing the multiple files, or Wirecast creates multiple shots that are not part 
of a playlist.

Shot Selection Icons 
Each layer contains one or more shot-selection icons.

The shot icons can be made to display any live activity in the source it represents, such 
as cameras or streaming.

See Creating a Shot and Shot Display Preferences.

Licenses Preferences
Licenses preferences enable you to register and license Wirecast.

License Key

This field displays the serial number that you have received for Wirecast.
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Note: The serial number is composed of numbers and upper case letters (excluding 
upper case letter O), but it never contains quotation marks. When you receive a serial 
number, it may be enclosed in quotation marks (e.g., “123-456-789”).

Purchase

When clicked, the Purchase button launches the purchasing dialog.

Deactivate

When clicked, the Deactivate button deactivates the serial number.

Update Preferences
Software update preferences enable you to obtain Wirecast updates.

Automatically check for updates

When checked, Wirecast checks for updates on the Telestream Website each time 
Wirecast is launched. No personal information is transferred to Telestream during this 
action.

Check Now

When clicked, Wirecast immediately checks for updates on the Telestream Website 
(www.telestream.net). Wirecast does not transmit personal information to Telestream 
during this action.

See Checking for Wirecast Updates.

Shortcuts Preferences
Shortcut preferences enable you to view and create application shortcuts and 
document hotkeys. An application shortcut is a combination of keys that executes a 
menu or mouse command. A document hotkey is a combination of keys that executes 
a document-specific command.

See Finding an Application Shortcut and Finding a Document Hotkey.

The Shortcuts tab of the Preferences dialog contains the following elements:

List of Keyboard Shortcuts

The Keyboard Shortcuts window displays a list of existing keyboard shortcuts.

“+” Button

When clicked, this button creates a new line item, in the list of shortcuts, that you can 
edit to create a keyboard shortcut.

“-” Button

When clicked, this button deletes the line item and keyboard shortcut selected in the 
list of keyboard shortcuts.
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Name

Text entered into this field names the keyboard shortcut selected in the list of keyboard 
shortcuts.

Key Binding field (unlabeled)

Wirecast makes the key combinations entered into this field keyboard shortcuts.

Global checkbox

When checked, Wirecast makes the key combinations entered into this field global.

See also Creating a Document Hotkey.

Controllers Preferences
Controllers preferences enable you to adjust MIDI and X-keys controller settings for 
Wirecast.

Controller

The controller selected from the drop-down menu controls Wirecast.

See Installing a Hardware Controller.

MIDI Control Assignments
Each MIDI controller has up to six controls assigned to it. The locations of each of these 
controls are shown below for the three midi controllers supported.

The locations of APC MINI controls are shown below:
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The locations of APC40mk2 controls are shown below:

        

The locations of Launchpad MK2 controls are shown below:

       

Each MIDI controller has up to six controls assigned to it. The locations of each of these 
controls are shown below for the three midi controllers supported.

MIDI Control Descriptions
Shot Layers

The matrix of buttons on the MIDI controller (five rows of eight buttons) automatically 
correspond to the five layers in the Wirecast shot list window. Up to eight shots in each 
layer are controlled by the MIDI controller buttons. Shots are automatically assigned to 
MIDI controller buttons as they are created. If fewer than eight shots exist on a layer, the 
corresponding buttons (to the right) are inactive.

Go Live

Pressing this MIDI controller button is the same as clicking the Go Live button in the 
Wirecast default layout.
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Transition 1

Pressing this MIDI controller button is the same as clicking the Left Transition button in 
the default layout.

Transition 2

Pressing this MIDI controller button is the same as clicking the Left Transition button in 
the default layout.

Audio Mixer Volumes

Sliding these MIDI controls adjusts up to eight volume controls in the Wirecast Audio 
Panel. Each MIDI slider corresponds (left to right) to a volume control in the Audio 
Panel. Volume controls are automatically assigned to MIDI controller sliders as they are 
created. If less than eight volume controls exist in the Audio Panel, the corresponding 
MIDI sliders (to the right) are inactive.

Channel Pan

Each Channel Pan control on a MIDI device corresponds with a Channel Pan control for 
a track in the Audio Mixer Panel, for as many as eight channels.

Wirecast automatically assigns Channel Pan controls to MIDI controls as they are 
created. If fewer than eight Channel Pan controls exist in the Audio Panel, the 
corresponding MIDI controls remain inactive.

Audio Mixer Channel Pan Controls
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X-keys Control Assignments
The X-keys controller has multiple controls assigned to it. All of the assigned controls 
are shown below.

     

General Key Operations
• Key lamps turn red when a function is on, and turn blue when off (except for keys 

that do not have dual states, like the Keyboard Shortcuts).

– Function lamps turn red when a function is on, and turn blue when off (except 
for keys that do not have dual states, like the Keyboard Shortcuts).

– Shot switching key lamps turn Blue when shot is in Preview and Red when in 
Live. Otherwise they are off.

• The Wirecast software and the X-keys panel stay in sync when keys are pressed or 
changes are made in Wirecast.

• Some keys are interactive. In such a case, pressing one key affects the status of 
another (like the PREV and LIVE keys).

Key Descriptions
Five Layers keys

Controls the first twelve shots (plus the Clear Layer shot) on each of the five layers.

Keyboard Shortcuts

The twelve keys represent the twelve Keyboard Shortcuts that have been assigned in 
Wirecast. Pressing a key executes the matching numbered Keyboard Shortcut (1 
through 13). The key lamps momentarily turn red, then turn back to blue.

1

2

3 4 5 6 7 8 9 10 11 12 13 14

15

16

17

18

19

20
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Live/Preview Swap Mode

Toggles the Live/Preview Swap mode. When in this mode, the Live and Preview shots 
are swapped.

Auto Live Mode

Toggles the Live Auto mode. When in this mode, selected shots are displayed in the 
Live Output window immediately.

Rendezvous

Toggles (show/hide) the display of the Rendezvous window.

Audio Mixer

Toggles (show/hide) the display of the Audio Mixer window.

Preview Monitor Audio

Toggles the Preview monitor audio (what you hear locally) on and off. (It is mutually 
exclusive with Live Monitor audio).

Mute Live Streaming audio

Toggles the Live Streaming audio (what your viewers hear) on and off.

Live Monitor Audio

Toggles the Live monitor audio (what you hear locally) on and off. (It is mutually 
exclusive with Preview Monitor audio).

Streaming

Toggles streaming on and off.

Recording

Toggles recording on and off.

ISO Recording

Toggles ISO recording on and off.

Multi Viewer

Enables all displays. Pressing this key is the same as selecting Output > Multi-Viewer 
Output > Enable All Displays.

NDI

Enables/Disables NDI output.

Fade to Black

Pressing this key acts as a “master transition-to-black”. The transition used is the one 
currently selected. It is very helpful when needed to make the Live Output black in an 
emergency. If Wirecast is in Live/Preview Swap mode, the live shot is moved to Preview 
and the pre-fade condition can be restored by pressing the Go key.

Live Media Play and Pause

Press the Play button to play a selected media file, and press the Pause key to pause it. 
These keys are interactive. Pressing one changes the lamp status of the other.
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Replay Create and Update

These keys execute Replay+ISO > Create All Replay Shots, and Replay+ISO > Update All 
Replay Shots.

Mark In

Pressing this key executes Replay+ISO > Program Replay > Replay Mark In.

Transitions 1 and 2

These keys select Transition 1 or Transition 2 so that when the Go key is pressed, the 
selected transition will occur.

Go

Press this button to send the shot from the Preview Area to the Live Broadcast Area, by 
way of the transition selected. If Wirecast is in the Live/Preview mode, the Live output 
shot will be moved to the Preview Area when you click the Go button.

Advanced Preferences
Advanced preferences enable you to adjust advanced settings for Wirecast.

Disable Vertical Sync

Check the box when running Wirecast minimized, when the Wirecast user interface is 
covered by another application, or when Wirecast is covered by a full-screen game.

Video Adapter

Select the desired video adapter from the drop-down menu.

Render Engine

Select the desired render engine from the drop-down menu. The options are as follows:

• Automatic This is the default setting. When this option is selected, Wirecast selects 
the best render engine based on the available hardware.

Note: Wirecast automatically sets the render engine to Direct3D 11 when it detects 
AMD hardware. Also, Wirecast automatically sets the render engine to Direct3D 11 
when Direct3D 12 is not available.

• Direct3D 12 Select this option to make Direct3D 12 the default render engine.

• Direct3D 11 Select this option to make Direct3D 11 the default render engine

Disable Vertical Sync

When checked, Wirecast receives frames as fast as possible, for example, during video 
game play. This is especially useful when the application window is minimized or 
covered by another application.

Video Adapter

The preference selected from the drop-down menu determines the video adapter 
Wirecast uses for rendering and compositing. If you are using a discrete GPU, select the 
same GPU on which your application is running.
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Note: Video Adapter defaults to the first discrete card that is discovered by Wirecast. If 
you have multiple GPUs, it is best to configure Wirecast to use the same card as used 
for your application (for optimal performance), otherwise Wirecast uses a slower 
capture path. Also, best performance is achieved by setting the Video Adapter to use 
the NVidia card.

Web Stream

Check to enable automatic discovery of ONVIF cameras.

Microphone

Check to automatically detect feedback and force the display of a warning message.

Missing Media

Check to automatically reconnect live shots when Wirecast loses communications with 
a source.

Application Source Latency

The value entered into this field determines Wirecast latency period, in microseconds. 
When you update this value, Wirecast applies it as soon as the preference is committed. 
You don’t need to restart Wirecast to see the change.

The minimum value for this preference is 50ms (2 frames @ 30fps). The maximum value 
is 330ms (10 frames @30fps). The default is 100ms (3 frames @ 30fps).

Note: Wirecast applies application source latency to all sources, while the audio delay 
and video delay values in Source Properties determine the delay for individual 
sources.

Language

The drop-down menu allows you to select any supported language for the Wirecast 
user interface. The default is System Default, which is the language of the operating 
system on which Wirecast is installed.

See Choosing the Wirecast Language.

Missing Media Image

The preference selected determines how Wirecast indicates a missing graphic.

• When Default is selected, Wirecast presents a red question mark in place of the 
missing graphic.

• When Transparent is selected, Wirecast makes no replacement of the missing 
graphic.

• When Custom is selected, Wirecast lets you browse to a graphic to replace the miss-
ing graphic.

• Browse button: click to browse to a media image.
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The Audio Mixer Window
The Audio Mixer enables you to monitor and control all of the audio sources from a 
single control panel. This section describes in detail how to use the Audio Mixer.

The Audio Mixer separates your audio by hardware and shot. The Live Sources pane 
shows all hardware audio sources that are live in your streaming event. This includes 
microphones, audio input feeds, cameras, capture cards, and Web streams. The 
remaining audio controls are associated with specific shots.

See Displaying or Hiding the Final Mix Audio Panel.

Figure 19. The Audio Mixer Window

Final Mix Mute 
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The Headphone Mute buttons toggle the source audio when monitoring Preview or Live 
output. Muting headphones doesn’t remove the audio from the output stream or 
recording. Channel Selection enables you to select left source only, right source only, or 
stereo (left and right).

FX

Click the down-arrow to display the audio effects pane.

Add New FX (+)

Click the plus (+) icon to select an audio effect from the drop-down menu. You can 
select more than one effect or plugin.

Level Controls

Adjust the audio levels.

Level Display

Displays the levels (left and right) of the live audio outputs.

Live Output Audio Level Control

Adjusts the audio level of the Final Mix audio output.

Final Mix Pane

Displays the levels (left and right) of the Final Mix audio outputs.

Final Mix Mute

Mutes the Final Mix audio output.

Headphone Mute

Toggles the monitor audio output in the headphones without effecting the Final Mix 
audio output.

Audio Playback Selection

Click the down arrow to select an audio playback device from the drop-down menu.

Audio Track Selection

Click the down arrow to select an audio track from the drop-down menu. For 
information about the assignment of audio channels to audio tracks see The Multi-Track 
Input Mapper.

Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out 
currently supports only two channels.

The Add FX (+) Drop-Down Menu
The Add FX (+) drop-down menu lists available sound effects, as follows:

De-ess

Thresh sets the threshold of de-essing. Freq selects the frequency at which de-essing 
will be applied to the audio. HF Drive adjusts the high frequency aspect of de-essing.
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Delay

L and R Delay adjusts how much delay on each channel. Feedback is how much delay is 
used. Fb Tone is a frequency setting of highs and lows to be delayed. FX Mix is how 
much delay will be added to audio output. Output sets the delay output level.

DubDelay

Opens the DubDelay dialog which allows you to set the parameters of DubDelay.

Dynamics

Thresh sets the threshold of engaging compression. Ratio sets the compression ratio. 
Output sets the compression level. Attack sets the manner in which compression is 
applied. Release sets how compression in released. Limiter sets a max output level on 
the audio. Gate controls (Thresh, Attack, and Release) sets the noise gate that cuts off 
noise at the set level. Mix adjusts how much compression is applied to the audio.

EQ

Low, medium, and high adjusts low, mid, and high frequency components in the audio.

Limiter

Thresh sets the minimum threshold of limiting in the audio. Output sets the amount of 
limiting used in the audio. Release sets the manner in which limiting is released as the 
audio decreases. Attack sets the manner in which limiting is applied. Knee adjusts the 
frequency and shape of point where limiting begins.

Loudness

Loudness adjusts the amount of loudness (raising high and low frequencies) in the 
audio. Output adjusts how much loudness is applied to the audio.

Multiband

Listen selects which part of the frequency spectrum to hear: low, mid, high, or all 
(output). L<>M adjusts the cutoff frequency in the low to mid range (87 to 1020 Hz). 
M<>H adjusts the cutoff frequency in the mid to high range (111 to 19606 Hz). L, M, 
and H Comp adjusts the compression for low, mid, and high frequencies. L, M, and H 
Out adjusts the output for low, mid, and high frequencies. Attack sets the manner in 
which compression is applied. Release sets the manner in which compression is 
released. Stereo adjusts how the left and right channels are separated (width) from 0 to 
200%. Process selects stereo or mono mode.

Noise Reduction

Amount sets the amount that noise reduction is applied.

The Output Settings Window
The Output Settings window enables you to customize the settings for a destination.

Destination List

Wirecast lists the last-used destinations in the left-side pane of the Output Settings 
window. 
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Add Button

When clicked, the Add button opens the Select an Output Destination dialog, enabling 
you to add destinations to the destination list.

Remove Button

When clicked, the Remove button opens the Select an Output Destination dialog, 
enabling you to remove destinations from the destination list.

Name

This is an editable field for the name of the output setting. By default, Wirecast names 
the setting for the destination selected.

Destination

This drop-down menu lists all the visible existing destinations. Each destination has its 
own broadcast technology preset, for example RTMP, or Windows Media.

See Multicast and Unicast Destination Settings.

More Button

This button opens a menu listing all existing destinations, with check boxes for making 
each destinations visible in the Destinations drop-down menu.

First Gear Icon

This drop-down menu lists actions available for the destination selected.

Encoding

This drop-down menu lists the available encoding presets. Each destination preset has 
its own encoding presets. The encoding presets define the codec, aspect ratio, and 
frame rate for each destination. Wirecast provides many encoding presets.

Second Gear Icon

This drop-down menu enables you to view the details for the preset selected, create a 
new preset, or filter the presets listed for the destination selected.

Audio Track Selection

This drop-down menu lists the audio tracks available for the destination selected.

Map Button

This button opens the Multi-Track Input Mapper for the destination and track selected.

See The Multi-Track Input Mapper.

Address

This editable field contains the network address for the destination selected.

Port

This editable field contains the port address for the destination selected.

Passphrase

This editable field contains the passphrase for the destination selected.
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Location

This field displays the host location for the destination selected.

See Destinations and The Encoder Presets Window.

Multicast and Unicast Destination Settings
You can select Multicast or Unicast from the Destination drop-down menu in the Output 
Settings dialog. Multicast lets you broadcast to multiple computers simultaneously. 
Unicast lets you broadcast to a specific computer.

During multicast, the broadcasting computer identifies each data stream individually. 
This enables recipients to choose between the available multicast streams.

The multicast protocol uses separate unique identifiers for video and for audio. These 
are not TCP/IP addresses, though they might look like TCP\IP addresses.

See The Output Settings Window.

The Multi-Track Input Mapper
 

The Multi-Track Input Mapper window enables you to determine the output audio 
channel destination for each of the audio tracks in a Wirecast document.

Source

Wirecast displays the filename of the audio source in the Source field.

Channel

Wirecast displays the output audio channels available in the Channel fields.

Track (1-8)

Wirecast displays checkboxes for each of the available audio tracks in the Track 
columns.

See Map, Mapping Audio Tracks to Output Audio Channels, and Mapping Audio Mixes to 
Playback Devices.

The Encoder Presets Window
The Encoder Presets window enables you to select a default encoder preset for your 
output, and to create your own custom presets.

Encoder Preset

This drop-down menu lists all default and custom encoder presets available.

Video Encoding

When checked, Wirecast enables you to customize the video encoding settings shown 
in the Video Encoding pane.

PRO
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Note: You should match the output to the canvas size as closely as possible to 
preserve video resolution and quality. For example, a 800x600 source results in 
significant loss of quality if an aspect ratio of 640x480 is selected for the output. 
Choosing an output of 720x576, which is much closer in size, helps preserve video 
quality.

Profile

Many encoder presets enable you to select one of three profiles: Baseline, Main, or High.

Baseline Profile (BP) Baseline profile is primarily for low-cost applications that require 
additional data loss robustness. This profile is used in some video conferencing and 
mobile applications. It includes all features supported in the Constrained Baseline 
Profile, plus three additional features used for loss robustness (or for other purposes 
such as low-delay multi-point video stream compositing). The importance of this 
profile has faded somewhat since the definition of the Constrained Baseline Profile in 
2009. All Constrained Baseline Profile bitstreams are also considered to be Baseline 
Profile bitstreams, since these two profiles share the same profile identifier code value.

Main Profile (MP) The Main profile is used for standard-definition digital TV broadcasts 
that use the MPEG-4 format as defined in the DVB standard. It is not, however, used for 
high-definition television broadcasts, since the importance of this profile faded when 
the High Profile was developed in 2004 for that application.

High Profile (HiP) The High profile is the primary profile used for broadcast and disc 
storage applications, particularly for high-definition television applications. For 
example, this profile is used by the Blu-ray Disc storage format and the DVB HDTV 
broadcast service.

Audio Encoding (AAC)

When checked, Wirecast enables you to customize the AAC audio encoding settings 
shown in the Audio Encoding pane.

See Encoder Presets and Encoder Presets.
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The Comment Moderation Window
Figure 20. The Comment Moderation Window, View comments pane

Descriptions of the controls in the Comment Moderation window follow.

Facebook, Twitter and YouTube logos

The colored ring around a logo indicates the status of the Wirecast connection to that 
platform, as follows:

Red

Not reading comments

Note: Until you start live streaming, Facebook and YouTube icons remain red.

Green

Connected and reading comments

Green with a yellow exclamation warning

Connected, but with a potential issue.

Turn off/on comments

Click the checkbox under any of the three platforms to turn off reading comments for 
that entire platform.
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Note: If you have more than one stream going to a platform (e.g. Facebook profile 
and Facebook group), this control turns off comments to all of the streams on that 
platform. There is not currently a way to turn off comments from individual streams to 
the same platform.

View Active Accounts

Click this to see which accounts you have authenticated, and what their status is. This 
opens the Active Accounts pane on the Comment Moderation dialog.

Figure 21. The Active Accounts Pane

• For Twitter:

– If the Account is authenticated and reading comments, the message will say 
Reading Comments

– If the Account is Authenticated, but you have unchecked it from the main 
Moderation window, it will say Offline

• For Facebook or YouTube:

– If the Account is Authenticated but you have not yet started streaming, or you 
have unchecked it from the main Moderation window it will say Offline

– If the account is authenticated and you are streaming, the message will say 
Reading Comments

• View Comments When clicked, Wirecast opens the View comments pane.

Add Facebook or YouTube Feed
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• Add Facebook or YouTube Feed When clicked, Wirecast opens the Select destination 
pane.

Search
Lets you search the text within comments

Rotate Selected Every XX Seconds

Check this option and all comments selected will rotate into the selected title and 
displayed. Click Unselect All to deselect any comments you have selected.

Comment panel

Comments appear as they come in from each selected platform. An asterisk “*” 
indicates the column can be sorted.

• Live The comments that are selected to rotate, if Rotate Every is selected, or the 
comment that is currently selected for live display

• Source The platform the comment came from

• Photo The photo of the commenter

• User Name The name of the commenter

• Comment The comment

• Time The time the comment was made on the platform

• Favorite To mark a comment as a favorite, click the star icon in the Favorite column 
for the comment.

Note: Colored rectangles showing amount paid appear in the Favorite column for 
super-chat comments.

When you click the Favorite header, Wirecast sorts the comments with super-chat 
comments at the top, followed by favorite comments, followed by the rest of the 
comments.

• See Social Media Shots, Moderating Social Media Comments, and Moderating Face-
book or YouTube Comments for a Streaming Computer or RTMP Server.

The PTZ Controller Panel
In this panel you can create a preset group of settings for each camera listed in the 
Camera drop-down menu. You can associate multiple presets for each camera. Also, 
you can switch between devices in the Camera drop-down menu.

Camera

This drop-down list shows cameras available to Wirecast. Selecting a camera updates 
the PTZ Controller window to display the preset VISCA and PTZ configuration for that 
camera. Once you establish a connection to a valid VISCA device, the PTZ Controller 
panel shows the camera's current Pan/Tilt orientation. Changing the Camera source 
changes all the settings in the panel accordingly.
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Note: A PTZ camera's VISCA configuration is discrete from the video feed. You can 
associate any available video source with any manually-entered VISCA device 
information. This accommodates a workflow where the camera's video feed is being 
captured via a Capture Card.

Protocol

Select a PTZ protocol from the drop-down menu.

IP Address

Enter the IP address of a valid VISCA-over-IP source on the network. This IP address is 
configured in your camera's network settings.

Port

Enter the IP port for the VISCA connection of the camera. This IP port is configured in 
your camera's network settings.

VISCA Address

Select the correct VISCA Address of the camera. This VISCA Address is configured in 
your camera's VISCA settings.

Status / Reconnect Button

Displays the current VISCA connection status (“connected” or “invalid source”) of your 
camera. Click the Reconnect button to force a reconnection.

Home Button

Click the House icon to reorient the PTZ camera to its default position (default centered, 
no zoom).

Pan/Tilt

Select the desired pan/tilt control method (Map, D Pad, or Analog Pad) from this drop-
down menu.

Figure 22. The Pan/Tilt Control

• Map – displays an X/Y plane with a yellow cross-hair representing the current Pan/
Tilt orientation of the camera
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Figure 23. The Pan/Tilt Control Map

• D-Pad – Pan the camera by clicking the left and right arrows, and tilt the camera by 
clicking the up and down arrows.

Figure 24. The D-Pad

• Analog Pad – Click in the analog circle to reposition the camera pan and tilt.

Figure 25. The Analog Pad

Zoom

Move the slider to adjust the zoom factor of your camera.

Note: When the PTZ Controller panel is the selected window, you can press the arrow 
keys on the keyboard to adjust the Pan (left and right arrow keys) and Tilt (up and 
down arrow keys) of the camera. Alternatively the W, A, S, and D keys can also be used 
(W = Up, A = Left, S = Down, D = Right)

Focus

Click the “+” Plus and “-” Minus buttons to adjust the focus of the camera. The yellow 
button in the center toggles auto-focus on and off. Any manual adjustments made to 
the focus will automatically disable the auto-focus.
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Exposure

Select the exposure mode from the Exposure drop-down menu.

• Shutter Move the slider to adjust the shutter of the camera. You can only adjust the 
Shutter when Exposure mode is not in auto-focus.

• Iris Move the slider to adjust the iris of the camera. You can only adjust the Iris 
when Exposure mode is not in auto-focus.

Note: Refer to PTZOptics documentation for more details about each mode.

White Balance

Select the white balance mode from the White Balance drop-down menu.

Note: Refer to PTZOptics documentation for more details about each White Balance 
mode.

One Shot

When the White Balance mode is set to One Shot, click this button to adjust the White 
Balance one time only.

Red Gain/Blue Gain

When not in auto-focus mode, you can use these sliders to adjust the red and blue gain 
of the video signal to compensate for white balance issues.

Presets

Enter a preset number and click Save to save current Pan, Tilt, and Zoom configurations 
of camera. To recall a preset, select a preset number by clicking the arrow buttons, then 
click the Recall button.

Note:  If you have Wirecast in the AutoLive mode, you must click the Live button to 
switch between presets on the same PTZ camera. This is a built-in safeguard against 
unintentionally moving the camera while in Live mode.

See Configuring The PTZ Controller, Opening the PTZ Controller Panel, and Controlling a 
PTZ Camera.

Menus and Application Keyboard Shortcuts
You can launch most Wirecast features from the items in the Wirecast menu bar. When a 
menu item is clicked, Wirecast opens a drop-down menu of features related to that 
menu item.

Also, you can launch most Wirecast features with application keyboard shortcuts. 
Application keyboard shortcuts are key combinations assigned to the Wirecast menu 
commands.
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Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

File Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

New

Creates a new, empty Wirecast document.

Open

Displays the Open dialog window for opening a Wirecast document.

Open Recent

Displays up to fifteen of the most recently accessed documents. Every time a document 
is opened or saved it is entered into this list.

Import Media

Enables you to import media into Wirecast. A new shot is automatically created using 
the new media.

Save

Saves the document. If the document has not already been saved, the Save As... dialog 
window is displayed.

Save As

Displays the Save As... dialog window so that the document can be saved using a new 
file name.

Close Window

Closes the currently active Wirecast window. If the window is a document, all of its Shot 
Editor windows are closed as well. If Wirecast is still broadcasting, you are asked to stop 
the broadcast. If the document has not been saved, you are asked to save the 
document before closing.

Preferences

Opens the Preferences dialog. If the Preferences dialog already is open, it becomes the 
active window.

See The Preferences Dialog Box, Customizing Wirecast with Preferences, and Resetting 
Preferences.

Exit

Closes all documents and then exits. If the broadcast is playing, you are asked to stop 
the broadcast. If a document has not been saved, you are asked to save the document 
before exiting.
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Always On Top

When checked, the Wirecast window remains active as the topmost open window on 
your system.

Edit Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Undo

Reverses your last change in Wirecast. Undo is only available in some windows (such as 
the Preview Area). Wirecast offers an unlimited number of undo actions (within 
computer memory limitations). Undo information is stored on a per-window basis. 
Also, if you close a window then reopen it, your undo information is lost. 

Redo

Reverses your last undo action. Redo is only available in some windows (such as the 
Preview Area). Wirecast offers an unlimited number of redo actions (within your 
computer’s memory limitations). Redo information is stored on a per-window basis. 
Also, if you close a window then reopen it, your redo information is lost.

Cut

Cuts selected text.

Copy

Copies selected text to clipboard.

Paste

Pastes selected text from clipboard to location of cursor.

Paste as new Consolidated Shot

Pastes selected shots into one consolidated shot. A consolidated shot is a shot created 
from multiple sources.

Select All

Selects all text in the active window.

Edit Shot

Opens the Shot Editor. You can also double-click a shot, or right-click and select Edit 
Shot, to open the Shot Editor.

See The Shot Editor Window. 

Rename Shot

Enables you to rename a shot. You can also right-click a shot and select Rename Shot.
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Duplicate Shot

Duplicates the currently selected shot. You can also right-click a shot and select 
Duplicate Shot.

Duplicate Shot Options

Check a source to create a new instance of it when duplicating the shot containing it. 
Multiple selection is allowed.

Delete Shot

Deletes the currently selected shot. You can also right-click a shot and select Delete 
Shot.

Move To Layer

Moves a shot to the selected layer. When shots are created, they are assigned to a 
specific layer. They exist on that layer until they are moved or deleted. You can also click 
and drag a shot to another layer.

Switch Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Go

Performs a transition (same action as clicking the Go button).

Transitions

Wirecast has up to three transition controls buttons that can be assigned any 
transitions (cut, smooth, etc.) that Wirecast supports. The Switch menu lists the 
currently assigned transitions by name. You can also select the Left, the Middle, and the 
Right transitions by pressing the control key and either the 1 or 2 key. Right-click on 
either transition to open the operation menu. Select how the transition will operate: 
Ease In, Ease In/Out Ease Out, Linear, or I.

To select which transitions appear in this menu, see Final Mix Audio Panel.

Transition Speed

Enables you to select one of five transition speeds ranging from Slowest to Fastest.

Manage Stinger Transitions

When clicked, Manage Stinger Transitions opens the Manage Stinger Transitions dialog. 
This enables you to import and use custom transitions that employ transparent 
backgrounds. These transitions are typically created using applications such as Adobe 
After Effects, Apple Motion or ScreenFlow.

See Importing Stinger Transitions.
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Figure 26. Add Transition and Remove Transition Controls
      

AutoLive

Toggles (turns on and off ) the AutoLive feature.

You may want to single-click a shot to make it become live. Alternatively, you may want 
to make several changes to a shot before making it live. You can use either method in 
Wirecast.

When enabled, the AutoLive feature lets you broadcast any shot with a single click. 
When AutoLive is enabled, Wirecast disables the Go button. Clicking a shot in a layer 
automatically places the shot in the Live Broadcast Area.

See Single-Click Switching with AutoLive and Go Button.

Live/Preview Swap

Toggles (turns on and off ) the Live/Preview Swap feature. When on, the Live Broadcast 
and Preview windows trade panes (swap) when the Go button is clicked.

Scrubber 

Play Preview

Remove Transition

Add Transition
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Layer Visibility

Click to open the menu and select a layer to hide or show in your shot. A check mark 
displays when the layer is visible. The shot icon becomes gray when not visible. You can 
toggle on and off the viability of each layer by pressing the Alt+1 through Alt+5 keys.

Disable PTZ Preset Recall

Enables/Disables PTZ preset recall.

See The PTZ Controller Panel.

Note: When you transition to a shot containing an animated title, Wirecast first 
executes the transition, and then performs the opening animation for the title. When 
you clear the title from the shot, Wirecast first performs the closing animation for the 
title, and then executes the transition for the end of the shot.

Media Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Start Playing All Movies

Starts playing any movies that are not currently playing.

Pause All Movies

Pauses all movies that are currently playing.

Shuffle Playlist

Randomly rearranges the order of media in the playlist.

Assign Placeholder

Opens the Assign Placeholder menu. 

Reset Placeholder

Opens the Reset Placeholder menu. 

Show Asset Manager

Displays devices that can be configured. Some devices (cameras, etc.) may be 
configurable. For example, you can configure a USB camera to manually change its 
focus, contrast, brightness, etc. Other devices have multiple inputs you can choose 
(AlchemyTV Card, etc.). 

See Remapping Media Locations.

Note: The Configure Devices menu selection is present only if a device is connected 
to Wirecast. The configuration user interface is provided by the device maker. It is 
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beyond the scope of this document to describe all of the features available for all 
devices. See the documentation provided with your device on how to configure it.

Output Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Output Settings

Opens the Output Settings window.

Start/Stop Broadcasting

Starts (or stops) broadcasting to the network. 

Start/Stop Recording

Starts (or stops) recording to disk. If you have not yet configured the Output Settings 
for this document, you are prompted to do so. 

Show Recordings

Opens all the folders of all the file directories in the Output Settings.

Multi-Viewer Output

Enables you to setup and use a Multi-Viewer display on and or all monitors. You can 
configure your displays, enable all displays, select a display to be active, or show (or 
hide) all displays when the application is in the background.

See External Display Outputs and Multiviewer/Secondary Live Output Button.

Configure Displays 

Select Configure Displays to open the configuration window.

Setup your Multi-Viewer by choosing a Monitor which determines where the Multi-
Viewer will display. Also select the Mode: Multi-viewer, Live Output, or Disabled 
(neither).

Select a Layout which determines how the Multi-Viewer will be displayed. The layout 
choices are: one, two, or four slots. In the Pro version ten or seventeen slots can also be 
selected. Each panel slot can then be mapped to any source: Preview, Live or any 
existing Shot in your document. Click inside a panel to select a source. Each Monitor is 
configured separately using the Configuration window. So, when you select a different 
monitor, the configuration panel (slots) also change. Additionally, all the monitors are 
automatically numbered. Clicking the Identify Displays button causes each of the 
monitors to display it number on it. 

You can also control how each panel is labeled by making a selection from the Labels 
menu:
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Draw Labels Below each Slot

Displays the label below each shot in each panel.

Superimpose Labels Over Each Shot

Displays the label over each shot in each panel.

Do Not Draw Labels

No labels are displayed.

Click on any slot panel to open the source menus, then select a source from the list to 
display it in the slot. Click Identify Display to cause the display number on each display 
to be shown.

Enable/Disable All Displays 

Select to hide or display all of your configured Multi-Viewed monitors.

Select a Display 

Select one of your configured Multi-Viewed monitors to hide or display. Shown below is 
a typically configured monitor with four slots. Audio meters are provided in each view.

Hide All Displays When App is in the Background

When selected, all Multi-Viewer Displays are hidden if Wirecast itself is put into the 
background or minimized. Turning this option off allows the Multi-Viewer outputs to 
stay on if Wirecast is put in the background or minimized

Note: Multi-Viewer displays can also be disabled by clicking on the Multi-Viewer 
display itself (on its target monitor), and then pressing the Escape (Esc) key.

Secondary Display Live Output

Sends the live program to a secondary device. For example, you can send a live 
program feed to another screen or to a capture card in an external device. If the 
external device has an UVC HDMI capture card, you can capture the live output from 
Wirecast for use in the applications--such as Zoom or Teams--on the other device.

You can use Secondary Display Live Output as an alternative to Virtual Camera/Mic.

You can map audio tracks, as well as video, to the secondary display.

See External Display Outputs and Multiviewer/Secondary Live Output Button.

Virtual Camera Out

Enables you to present the output of Wirecast as if it were a camera (a virtual camera), 
allowing it to be automatically detected by other applications when they are launched. 
Outputs only the Live Program feed. 

Active Broadcast

Once you have logged into your YouTube or Twitch account and you start streaming, 
you can select Active Broadcast to display the YouTube broadcast window in a browser.

PRO
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Control Room (YouTube only)

Once you have logged into your YouTube account, you can select Control Room to 
display the YouTube control room window in a browser.

Dashboard (Twitch Only) Once you have logged into your Twitch account, you can 
select Dashboard to display the Twitch dashboard window in a browser.

VOD of Last Broadcast Enables you to view the most recent completed broadcast.

Note: Active Broadcast is enabled only for Twitter-Live Broadcast and YouTube., 
Control Room and VOD of Last Broadcast are enabled only when you are logged into 
YouTube.

Facebook (Facebook Live Only)

Select Active Broadcast to display your Facebook Live event.

Twitter

Opens menu to monitor your Twitter broadcast.

• Active Broadcast Once you have logged into your Twitter account and you start 
streaming, you can select Active Broadcast to display the your broadcast window in 
a browser.

• Producer Dashboard Once you have logged into your Twitter account, you can 
select Producer Dashboard to display the Twitter dashboard window in a browser. In 
the dashboard you can start your broadcast by clicking the Go Live button. 

To stop your broadcast click the Stop Stream button.

• Toggle Broadcast Click to toggle between Go Live and Stop Broadcast on the 
Producer Dashboard.

Canvas Size

Sets the canvas size resolution used when broadcasting a Wirecast document.

Note: You should match the output to the canvas size as close as possible to preserve 
video resolution and quality. For example, a 800x600 source results in significant loss 
of quality if a resolution of 640x480 is selected. Using 720x576, which is much closer in 
size, helps preserve video quality.

Show Statistics

Displays the statistics window for your broadcast. You can select (for display): Bitrate, 
RTMP Queue Size, Framerate, System CPU Usage, and System Memory Usage.
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NDI Output

Sends the output of the Live Program feed. Select the output resolution for your NDI 
output. You can also select a link that will take you to NDI.NewTek.com for additional 
information.

Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out 
currently only supports two channels.

Blackmagic Cards

Note: If you are updating to Wirecast 14 (or a previous version) and have multiple 
capture cards that are different models, when you open a saved document that 
contains sources from the capture cards, one of the inputs may fail to upgrade (and 
will show their saved source.) To remedy this re-add the missing source back into the 
document, then open the Asset Manager and assign that newly added source to back 
into its saved shot.

You can use Blackmagic cards to send live feeds directly into editing, effects and 
broadcast design systems. In order to use this feature, install a Blackmagic card with 
associated drivers, then restart Wirecast. The Blackmagic card with then be listed in the 
Output menu.

Under the Output menu, select a Blackmagic card, and then select an HD setting for its 
output. If your card has multiple outputs, you can select more than one and all will 
output simultaneously at independent resolutions and Frame rates.

To begin outputting, select Start Output and chose a setting.

You can stop the Blackmagic card output by selecting Stop Output. If you have multiple 
outputs selected, they will all stop outputting.

Note: Some Blackmagic cards do allow input and output simultaneously, but need to 
be configured in the Blackmagic software.

PRO
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Layout Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

To optimize the user interface for each document, you can configure the Wirecast 
layout.

Wirecast enables you to select which functions are displayed in the default layout. 
These functions are added or removed from the default layout using the Layout menu.

Final Mix

When checked, displays the Final Mix Audio controls. Final Mix Audio controls are 
located on the left and right sides of the default layout.

Show Live and Preview

When checked, displays the Live and Preview windows, and allows you to select 
between displaying the Preview Area only, the Live Broadcast Area only, or both.

Show Preview Only

Displays the Preview Area only.

Show Live Only

Displays the Live Broadcast Area only.

Note: The three controls above work the same as the Mode Control buttons at the 
top-right of the default layout. See Layers.

Zoom Layers In

Increases the size of all the layer icons.

Zoom Layers Out

Decreases the size of all the layer icons.

Zoom Layers To

Sets the size of all the layer icons to: 50%,100%, or 200%. 

Note: You can also change each layer size by clicking and dragging the divider line 
between layers. Additionally, you can change the size of all layers by holding the Ctrl 
key while clicking and dragging the divider line between layers.

Go to Layer

Displays the selected layer. You can also press Ctrl + Shift keys with the T, F, N, B, or A 
keys to select a layer. Each of these letter keys represents a layer name: Title, 
Foreground, Normal, Background, and Audio.
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Replay + ISO Menu

 

Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Start All

Activates the Create Replay Shot system. When activated, the menu item becomes 
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.

Activate

Activates the Create Replay Shot system. When activated, the menu item becomes 
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.

Configure ISO Outputs 

Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an 
ISO output, click Configure, then click the Add ISO button.

Note: You can create ISO recordings of any source or shot in your document.

Replay Mark All

Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the 
beginning point of your Replay Shot capture.

Create All Replay Shots

Select Create to create additional Replay shots. 

Update All Replay Shots

If no replay shot exists, selecting Update creates a new Replay shot. There after, 
selecting Update updates the first Replay shot created.

Configure

Displays the Replay Shot settings window.

For more information about Replay Shots see Replay + ISO Menu. 

ISO enables you can set up ISO recording and do Replays from the same menu. To use 
Replay and ISO functionality, select the Replay + ISO menu.

Start All

Activates all configured ISO shots and/or the Program Replay.   When activated, the 
menu item becomes Stop All. Click Stop All to deactivate the Create Replay Shot system.

Program Replay

Allows you to Stop, Mark In, Create, or Update a relay shot.

PRO
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Replay Mark All

Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the 
beginning point of your Replay Shot capture.

 

Create All Replay Shots

Select Create to create additional Replay shots. 

 

Update All Replay Shots

If no replay shot exists, selecting Update creates a new Replay shot. There after, 
selecting Update updates the first Replay shot created.

 

Configure

Displays the Replay Shot settings window.

Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an 
ISO output, click Configure, then click the Add ISO button.

See Configuring Replay + ISO.

Social Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Two social media options are provided: Facebook and Twitter. Facebook enables you to 
receive polling data from viewers. Twitter enables you to add Twitter messages to your 
broadcast along with filtering the messages displayed.

Facebook
The Social > Facebook menu contains the Create New Poll option as well as a list of any 
previously-created polls.

See Creating a Facebook Poll in Wirecast and Selecting a Facebook Poll.

Twitter
Message Feed

Brings up your Twitter feed.

PRO

PRO

PRO

PRO
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Create Shot

Creates a shot with a social media title in Main Layer 1.

Settings

Brings up the Social Media Settings dialog.

Authenticate

Click to authenticate your account with Twitter. Enter your pin when the PIN field 
displays.

Feed Type

Select a Feed Type: Home Timeline, User Timeline, Favorites, Search. If you select 
Search, the Search String field becomes active.

Search String

Enter a search string. (Active only when Search is selected in Feed Type above.)

Comments
Opens a dialog listing comments about the broadcast that are posted to Facebook, 
Twitter, or YouTube.

Window Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Welcome to Wirecast

Displays the Welcome screen.

Encoder Presets

Opens the Encoder Presets window.

See Encoder Presets and The Encoder Presets Window.

Audio Mixer

Opens the Audio Mixer window.

See The Audio Mixer Window.

Audio Plugin Explorer

Opens the Audio Plugin Explorer dialog box.

See The Audio Mixer Window.
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PTZ Controller

 

Opens the PTZ Controller Panel.

Wirecast Pro allows you to remotely control cameras with built-in pan, tilt and zoom 
(PTZ) features using the built-in PTZ Controller window. This feature currently works 
with PTZOptics and Lumens cameras that support VISCA over IP control, as well as NDI 
PTZ protocol controls.

See The PTZ Controller Panel.

USB Devices

Opens a list of all USB devices.

Rendezvous Dashboard

Opens the Rendezvous Dashboard. Click Start Session to use.

See Rendezvous.

 

Rendezvous Audio Mixer

Displays the Advanced Rendezvous Audio Mixer window, which includes the following 
controls:

– Output from [document] Select document source from the pull-down menu.

– Channel Output level indicators for each channel.

– Include In Mix When checked, this audio source is included in your Rendezvous 
session.

– Audio Level (Sliders) Move the sliders to adjust the audio level.

See Opening the Advanced Rendezvous Audio Mixer.

Download Manager

Opens the Stock Media download monitor window. Whenever you add a Stock Media 
Library file, the downloading progress is displayed. You can cancel a download by 
clicking on the X icon. To navigate to the location of a downloaded file, click the 
spyglass icon.

Notifications

Opens the notifications window. This window displays last “important” log messages 
and other application health messages.

New Layer Window

Opens a new Main Layer window for the layer selected.

Document Windows

All open document windows are listed at the bottom of this menu.

PRO

PRO
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The Rendezvous Dashboard
Descriptions of the controls in the Rendezvous Dashboard follow.

See Starting a Rendezvous Session.

Figure 27. Guest Shot in Rendezvous Dashboard

Guest button

Local camera

Guest 
camera

Diagnostics

Audio output 
drop-down menu

Audio source drop-down menu
Video source drop-down menu

Disconnect/Reconnect 
to previous session 

Mute Audio

Mute Video
Settings

Open live 
chat



Windows, Controls, and Menus
Window Menu

194

Wirecast User Guide

Control Description

Video source drop-down menu Displays available video sources.

Audio source drop-down menu Displays available audio sources.

The Advanced menu item opens the 
Advanced Rendezvous Audio Mixer. See 
Rendezvous Audio Mixer.

Audio output drop-down menu Displays available audio output sources, 
such as speakers.

Start Session button When clicked, Wirecast starts a 
Rendezvous session.

Disconnect/Reconnect to previous 
session button

When clicked, Wirecast disconnects or re-
opens the previous Rendezvous session.

Diagnostics Displays bitrate, audio, and video data for 
the guest stream

Guest button

• Guest name

• “P” icon

When clicked, Wirecast adds the guest to 
the Rendezvous session, and to the 
Rendezvous Dashboard.
Wirecast displays a “P” icon to the right of 
a user’s name when the connection is 
“proxied” through the Wirecast TURN 
infrastructure, and traffic flows through 
Wirecast proxy servers. Data flows 
through Wirecast servers only if Wirecast 
can’t connect to the user’s server directly. 
This happens, typically, where there are 
restrictive firewalls. Otherwise, the traffic 
flows peer-to-peer, and there is no need 
to worry about Wirecast server capacity.
See also Wirecast Network Ports and 
Proxy Servers.


https://support.telestream.net/s/article/Wirecast-and-Proxy-Servers/

https://support.telestream.net/s/article/Wirecast-and-Proxy-Servers/

https://support.telestream.net/s/article/Wirecast-and-Proxy-Servers/
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The Rendezvous Guest Window
Descriptions of the controls in the Rendezvous guest window follow.

See Joining a Rendezvous Session as a Guest.

Mute Video When clicked, Wirecast turns off guest 
video.

Mute Audio When clicked, Wirecast mutes guest 
audio.

Settings When clicked, Wirecast opens a menu 
from which you can select:

• Assign Placeholder
• Toggle Network Statistics
• Disconnect (guest) from Rendezvous 

session

Control Description
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Figure 28. Rendezvous Guest Window in Browser

Control Description

Show chat Opens the chat panel.

Mute video Mutes Rendezvous video

Mute audio Mutes Rendezvous audio

Share screen Shares the guest screen to 
Rendezvous.

Settings Opens settings for 
microphone, camera, and 
other options.

Mute (guest) video Mutes Rendezvous guest 
video

Mute (guest) audio Mutes Rendezvous guest 
audio

Show chat
Mute video

Mute audio
Share screen

Settings

Mute (guest) video
Mute (guest) audio
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Help Menu
Note: To view a complete list of the default application keyboard shortcuts, see 
Finding an Application Shortcut.

Wirecast Help

Opens the online version of the User Guide.

Open Wirecast PDF User Guide

Opens the PDF version of the User Guide.

Open Tutorial HTML

Opens the Wirecast Tutorial in your browser. To follow the tutorial, you'll need to Create 
a Document for the Tutorial as well.

Create Document for Tutorial

Creates a new Wirecast Document which contains the media necessary for following 
the Tutorial.

Buy/Upgrade

Opens Licenses in the Preferences dialog. This window allows you to purchase licenses 
and to activate or deactivate them.

Provide Feedback

Opens the Telestream Website feedback page where you can enter any feedback you 
may have about our product or company.

Send Support Information

Opens a Support Assistant dialog window. To create a new support ticket, select Create 
a support ticket. The information is sent to the Telestream support team for evaluation. 
If you have been previously issued a case number, select Link with existing support case 
# and enter your case number. You can also select Do not receive follow-up from 
Telestream. This enables you to send support information to Telestream without 
receiving a response. Click Save Report to save the information to a file on your 
computer. Click Send Report to send the information to Telestream.

For troubleshooting purposes, you can reset your preferences to the defaults by 
clicking the Reset Preferences button. This will reset your preferences and create a 
backup of your current preferences, in case TS Support needs it.

For troubleshooting without resetting preferences, you can also open Wirecast in “Safe” 
mode using Shift + Control + Open.

Note: You must click Send Report to create a ticket. If you click Save Report, a ticket will 
not be created.

Open Scripting Documentation Opens the Wirecast Scripting Help document.
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Show Scripting Examples Opens the directory where the Wirecast Scripting examples 
are located.

Visit Telestream LLC Website

Opens the Telestream Website home page.

Visit Wirecast / Desktop Presenter download page

Opens the Telestream Website download page for Desktop Presenter.

Acknowledgments

Opens an on-line help to Acknowledgments.

About Wirecast

Opens a dialog box that gives the Wirecast version number and copyright information.
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Tutorials

The best way to learn Wirecast is to work quickly through all its main features. These 
three tutorials introduce Wirecast features, and show how to create and broadcast 
presentations.

As you work through these tutorials, you become familiar with important Wirecast 
concepts. The better you understand how to use Wirecast, the better it serves your 
broadcasting objectives.

Because each tutorial builds on the skills and knowledge you learn in the previous 
tutorials, take the tutorials in order. Working through all the tutorials takes about thirty 
minutes.

Note: If you work through the tutorials before activating a Wirecast license, or with 
Wirecast in demonstration mode, Wirecast periodically superimposes a logo 
watermark over the video, and a voice-over watermark over the audio.

Note: For licensing information, select File> Preferences > License. Click Purchase, or, 
contact Telestream at: desktopsales@telestream.net.

Topics
■Tutorial 1: Basic Concepts 200

■Tutorial 2: Editing Shots 204

■Tutorial 3: Broadcasting 205

Tutorial 1: Basic Concepts
This tutorial guides you through creating and streaming a presentation.

Tutorial Prep
To prepare for this tutorial, do the following:

1. Select Help > Create Document for Tutorial.

2. Select Switch > Smooth.
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3. Select Switch > AutoLive.

4. De-select Switch > Live/Preview Swap.

5. Select Layout > Show Live Only.

Wirecast displays the Live Broadcast Area, and the Go button with the red AutoLive 
LED turned on. You change all of these options during the tutorial.

The Wirecast Default Layout
To familiarize yourself with the main windows, controls, and menus of Wirecast, see The 
Default Layout.

What Is a Shot?
Wirecast uses the concept of a “shot” to construct presentations. A shot contains one or 
more media sources or files, along with settings for the sources and files. A shot 
contains at least one media file, such as a photo or a video clip. However, a shot can 
contain a number of sources and files, such as a live camera, a title, and background 
music. A shot can even include a whole playlist of clips.

You can assemble most of the files and sources for your broadcast in shots, before you 
start broadcasting. Also, you can edit a shot and change its settings.

See Tutorial 2: Editing Shots.

Switching Between Shots
Individual shots are displayed in the Layers. The Transition Controls are located just 
below the Live Broadcast Area where the two default transitions are shown: Cut and 
Smooth.

Replacing a shot in the Live Broadcast Area with a shot in the Preview Area is called 
“taking a shot live.”

See Layers and Final Mix Audio Panel.

1. With the second Transition Controls button labeled Smooth and highlighted, click 
the Ripples shot in the third layer.

The Ripples image fades in on the Live Broadcast Area. The Smooth fade action 
occurred when you clicked on Ripples. This is because the Smooth fade is the transi-
tion selected.

2. Click a shot labeled Clear Layer.

The Ripples image fades to black. The Clear Layer shot enables you to display black 
video.

Note: Wirecast doesn’t support a true dissolve transition. The Smooth fade transition 
is the transition closest to a dissolve.
If you switch from shot “A” to a shot that contains shot “A,” the Smooth fade 
interpolates the difference between the two shots and animates the changes. This 
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makes a shot element larger or smaller, and changes its position as needed.
However, if you switch from shot “A” to an entirely different shot “B,” then the Smooth 
transition simply fades between the two shots.

3. To make the cut your default transition, drag down across the first Transition 
Controls button and select the Cut control.

4. Click the Ripples shot in the third layer.

The Ripples image cuts in on the Live Broadcast Area.

When you select Cut as the default transition, switching from shot “A” to shot “B” simply 
cuts from the first shot to the second. When Smooth is selected, transitions fade in and 
out.

Transitions
To select a different transition, click the small arrow on the right side of any of the 
Transition Controls buttons, or drag the mouse downward to display the menu of 
transitions. When the list of transitions appears, select a transition to assign to that 
button.

1. To change the left Transition Controls button from Cut to Bands, click the Cut button 
and drag downward until the menu appears. Select Bands from the menu. The left 
Transition Controls button is now labeled Bands.

2. Now click back and forth between the River and Ripples shots using Bands.

You can use these keyboard shortcuts for the two default transition buttons: Ctrl+1 
and Ctrl+2.

Note: Wirecast displays as many as three Transition Controls buttons. To set the 
number of transition buttons that Wirecast displays, select Preferences > General.

See The Default Layout and Final Mix Audio Panel.

Transition Speed
To determine how fast a transition occurs, do the following:

1. Select Switch >Transition Speed.

2. Choose a transition speed, from Slowest to Fastest.

Layers 

Note: Before you start this section, select Smooth as your default transition.

You can display several shots in the Preview Area and Live Broadcast Area at the same 
time by placing them in layers, one above another.
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To broadcast a layered shot, do the following:

1. Select the Logo shot in layer 2.

2. Select the River shot in layer 3.

The Live Broadcast Area displays a layered shot containing both images.

See Layers.

Auto Live
So far in this tutorial, Wirecast has been running in AutoLive mode. Wirecast sends any 
shot you select in a layer automatically to the Live Broadcast Area. This mode is very 
useful for those users who want to set up all of their shots at once and then single-click 
shots as they run their presentation.

The disadvantage of this single-click method is that you can’t preview the shot before 
taking it live.

Turning AutoLive Off
A red LED, next to the Go button is lit when you are in AutoLive mode.

See Final Mix Audio Panel.

1. For this tutorial, turn off AutoLive. Select Switch, and deselect AutoLive.

A dialog box informs you that AutoLive is off.

2. Click OK in the dialog box to continue.

3. Click the Ripples shot.

Notice that Wirecast doesn’t send Ripples to the Live Broadcast Area. That is because 
AutoLive is turned off.

4. Now, click the Ripples shot, and then click the Go button.

Wirecast sends the Ripples shot to the Live Broadcast Area.

Note: When AutoLive is off, you must click the Go button (or press Ctrl+G) to display 
the selected shot in the Live Broadcast Area.

Multiple Changes
A benefit of having AutoLive off is that you can make several changes to your shot first, 
and then have all changes sent to the Live Broadcast Area at the same time.

Do the following:

1. Verify that AutoLive is off.

2. Click Sample Title in Layer 1.

3. Click Clear Layer Shot in Layer 2, and then click the Ripples Shot in Layer 3.
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4. Click the Go button (or Ctrl+G)

Wirecast takes the Ripples and Sample Title shots live at the same time.

Preview 
One problem you may have noticed is that you can’t see the changes you are making 
before broadcasting them. To solve this problem, Wirecast enables you to see a preview 
of what you broadcast.

1. Select Layout > Show Live and Preview.

Wirecast displays the Preview Area to the left of the Live Broadcast Area. The Preview 
Area uses a green LED to identify it. The Live Broadcast Area uses a red LED to iden-
tify it. Wirecast also displays green and red LEDs to identify which shots are associ-
ated with the Preview or Live areas.

2. Click the River shot on Layer 3.

Wirecast displays the River shot in the Preview Area. When shots are selected they 
display a green or red LED to indicate selection for Preview Area or Live Broadcast 
Area.

3. To send the River shot to the Live Broadcast Area, click the Go button.

4. To remove the title from the River shot in the Preview Area, click the Clear Layer shot 
in Layer 1.

5. Turn on the Live/Preview Swap option by selecting Switch > Live/Preview Swap 
(check mark displayed). Notice that the Go button displays a double-arrow, 
indicating that the Live/Preview Swap option is on.

See the Go button on the screenshot in The Default Layout.

6. Select the Ripples shot and click the Go button to send the Ripples shot to the Live 
Broadcast Area.

Notice that the Ripples and River shots have swapped areas. Also, the shot LEDs 
have changed color. The green shot LEDs indicate shots included in the Preview 
Area and the red LEDs indicate the shots included in the Live Broadcast Area. You 
can view the shot that is live in the Live Broadcast Area as you prepare your next 
shot in the Preview Area.

Tutorial 2: Editing Shots
The first tutorial explained various ways in which you can use existing shots. However, 
you can also create and edit shots during a broadcast. This tutorial demonstrates how 
to edit your shots.

1. To edit a shot, double-click its icon in a layer.

Wirecast opens the Shot Editor panel. The Shot Editor has six tabs: Shot Layers, Shot 
Layer Properties, Audio, Chroma Key Properties, Smooth Transition Properties, and 
Additional Source Properties.

See The Shot Editor Window.
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2. Practice editing a shot using the various options in the Shot Editor Window tabs.

Tutorial 3: Broadcasting
This tutorial demonstrates how to set up and broadcast your Wirecast presentations. 
You can broadcast to a specific computer (Unicast), multiple viewers (Multicast), or 
even record your broadcast to disk.

There are two main components for broadcasting your presentation (or saving it to 
disk): encoding and selecting a destination.

First, decide how to encode your broadcast. Encoding is the type of compression used 
(JPEG, MPEG4, etc.). Wirecast comes configured with many common encoding options.

See The Encoder Presets Window for details.

You must select a destination for the broadcast. You can send the broadcast to a server 
or save it to disk.

Streaming
1. To start streaming, click the Output Settings button.

See the Output Settings button on the screenshot in The Default Layout.

Wirecast opens the Select an Output Destination dialog.

2. Select a destination, and click OK.

3. Select the output settings desired, and click OK.

Note: In the Control/Status bar, the Output Settings icon blinks until a connection is 
made. Once you are connected the Output Settings icon turns green. If you can’t 
connect, Wirecast displays an error message.
See Control/Status Bar.

Note: While streaming, the streaming status is displayed at the top of the default 
layout. Connection strength is indicated by how many bars are displayed in the Output 
Settings icon. Fewer bars indicates a weaker (slower) connection. If you are streaming 
to Facebook, additional statuses are displayed on the right side of the status bar.
See Streaming Status Colors.

4. Click the Record button.

See the Record button on the screenshot in The Default Layout.

5. To stop streaming or stop recording, click Record again.
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Making Great Broadcasts

When you save video to disk or transmit it, you must compress the video. Encoder-
decoders (codecs) do the work, and codecs work best with clean input data. If the audio 
or video is muddy to start with, it remains muddy after compression. Some codecs may 
even exaggerate the imperfections of poor inputs.

Your goal is to send the best quality video and audio to the codecs. Make sure what you 
see and hear in the Live Broadcast Area is high-quality video and audio.

There are many ways to make a good live event even better, and to deliver clean data to 
the codecs. This appendix focuses on three of the main concerns.

High Quality Audio Input

Great-looking video with poor audio is poor video.

Good Lighting

Video without light is radio. Poor lighting can ruin an otherwise excellent live event. If 
you use chroma key or luma key, excellent lighting of talent and background is 
essential.

Broadcast Settings

For best results, optimize your broadcast settings.

Topics
■ High Quality Audio

■ Good Lighting

■ Broadcast Settings

High Quality Audio
You can make a good live event even better by paying attention to audio details. Here 
are some suggestions:

• Use an External Microphone Most video cameras have an audio input for an 
external microphone. Use this, whenever possible, instead of the built-in micro-
phone. Built-in microphones usually are not high quality, and they tend to pick up 
hum from the electronics inside the camera. Even an average external microphone 
can deliver better sound than most built-in camera mics.

• Use a Microphone Splitter or Mixer If the broadcast has more than one sound 
source, use a separate mic for each sound source. Give each speaking subject a 
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dedicated mic. Connect the mics to a mic splitter or audio mixer. Connect the out-
put of the splitter or mixer to the camera audio input.

• Position the Microphone Properly Place any microphone as close to the sound 
source as possible, even when using omni-directional microphones, because sound 
volume decreases greatly the farther away the microphone is placed. High-volume 
sound hitting the microphone results in a stronger signal from the mic.

• Use Lapel Microphones Even inexpensive lapel microphones can make a huge dif-
ference because you can place them close to the source of the sound: the speaker’s 
mouth.

• Control Environmental Noise If a chair squeaks, use a different chair. If you have a 
wood floor and you can hear people shuffling their feet, put down a rug. Turn off air 
conditioners, machines, and buzzing fluorescent lights. Do whatever it takes to 
keep noise at a minimum. Microphones pick up everything. Before you start broad-
casting, yell, “Quiet on the set!”

Good Lighting
Do not underestimate the power of lighting. Whether shooting outdoors or indoors, 
you must control the light that hits the lens. For a good picture and a high-quality video 
signal, you must provide your lens two things: enough light and light with the right 
qualities. Here are a few suggestions for good lighting:

• If you use only one light source, don’t shine it directly on your subject. Diffuse the 
light by bouncing it off the ceiling, or by shining it through translucent material.

• Avoid deep shadows. Make sure you fill all areas of your subject with light. Some-
times this requires adjusting the light to bounce off a different wall. Alternatively, 
use two lamps. To light evenly, you can place one lamp low and another high.

• Allow soft shadows. Do not light too evenly. Good lighting usually has the brightest 
lamp above and to one side of the lens, aimed at the subject.

• If you pour too much light on your subjects, they will look washed out. If your light-
ing balance is excellent, you can avoid using much make-up on your subjects.

• Watch professional broadcasts and learn from them. As you watch, notice the light-
ing. Notice how directors employ the suggestions listed above.

Good lighting can make an amateur video look professional and a professional video 
look fabulous. One or two properly-placed lamps or reflectors can make a huge 
difference in the visual quality of your broadcast.

Triangular Lighting
One advanced and very effective approach to good lighting is known as triangular 
lighting (or three-point lighting, or the three-light setup). This involves setting up three 
lamps (sometimes using the Sun as one of the light sources), in a configuration that 
achieves a good balance. Here are the main elements of triangular lighting:
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• Key Light (Main Light) This is the strongest of your lights and does most of the 
work. You can use the Sun or a strong lamp as your key light. Place the key light 
higher than talent eye-level, higher than the lens, and to the left or right of the lens. 
at least 20 degrees off the line between lens and talent. This creates shadows on 
the subject that enhance the sense of three-dimensionality.

• Fill Light This is a soft light. Place the fill light higher than talent eye-level, higher 
than the lens, and on the side of the lens opposite the key light. If your key light 
comes from the left of your camera, your fill light should come from the right, or 
vice versa. The fill light brightens the shadows, making them softer and less severe.

• Back Light (Rim Light) This light is directed from behind and above the subject. 
Aim the back light at the top of the subject’s head. The back light is also called a rim 
light because it makes a slight rim around the edge of the head of your subject. The 
back light separates your subject from the back ground. This enhances the sense of 
three-dimensionality and helps create a sharp separation between the subject and 
a chroma-key background. Since the back light faces the lens, make sure light from 
the back light does not spill into the lens, causing lens flares.

Broadcast Settings 
Once you have good video and audio coming into Wirecast, make sure the broadcast 
settings are configured correctly for your presentation. Though there are many 
broadcast parameters to modify, there are three that are the most important: 
bandwidth, motion, and encoder settings.

Bandwidth
Bandwidth is the speed of data you can broadcast from your computer to your viewers. 
Transmit data no faster than your network upload speed and your viewers’ download 
speed.

Estimate your viewers’ download speed by the type of Internet connection they likely 
have. Are your viewers all on your corporate high-speed LAN, are they viewing from 
home via DSL or cable Internet, or are they on cell phones in remote areas downloading 
video over slow cell phone networks? Set your broadcasting bandwidth accordingly.

If you broadcast to a LAN, discuss your plans with your network administrator. Verify 
that you will not disrupt the network with your broadcasts. Ask the administrator what 
your bandwidth upper limit should be.

Motion
Once you determine your bandwidth, determine whether your video contains a lot of 
motion. An interview typically has little motion. A sports event, however, typically has 
lots of motion. Wirecast comes configured with defaults to help ease your 
configuration task. Choose a default configuration that meets your motion constraints.



Making Great Broadcasts
Broadcast Settings

209

Wirecast User Guide

Encoder Settings
It is beyond the scope of this document to describe the delicate balance required in 
defining encoder settings. Various streaming networks publish their optimal encoder 
settings. The Wirecast settings for the various streaming platforms generally are 
optimized for those platforms.

See The Encoder Presets Window for information on changing the encoder settings.
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■ Steinberg VST Plug-In SDK Licensing Agreement (Version 3.6.6- 17.06.2016)

■ MIT

■ TurboJPEG

Steinberg VST Plug-In SDK Licensing Agreement 
(Version 3.6.6- 17.06.2016)

VST is a registered trademark of Steinberg Media Technologies GmbH.

MIT
Copyright (c) 2018 Telestream, LLC

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the “Software”), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, merge, 
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons 
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or 
substantial portions of the Software.
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THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL 
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR 
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 
OTHER DEALINGS IN THE SOFTWARE.

TurboJPEG
This software is based in part on the work of the Independent JPEG Group.

Copyright (C)2009-2019 D. R. Commander. All Rights Reserved.

Copyright (C)2015 Viktor Szathmáry. All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

• Redistributions of source code must retain the above copyright notice,   this list of 
conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright notice,   this list 
of conditions and the following disclaimer in the documentation   and/or other 
materials provided with the distribution.

• Neither the name of the libjpeg-turbo Project nor the names of its   contributors 
may be used to endorse or promote products derived from this   software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS”, AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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